Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: "No DLL were found in the Waterfall procedure" Finally SOLVED.

30 Jan 2015   #31

Windows 7 64 bit

I too downloaded the dll 'ippsw7-6.1.dll' and it did not correct my problem; however I followed aaroux's work-round and that fixed it for me. I had previously installed the GoPro studio and since upgraded it to 2.0 so it may have removed something during the upgrade. Thank you for a good fix!

If this occurs the solution is to browse to: C:\Windows\SysWOW64 and then remove these files:
  1. ippcore-6.1
  2. ippj-6.1
  3. ippjw7-6 .. 1
  4. IPPS-6.1
  5. ippvc-6.1

My System SpecsSystem Spec
30 Jan 2015   #32

Windows 7 Professional SP1 64 bit

Quote   Quote: Originally Posted by lmicklus View Post
Thanks for the tip that lead me to the final solution. The error is caused because GoPro CineForm Studion version 121 removes ippsw7-6.1.dll from the operating system. The solution is to place ippsw7-6.1.dll in the directory


The attached file No DLLs in Waterfall contains the missing ippsw7-6.1.dll.
Much thanks for the solution AND the download. Still solving folks problems after all this time. You sir, are one of the heroes of the internets. Blue skies.
My System SpecsSystem Spec
02 Feb 2015   #33

windows 7 home premium

It worked perfectly for me having caused it by un-installing the GoPro suite.
Many thanks
My System SpecsSystem Spec

17 Feb 2015   #34

windows 7 home 64

For my we cam HP allinone worked this method
If this occurs the solution is to browse to: C:\Windows\SysWOW64 and then remove these files:
ippjw7-6 .. 1

My System SpecsSystem Spec
15 May 2015   #35

Windows 7 Ultimate x64

Just signed up to the forum to say thanks for this thread and to those who posted info. I recently installed GoPro Studio and the Cineform video codec with it on my Windows 7 Ultimate x64 desktop which prevented my previously working Cyberlink Power2Go 7 app from starting up and after first making some tweaks to Power2Go's startup procedure that I found in another forum and then following the instructions here to fix the secondary error of "No DLL were found in the waterfall procedure" I got Power2Go working again.
My System SpecsSystem Spec
21 May 2015   #36

windows 7 pro, x64

I have a MicroTek Scanner (DI 6240). I got those DLL messages and found the solution here. However, I can't find the actual solution. I'd like to quote the solution and send it to Microtek at

Lots of thanks to those who found the solution. I happened to stumble on this site. I believe the changes involved using someone's patch and deleting a few programs in the window directory.
My System SpecsSystem Spec
01 Jun 2015   #37

Windows 7 Ultimate x64

Thank you so much! Adding, combined with deleting the DLL's as mentioned finally gave me my webcam back!
My System SpecsSystem Spec
29 Jun 2015   #38


Quote   Quote: Originally Posted by aaroux View Post
The above did not work by itself, but doing this in addition did:

Note: I suggest you do not outright delete the DLLs below but save them somewhere just in case.

In some cases after installing GoPro Studio, other applications may report an error that states: "Error at loading if ippSP library - No DLLS were Found in the Waterfall procedure".

If this occurs the solution is to browse to: C:\Windows\SysWOW64 and then remove these files:
  1. ippcore-6.1
  2. ippj-6.1
  3. ippjw7-6 .. 1
  4. IPPS-6.1
  5. ippvc-6.1
Bravo! Bravo!
My System SpecsSystem Spec
13 Aug 2015   #39

windows 7 home premium 64bit

Hi guys, just called in to say that adveleksa's fix worked for me. my client had uninstalled go pro studio 2.5.6 and it knocked edius off. He reinstalled the program without success. I tried the d/l without success so moved the 5 drivers to a folder on the desktop and it worked immediately,

thanks very much, spot on and I hope it helps someone else :)
My System SpecsSystem Spec
23 Oct 2015   #40

Windows 7 Home Premium 32bit

You can do it manually a few videos on youtube have the solution to this

Go to ;My Computer--Local disk:C--Windows---system 32 or syswow64
depending on the Windows version and remove the fallowing;
ippjw7- 6.1.dll
My System SpecsSystem Spec

 "No DLL were found in the Waterfall procedure" Finally SOLVED.

Thread Tools

Similar help and support threads
Thread Forum
"Procedure entry point OpenSemaphoreW...api-ms-win-core-synch-l1-2-0"
When I open up programs like FL Studio or LightShot, I get this error message. I tried cleaning out the registry, doing a SFC scan but no avail.
Samsung SSD - "A disk read error occured Press ctl alt del - SOLVED"
Hello, I encountered a problem and found a solution and just wanted to put it on the internet for posterity. So I have a Samsung SSD 850 EVO. I'm actually running Vista 64 Ultimate but ran across a relevant thread about this seemingly hardware issue here, so.... I started with a fresh...
Performance & Maintenance
When I click "install now", it's saying "No device drivers were found"
Ok, now I get another problem... When I click "install now", I get a msg box that is saying 'no device drivers were found. Make sure that the installation media contains the correct drivers, and then click OK' What should I do now?
Installation & Setup
Visual Studio 2008 Pro SP1: Error spawning "rc.exe" finally FIXED!
Hi All, This is my first VS2008 installation and I bumped to this error. Wasting much time googling the net showed bunch of lame solutions like "reboot pc, reinstall windows and etc..." I thought it is W7's incompatibility, however the problem is easily solved by adding additional component...
BSOD after "Remote procedure call failed and did not execute"
-Windows Home Premium x64 -Windows Vista initially installed; Dell provided a windows 7 Installation CD once it came out. Hardware was bought ~December 2009. Installed Windows 7 once in 2010 and once earlier this year. When I tried to make the System Health Report, it came up with "The...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:04.
Twitter Facebook Google+