Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: wmplayer process "resurrects" itself and hogs 50% CPU

27 Jan 2009   #1

Windows 7
wmplayer process "resurrects" itself and hogs 50% CPU

An interesting problem certainly.

I've had issues with WMP not exiting properly and having to kill the process by hand, but this takes it to a new low. I exit, and i started to notice that firefox stopped working - frozen. I discovered that it was because the media player process was running in the background and was taking up so much processing power that firefox was lagging.

I've tried ending the process, ending the process tree, disabling the WMP network service, restarting. I don't want to reinstall because i don't think it would do much good. I don't think it's a codec issue either, that usually just keeps the process running - but it doesn't make the process start up straight away again.

After a while sometimes i can just close it, but it's not a good workaround.

Any ideas?

My System SpecsSystem Spec
03 Jun 2009   #2

Windows 7 Build 7600

After reading a lot of forum posts and tinkering with the problem ... I think I've found the solution. I *JUST* fixed the problem literally a few minutes ago ... so I'm eager to help others. Hopefully I didn't jump the gun and THINK I solved it when I didn't.

Most people got the problem solved by going into the Sync Center and turning off the sync to devices. So if this helps you, then yay.

I had no devices in there. So that didn't work for me.

For me, the problem was in Side Show. (I have the Logitech G15 keyboard). So under Control Panel->Windows Sideshow, I unchecked the boxes next to Windows Media Player.
My System SpecsSystem Spec
24 Oct 2009   #3

Win XP Pro/Win 7 Pro

Thank you for the fix! I created this account just to tell you that you're awesome.
My System SpecsSystem Spec

24 Oct 2009   #4

Windows 7 Build 7600

Heh, no problem. If you noticed, that was my FIRST post. I also created that account JUST to let everyone know how I fixed it. Just in case some random person wanted to google up how to fix the problem. Because I remember being so glad to figure out what on earth was going on. :P
My System SpecsSystem Spec
06 Jan 2010   #5
The Carnage

Windows 7 Pro 64bit

@ Nestea80, you are a god... For i am that random googleing person, i also have a G15 and the wmp process never closing was staring to get on my nerves. I often make movies on sony vegas and alternate looking at clips in wmp and editing them and since i installed win7 the 2 programs have been clashing when wmp refuses to get go of the file when i close it, forcing me to end the process in task manager. Unticking the g15 slide show boxs worked like a charm, so thanx for posting.
My System SpecsSystem Spec
23 Feb 2010   #6

win7 64 bit uk home pro

Same here, allso a random google searching dude.
Whiternoise your Epic, thanks for your input.
My System SpecsSystem Spec
21 Mar 2010   #7


nestea80 & Whiternoise, thank you very much, Like others, I just created account to thank you!
My System SpecsSystem Spec
08 Aug 2010   #8

win7 x64

I've had to look up this issue at least twice now with new system installs, and it is still spot on. I have no idea why this has not been fixed. so many people I am sure have this problem yet have no idea how to fix it.

I am running Win7 x64 and use a Logitech g15 keyboard. I also found that wmplayer.exe kept coming on as an unkillable process and hogging resources.

As suggested, Windows Sideshow and the Logitech software was the issue. To solve this open the 'Logitech LCD manager' from your start menu. Go to Programs and then select the Windows Sideshow line (Monochrome of color, it doesn't matter). Then select 'configure' and then unselect the two options.
Alternative, the system URL to get here was 'Control Panel\Hardware and Sound\Windows SideShow', so you might copy and paste that in your system folder/directory (e.g. open any folder and just copy/paste in the path/URL bar).

I registered and did a write-up just to add a few more keywords in hopes others looking for a solution can find this as well.
My System SpecsSystem Spec
14 Aug 2010   #9

windows 7

nestea you are the king!

I too am running Windows 7 x64 and use a Logitech g15 keyboard. I also found that wmplayer.exe kept coming on as an unkillable process and hogging resources.

logitech get your act together!!
My System SpecsSystem Spec
07 Nov 2010   #10

ultimate 64 bit

you are an absolute legend, same problem with the g15,
My System SpecsSystem Spec

 wmplayer process "resurrects" itself and hogs 50% CPU

Thread Tools

Similar help and support threads
Thread Forum
When process "Explorer.exe" is ended or restart pc, stop error
when the process explorer.exe or windows explorer is ended (i usually do that while watching movies or videos VLC) i get the stop error and it says dumping memory on the bottom, and it has white text. any other process that is ended is good, and restarting does the stop error aswell. this start...
BSOD Help and Support
"Error opening process" message in Process Explorer
Hi Everyone I recently did a System Restore on a Windows 7 Pro 64 bit system to correct a strange problem I was having with IE. It seems to have solved the problem, but now Process Explorer is displaying the messages in the screen shot below, and I'm not sure why. The computer is functioning...
"Server execution failed" with wmplayer
Trying to fix my brothers laptop. He is unable to open windows media player, the message saying "server execution failed" Also, wmplayer*32 is always running in the background, even after ending the process in task manager.
Music, Pictures & Video
Problem launching game - "Unable to terminate process" may be related
Hey guys, I'm hoping you can help me find a solution to this problem that doesn't involve doing another clean install of Windows 7, so here we go. I've been playing a game called Silk Road Online on and off on my laptop, and suddenly one day (maybe after windows updates, I'm not sure) when I...
Eject hardware showing "Windows host process"
My external HD will not eject. In Vista it ejects fine. I west to customize the tray icons and saw this. The eject button listed as "Windows Host Process" What is up with this and is this why it will not eject? I have never seen this before and wonder if it's correct or a bug. I went back a few...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:03.
Twitter Facebook Google+