Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows installer service error 1719

06 Sep 2013   #1

windows 7 64 bit
Windows installer service error 1719

Hi all, I have been experiencing the windows installer service error 1719 for a few months now everytime i try to install a program. I cant even properly update my windows 7 updates anymore. Each time i try updating, almost all of the updates would show me "update failed" when I restart. This is getting very frustrating. I have googled and tried many suggested solutions such as using regedit from error 1719 windows installer service could not be accessed .... - Microsoft Community

Nothing has been working so far though. However, I am suspecting that it might be due to me adding a new hard disk a few months before. My old hard disk was failing (at startup they told me its health was poor) and so i added a new one. I am a total newbie at installing the hard disk and i made it replace the old hdd as the main hard disk. I am not entirely sure that i did it smoothlessly and might have screwed up some stuff along the way leading to the error 1719. I am considering doing a clean install but im not sure how to go about doing it since there are two hard disks. Im not even sure if it will solve the problem after all the effort.

Can anyone please give me some advice? I will be very grateful even if it doesnt help. Thanks guys!

My System SpecsSystem Spec
07 Sep 2013   #2
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

Let's start by confirming the Installer service is set correctly

Start> In search box type services.msc> Enter> Confirm the Windows installer service is set to automatic, and started

Now confirm the Dependencies are also set correctly

Start> In search box type services.msc> Enter> Confirm the Dependencies in this screenshot are all set to Automatic, and Started

If not, change them to Automatic, and Start them and try a MSI again.

If they are all set correctly, or no change, lets try these commands

Start> In search box type cmd> Right click on cmd.exe in results above and choose Run as administrator> When the command prompt opens, type

%windir%\system32\msiexec.exe /unregister


%windir%\syswow64\msiexec.exe /unregister


%windir%\system32\msiexec.exe /regserver


%windir%\syswow64\msiexec.exe /regserver


Restart your PC and test again

If no help, try to re-register the MSI service

Windows key + R> In the run box type net start MSIServer> Enter

If no success, try the above again, but in Safe Mode

A Guy
My System SpecsSystem Spec

 Windows installer service error 1719

Thread Tools

Similar help and support threads
Thread Forum
Windows installer Error 1719
Hi everyone. I've been trying to install pinnacle's "Dazzle" usb video capture device driver (model DVC100), but keep getting this: Error 1719. The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed. Contact your support...
error 1719 The windows installer service could not be accessed.......
I bought a new hard drive to free up space from my C: drive all went well until copied all files to the new HD including all windows files (mistake) now the new drive (E:) is shown as an OS drive like C: so when I try and install a new program like Ventrilo (or any program that needs the installer...
General Discussion
Error 1719 - Can't find Windows Installer - but I know it's there!
I have been going around and around with my wife's computer. Specs: MSI X58 mobo, Intel Core i7, 16g ram, gForce 9500 video with dual DVI out, 740g drive, Win 7 Pro 64b. I built this machine and it has been running great for months and last week it started to freak out. My wife was having...
Windows Updates & Activation
Error 1719 and No Windows Installer?
Hi, I've had my Lenovo U350 for a about a year and a half. Towards the very beginning I've had this issue on and off, but never really noticed it. Today I tried to install steam.exe, but I keep getting an error 1719. I went to services.msc and realized that I don't actually have a 'Windows...
General Discussion
Windows installer service error
I can't install or uninstall anything more. It has been running just fine, but suddently I get this error when trying to install or uninstall: The Windows Installer Service could not be accessed. This can occur if you are running Windows in safe mode, or if the Windows Installer is not...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:53.
Twitter Facebook Google+