Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Java Error : java.lang.RuntimeException when Updating Vuze

04 Jan 2014   #1

Windows 7 Ultimate 64-bit SP1
Java Error : java.lang.RuntimeException when Updating Vuze

Hello to everyone!

I am currently experiencing this Java problem that I only encounter when updating my Vuze Bittorrent Client. I am just updating it to newer version but every time I try, the error pops up. The complete error is:

"An error occurred: java.lang.RuntimeException: java.lang.reflect.InvocationTargetException"

After clicking OK button, the setup ends. And when I re-try to install the update, the Vuze Installation Wizard will show this message:

"The installer did not start up correctly on the last run. This is probably caused by a corrupted Java VM. Do you want to download or manually select the JVM?"

When I choose YES, the installer will download the file but will fail and will show the Java error. When I choose NO, the installer will proceed normally but will show the same Java error.

I manually update my Java to the latest version which is Version 7 Update 45 but problem still persists. I checked my Java version by going to

If you have questions, feel free to ask. I need your help on this since I'm a bit cautious when dealing with this Java since I don't know much about it.

Thanks in advance!
My System SpecsSystem Spec
04 Jan 2014   #2

Windows 7 ultimate 64-bit

Well; first thing i would try is completely uninstalling Java; and then reinstalling it. Then;(make sure any files retrieved from the bit torrent client are backed up if possible) uninstall the bit torrent client and reinstall that. Try these things and report back and we can go from there if not solved.
My System SpecsSystem Spec
07 Jan 2014   #3

Windows 7 Ultimate 64-bit SP1

Thank you for the reply, matts6887! I'm sorry if I can't respond to you earlier, I've been busy with my work.

Anyway, doing what you said, I uninstalled the Java and the bit torrent client. Restart the PC. Then reinstall the Java and the newer version that I supposed to upgrade my current client version to. Fortunately, I was a success. But why?!

I am now thinking that maybe, It has something to do with other problem (and I post it here also on the same day with this but in different section). I know it is too much for a request but can you look at it? I'm just thought because I upgraded my client before but I encounter nothing like this.. only after I changed my User Account Name.. Here is the link of my other post:

Installation Problem After Changing User Account Name?

Thanks for the help!!
My System SpecsSystem Spec


Thread Tools

Similar help and support threads
Thread Forum
Java Updating - Always a Hassle?
Once again I find myself with 'real things to do' and updating Java. Boy is this a love/hate relationship. Why can't Oracle get this right? I successfully downloaded and installed 8.25 (avoiding the 'free bloatware' bundled with it.) I ran the uninstall routine and was assured that I'd...
Possible JAVA Error?, Cannot run any programs requiring JAVA?
Evening all, first post... Hopefully someone could help, Everything was working fine yesterday (05/06/2013) then when i turn on today (06/06/2013) i cannot run any applications that are running java. For example, firefox uses JAVA, but when i start firefox, it crashes..... heres the...
Exploit:Java/CVE-2008-5353.B;Trojan:Java/Selace.A and B
Help! I ran the Windows Safety Scanner. It detected four issues, but apparently, the scanner cannot clean three: Exploit:Java/CVE-2008-5353.B Trojan:Java/Selace.A Trojan:Java/Selace.B There is no concrete information on how to get rid of these unwanted visitors and prevent them from...
System Security
updating Java sending me in circles
Hello out there, Updating Java is making me a little crazy! When I'm logged in under my credentials I keep getting the little popup note that I need to update Java. I try to update it & it stalls, I assume because it requires Admin. credentials to install. So I switch user to Admin. and I...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:43.
Twitter Facebook