Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: The Application was unable to start correctly (0xc000007b)

04 Apr 2014   #1

The Application was unable to start correctly (0xc000007b)

I just installed Windows 8.1 on a second hard-drive so that I can dual-boot between Windows 7 and Windows 8.1.

I reinstalled all of my programs, games, etc and everything is absolutely amazing. Windows 8.1 is actually really fast!

Anyways... Everything is working great except 1 thing! I have a standalone .exe (requires no installation, so there's no direct connection to an OS via registry or anything) that will NOT open on Windows 8.1

If I attempt to open it on my Windows 8.1, I get the error "The Application was unable to start correctly (0xc000007b)"

but on my Windows 7, it works just fine..

I've done a LOT of research on this and I've read just about every article linked to this issue online and nothing has worked.

Here's what I've done..

1. Re-installed Visual C++. I did for every year, i.e. 2005, 2008, 2010, etc.

2. Replace the 5 DLL's for Visual C++ while in Safe-Mode and then restart.. I was only able to replace 4 of them, the last one was giving me permission troubles for some reason. It was called "msvcr100_clr0400.dll"

3. Run a debugger (WinDbg) and use Application Verifier to try and pinpoint the problem. Tried this, but the program doesn't boot far enough to gather any information, and I can't really understand what WinDbg throws at me.

4. Use Dependency Walker to see if it points you to a DLL. When I use Dependency Walker, it has very minimal results.

To be exact:

00:00:00.000: Started "d:\Application.EXE" (process 0x1364) at address 0x00400000 by thread 1. Cannot hook module.
00:00:00.000: Loaded "c:\windows\system32\NTDLL.DLL" at address 0x77D80000 by thread 1. Cannot hook module.
00:00:00.000: Page heap: pid 0x1364: page heap enabled with flags 0x3.
00:00:00.953: Exited "d:\Application.EXE" (process 0x1364) with code -1073741701 (0xC000007B) by thread 1.

5. I haven't done anything with DirectX for a few reasons. 1. All of my games work fine, and I play A LOT of games. This small .exe is the only thing giving me problems, and it has nothing to do with DirectX, so I know it's not that.

6. NTDLL.DLL, in Dependency Walker, I can't tell if the program can't start because NTDLL.DLL isn't hooking, or if NTDLL.DLL isn't hooking because the program can't start, but either way, I can't find ANYTHING on Google about NTDLL.DLL being a culprit of a program not launching.. Can anyone say anything about this?

Now remember, this .exe is a standalone executable, so it won't be the way it was installed.. because it doesn't require installation! Both of my Windows 7 and 8 are 64-bit, so that can't be the problem.

Any help would be greatly appreciated.

This application isn't needed and I don't care if it works or not, but I'm curious why this is happening... I also don't want to run into this issue in the future with an .exe that I do actually need!


My System SpecsSystem Spec
04 Apr 2014   #2


No one?
My System SpecsSystem Spec

 The Application was unable to start correctly (0xc000007b)

Thread Tools

Similar help and support threads
Thread Forum
''Unable to start correctly (0xc000007b)'' Skyrim,DiRT3,Goat Simulator
I Have this problem with games like Goat Simulator, DiRT3 and The Elder Scrolls Skyrim and I am So pissed off. I just got my custom made computer and now these games doesn't work and yes i have installed all .net and .dll files also c++ etc. But nothing works. :cry: I'm so tired of this! I have...
HELP! The application was unable to start correctly (0xc000007b)
I've looked up this error over and over and there's a 1000 "fixes" and none of them have worked for me. Situation: Four years ago I purchased Windows 7 Home Premium Pack, which was a disk set with four licenses. I installed three of them on my wife's laptop, my laptop, and my desktop, all...
explorer.exe the application was unable to start correctly (0xc000007b
Hello guys I think I messed it up bad :confused: I was working on making a theme and I restarted to this error. explorer.exe the application was unable to start correctly (0xc000007b). And the whole screen is black with a cursor in the middle, and there is no option to do, even the task manager...
BSOD Help and Support
This application was unable to start correctly (0xc000007b).
For some reason when I open up certain programs in my computer I get this problem. The programs include Adobe Premiere Pro, Office 2013 and a few other programs. Here are the details of my system computer: I have also done a...
"The application was unable start correctly (0xc000007b)."
I get this error when I open up a specific .exe I'm trying to access, none others give this error, just this one. What could the problem be?
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:51.
Twitter Facebook Google+