Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: I can't uninstall that program

05 Apr 2014   #1

windows 7 32-bit
I can't uninstall that program

Hi all,

I have a USB bluetooth hardware device that I would use it before without problem. When I would put it into the USB port , the machine would install it's program automatically and I could use it easily. This time that I reinstalled Windows 7 I used the Driverpack for installing drivers. That pack installed a program named "Bluetooth Stack for Windows by Toshiba" for that USB hardware device. And now neither I can use the bluetooth nor I can uninstall that program. Now I want to remove it but I get error (image 2)!!
Any solution?

Attached Images
I can't uninstall that program-1.png I can't uninstall that program-2.png 
My System SpecsSystem Spec
05 Apr 2014   #2

Windows 7 Pro x64 Windows 10 Pro x64

Do a system restore to a date before you installed the driver pack.

FYI, there is no need to use a driver program with Windows 7
My System SpecsSystem Spec
05 Apr 2014   #3

windows 7 32-bit

It's impossible to do a system restore because I installed numerous apps after that installing. And further more, after installing Windows (say 7) I should somehow install the drivers, not? What I need now is a program that uninstall that app I think.
My System SpecsSystem Spec

05 Apr 2014   #4
Microsoft MVP

Windows 7 Ultimate X64 SP1

If the Blue Tooth device is an add on piece of hardware the Toshiba driver pack won't install it. You would need to install it from the provided disk or go online and find the driver, install it, then try uninstalling it.

Well, wait a minute, are you working on the machine in your specs? If so, throw away the "Driver pack for Windows" what is that?
My System SpecsSystem Spec
05 Apr 2014   #5

windows 7 32-bit

The blue Tooth device is a hardware snip without any name to finding it's driver on the Web and also when putting it into the USB port (for first time), the machine (each machine) itself installs its driver automatically and easily but this time I used that pack for installing its driver which was a mistake!
I also tried to install it again from that pack and then uninstall it but each time I faced that error. I also tried to use the Cleaner tool for uninstalling but same outcome.
Driverpack is a tool which recognizes all drivers of Windows hardware (Audio, Video card, chipset and etc) and easily offers driver for each one. there isn't need to surf the Web for finding the drivers when existing driverpack.
My System SpecsSystem Spec
05 Apr 2014   #6
Microsoft MVP

Windows 7 Ultimate X64 SP1

As AddRAM said, there's really no need for any kind of driver pack. I suspect that has caused the problem.

Please download AdwCleaner:
Save to the desktop.

Close all open programs.
To run the program, right-click AdwCleaner.exe and select: Run as Administrator

Click on Search and confirm the prompt.
After the program finishes, a text file report opens.
Please post the content of the C:\AdwCleaner[Rx].txt in your reply. In the reply window click the "#" icon at the top and paste the log text between the [code ] Paste Here [ /code] tags.

Do NOT perform the delete part before I or someone else can read the log.

To delete:

Run AdwCleaner once again.
This time click on: Delete
When done, please post the content of the C:\AdwCleaner[Sx].txt in your reply as outlined above..
My System SpecsSystem Spec
05 Apr 2014   #7

windows 7 32-bit

I clicked on Run as administrator. There wasn't any search so I just confirmed the user Account control prompt. Then I clicked on scan button. It didn't show anything except for my Babylon app in folder column. The text file is as follows:

# AdwCleaner v3.023 - Report created 05/04/2014 at 17:40:42
# Updated 01/04/2014 by Xplode
# Operating System : Windows 7 Ultimate Service Pack 1 (32 bits)
# Username : CS - CS-PC
# Running from : C:\Users\CS\Desktop\adwcleaner.exe
# Option : Scan

***** [ Services ] *****

***** [ Files / Folders ] *****

Folder Found C:\Program Files\Babylon
Folder Found C:\ProgramData\Babylon
Folder Found C:\Users\CS\AppData\Local\Babylon
Folder Found C:\Users\CS\AppData\Local\Temp\Babylon
Folder Found C:\Users\CS\AppData\Roaming\Babylon

***** [ Shortcuts ] *****

***** [ Registry ] *****

Key Found : HKCU\Software\Babylon
Key Found : HKCU\Software\Microsoft\Office\Powerpoint\Addins\babylonofficeaddin.officeaddin
Key Found : HKCU\Software\Microsoft\Office\Word\Addins\babylonofficeaddin.officeaddin
Key Found : HKLM\Software\Babylon
Key Found : HKLM\SOFTWARE\Classes\.bdc
Key Found : HKLM\SOFTWARE\Classes\.bgl
Key Found : HKLM\SOFTWARE\Classes\.bof
Key Found : HKLM\SOFTWARE\Classes\AppID\{B16632F1-24E0-4D99-A68D-70BFB6447C48}
Key Found : HKLM\SOFTWARE\Classes\AppID\BabylonIEPI.DLL
Key Found : HKLM\SOFTWARE\Classes\BabyDict
Key Found : HKLM\SOFTWARE\Classes\BabyGloss
Key Found : HKLM\SOFTWARE\Classes\BabylonOfficeAddin.OfficeAddin
Key Found : HKLM\SOFTWARE\Classes\BabylonOfficeAddin.OfficeAddin.1
Key Found : HKLM\SOFTWARE\Classes\BabyOptFile
Key Found : HKLM\SOFTWARE\Classes\CLSID\{6AC0BB10-C922-45E2-857D-2A368FE749E5}
Key Found : HKLM\SOFTWARE\Classes\Interface\{B7EA2226-F876-4BE4-B478-76EBAE2A668A}
Key Found : HKLM\SOFTWARE\Classes\Prod.cap
Key Found : HKLM\SOFTWARE\Classes\TypeLib\{A1489C85-4F6F-48C4-AC9E-18B63AF4703E}
Key Found : HKLM\SOFTWARE\Classes\TypeLib\{F310F027-15CB-4A7F-B10D-3A4AFB5013A5}
Key Found : HKLM\SOFTWARE\Microsoft\Shared Tools\MSConfig\startupreg\Babylon Client
Key Found : HKLM\SOFTWARE\Microsoft\Tracing\Babylon_RASAPI32
Key Found : HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\App Paths\Babylon.exe
Key Found : HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Babylon

***** [ Browsers ] *****

-\\ Internet Explorer v11.0.9600.16428

-\\ Mozilla Firefox v25.0.1 (en-US)

[ File : C:\Users\CS\AppData\Roaming\Mozilla\Firefox\Profiles\58oukfr1.default\prefs.js ]

-\\ Google Chrome v33.0.1750.154

[ File : C:\Users\CS\AppData\Local\Google\Chrome\User Data\Default\preferences ]


AdwCleaner[R5].txt - [2424 octets] - [05/04/2014 17:40:42]

########## EOF - C:\AdwCleaner\AdwCleaner[R5].txt - [2484 octets] ##########
Can I perform the delete part now?
My System SpecsSystem Spec
05 Apr 2014   #8
Microsoft MVP

Windows 7 Ultimate X64 SP1

Yes Run the delete part. It will remove Babylon though, it is a known trouble maker and can bring in others as well. It's not needed and could be causing your issues.
My System SpecsSystem Spec
05 Apr 2014   #9

windows 7 32-bit

Britton30: It just doubled my problem! I SAID I WANT TO DELETE THE BLUE TOOTH NOT THE BABYLON.
Now I should waste more than one hour to returning the situation to before and the blue tooth program still exists! I don't know I write in English or Chinese
My System SpecsSystem Spec
05 Apr 2014   #10
Microsoft MVP

Windows 7 Ultimate X64 SP1

Fine, you will have problems as long as you keep Babylon, did you no understand that?
Someone else may have help for you.
My System SpecsSystem Spec

 I can't uninstall that program

Thread Tools

Similar help and support threads
Thread Forum
I need help trying to uninstall a program
Hi everyone, I am trying to remove an online Bible program i had tried to install on my PC. I was just looking in the programs list and found it still listed. I tried to uninstall the program but it stubbornly refuses to remove itself. A little background: I got the program from someone at...
How can I uninstall a program that doesn't appear in Uninstall/change
How can I uninstall a program that doesn't appear in Uninstall/change programs? I can see the program folder in Program files but I guess deleting this folder alone will leave traces on the registy etc. I've tried with CCleaner and Revo uninstaller and the program doesn't appear either. ...
I can't uninstall this program.
Hi, I did a system restore to reinstall a program that I had uninstalled. It did not work. For some reason the program was only half heartedly removed, it was still on my PC but fragmented. So I decided to completely uninstall it...however, I cannot. When I click uninstall it tells me this error...
Can't Uninstall software from "Uninstall a program", link won't work
Firstly, sorry for any possible interruption I have the following problems and they seem to insist despite many of the solutions I've tried: It must be something wrong with Control Panel / Programs / Programs and Features: * Uninstall a program * Turn windows features on or off * View...
hep cant uninstall a program
i am trying to remove microsft office from my desk top pc using add and remove in programs each time i try to do thid is says the windows installer service could not be accessed. any idea how i can remove this program?
Microsoft Office

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:03.
Twitter Facebook Google+