Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Explorer.exe hangs with IRP along with another specific process

22 Apr 2014   #1

Windows 7 Ultimate x32
Explorer.exe hangs with IRP along with another specific process

I've had this problem for possibly 2 or 3 weeks now (time passed and I couldn't remember when exactly it occurred) in which whenever I would run League of Legends via it's launcher, explorer.exe would hang and I came to the conclusion it hangs with IRP based on a test I've done with NotMyFault. I thought the problem would reside with the game itself being broken for some reason or something along the line however after completely removing every BIT of it (no more registry entries or leftovers) I simply tried to install it once again with the exact same issue but now present on the installer itself. There's 2 DLL's showing as the culprit however after tons of hours wasted on researching I could not diagnose the problem in any other way. Just to be clear the process created for the installer and previously for the game would become unkillable no matter what I would use. This also applies to explorer.exe or if say explorer.exe would be killed before attempting the program it ran from would suffer from the issue. Example of what was previously stated: I closed explorer.exe before trying once more and I did a most basic thing. I ran the installer from the downloads tab from Firefox and it ended up just the same. I am forced to restart my PC once I open the installer for League of Legends as I can not get rid of it in any way. Since the 2 processes can not be closed I also can not shutdown my PC or restart the normal way. Restarting via button is the only option along with say power off/on.
To go with all these I have included 2 images of what I can see through Process Explorer. I also have quite a few other utilities present that I can further use if needed.
First one will be of both processes which I hope to have sufficient information to start with:
Second one is something I found quite odd. Hovering over explorer.exe ends up showing this:

My System SpecsSystem Spec
22 Apr 2014   #2

Windows 7 Ultimate x64 SP1

Hey Zakusho

Found this thread, might help.
Multiple explorer processes.
My System SpecsSystem Spec
23 Apr 2014   #3

Windows 7 Ultimate x32

Sadly unrelated despite the similarity within the commandline used.
My System SpecsSystem Spec

01 May 2014   #4

Windows 7 Ultimate x64

Found the solution, if you are still looking(I've seen your posts on many sites, hope you aren't pulling your hair out).

This has to do with the new update to MalwareBytes(it's 2.0 version). It seems to crash both EU and NA Clients/Installers but not for PBE, so I knew it wasn't AIR. Moved the PBE Exe's into the NA folder to replace the old ones, and then, same bug. It seems to be targeting NA clients by path(PBE Files are same name but, only crashed when I put them in the NA directory) and the installer by file name(crashed no matter where it was).

First off, uninstall Malwarebytes, you can attempt to revert to an old version of Malwarebytes, or seek out new alternatives.
Secondly, run Windows Update and download all recommended and optional updates(Except for Bing Bar/Desktop, language packs, etc.)
Restart your PC after all updates are downloaded, and let it run(will restart a few times based on updates).

I would recommend you check to see if you client will run after and repair the installation(just in case), if not, redownload the installer and run it.

Should work fine afterwards.
My System SpecsSystem Spec
01 May 2014   #5

Windows 7 Ultimate x32

Already tried. I figured the problem after going for a format and reading a specific comment somewhere. Sadly with the release of Dark Souls 2 I could not risk it any longer and had to format and thus have no way to be sure if I really did or not figure it out but it's the only thing I can think of. I've made a custom profile for League of Legends with the aid of tools such as Nvidia Inspector and some other minor ones and the profile worked wonders for ages up until a DarkComet/DarkKomet RAT touched it. I managed to repair all of the damage caused by it except for this one. Just so people don't get the wrong idea... the RAT didn't do any real harm as I noticed it within seconds of infection. It stood merely for 12 minutes in which it has only done minor things to my system. I simply didn't realize this specific RAT would be capable of modifying my custom profile set for the game but there you go... pretty much sure it's the reason why it stopped working. Yes the profile also targets the installer because it wasn't set to work only on the main executable but on everything related to LoL. Also... I've lost track of my bookmarks (silly me thought Firefox Sync was something else) and can't remember the forums I've posted on anymore so yeah forgot to mark it as solved.
My System SpecsSystem Spec

 Explorer.exe hangs with IRP along with another specific process

Thread Tools

Similar help and support threads
Thread Forum
Boot process hangs until I Press F1 key
Can someone tell me how to stop the boot process from hanging-up until I press the F1 key. After I press the F1 key the process resumes until the Windows 7 login screen appears. How can I stop the boot processs from requesting I press the F1 key?
Installation & Setup
"Error opening process" message in Process Explorer
Hi Everyone I recently did a System Restore on a Windows 7 Pro 64 bit system to correct a strange problem I was having with IE. It seems to have solved the problem, but now Process Explorer is displaying the messages in the screen shot below, and I'm not sure why. The computer is functioning...
Re-Installing Win7 / Process hangs in a black screen with cursor
Hi all, I have been trying multiple times to install Windows 7 to my hp pavilion g6-1007 laptop from an installation DVD but with no success so far. The problem is that I can't proceed with the installation. Every time I put the DVD and boot from there, first I see that black screen with the bar...
Installation & Setup
open explorer, starts new process, close it, process remains active
Hi, I've got a quicklaunch shortcut to: %windir%\explorer.exe shell:::{323CA680-C24D-4099-B94D-446DD2D7249E} That takes me straight to my explorer favourites. What I notice is that when I launch that, I get a new explorer.exe thread appear in the task manager. When I close it though, that...
General Discussion
Windows 7 + Process Explorer + Patch: [Opening error process]
Hi fooks, I hope you all can read this, i'm from Belgium so my Englsich is not as good as it might be. I have bought last year a little notebook with Windows 7 Home Premium on it. On this machine i am the Administrator, and there are no other people on that, or guestaccounts made. On...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:57.
Twitter Facebook Google+