Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Please help! Cannot install any MS Visual C++! Error 1935

02 Jul 2014   #1

Windows 7 Ultimate x64
Please help! Cannot install any MS Visual C++! Error 1935

So, I'm just going to get straight to the point. I'm trying to install Microsoft Visual C++ 20xx so I can play games like Grand Theft Auto IV or BeamNG Drive, Ship Simulator Extremes, etc., but every time I try to install any of the Microsoft Visual C++ versions (anything between 2004 and 2013) it gives me this error:

I was told that it was a registry error, and I've already looked at all of the helpful looking pages on Google, nothing helped. I think it may be some kind of Malware but my antivirus doesn't find it. (Phantom Virus maybe?) Please help! It's preventing me from playing one of my most favorite games.

My System SpecsSystem Spec
02 Jul 2014   #2

Windows 7 Ultimate 64-bit

Error 1935, can also be caused by unsuccessful updates.

Here is a link to reset your updates, and try again.

Windows Update - Reset

Let me know how it goes and if you need any more support.
My System SpecsSystem Spec
02 Jul 2014   #3

Windows 7 Ultimate x64

It did not work. I got this.

My System SpecsSystem Spec

11 Jul 2014   #4

Windows 7 Ultimate x64
Figured out how to avoid Error 1935

All I need to do is install Microsoft Visual C++ 20xx with a third party installer. It seems to only occur (Error 1935) when I use the normal VC++ installers, so I thought if I could find third party installers, I could install them and play the games I've wanted to. Anyone have tips on where to look for these installers?

Source: Installed Unturned from steam, and it also installed VC++ 2010 with no errors
My System SpecsSystem Spec
14 Jul 2014   #5
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1

Welcome to Seven Forums hudzell. You appear to have a Windows Update issue that is more serious than a game issue. You would be wise to post about that problem in the Windows Updates & Activation - Windows 7 Help Forums

A Guy
My System SpecsSystem Spec

 Please help! Cannot install any MS Visual C++! Error 1935

Thread Tools

Similar help and support threads
Thread Forum
Error 1935 Microsoft Visual C++ Redistributable
Hello, I am trying to install Autodesk Maya, a 3D graphics development program. The first part of the installation gets hung up when it attempts to install Microsoft Visual C++ Redistributable. I figured I would install it separately, and I got this error message with every version of...
Error 1935, Microsoft Visual C++ 2008 Redistributable Package (x86)
I once had this before when I tried to download Age of Empires Online. I decided one game isn't worth the problem, and I'd avoid all "Games for Windows" games because of this issue. Now, I recently bought a Vita and now I can't download Content Manager Assistant because of this, so now it is...
Error 1935 HRESULT: 0x80070003 when installing Microsoft Visual 2008
Hello, I was trying to install XNA 3.1 when I started receiving some VC90 errors. I uninstalled Microsoft Visual C++ 2008 32 and 64, but receive an error when reinstalling. Error 1935 HRESULT: 0x80070003. I ran SFC /SCANNOW. CBS came back OK. I ran the readiness tool. CheckSUR says I'm fine....
Performance & Maintenance
Microsoft Visual C++ 2005 Redistributable Error 1935
Hello! I am getting a really infuriating problem that is preventing me from installing applications, such as Livestream Podcaster. Here is the error as displayed by Event Viewer: Product: Microsoft Visual C++ 2005 Redistributable -- Error 1935.An error occurred during the installation of...
Installation & Setup
Error 1935: Microsoft Visual C++ 2008 Redistributable x86 Install
I was trying to install Visual Studio 2010 and started encountering errors with the C++ distributable package during install, so I decided to install it by itself. Whenever I try and install it, it stops on Feature: FT_VC_Redist_openMP_x86 and I receive the following error message before it...
Acdsee Pro 2.5 install error 1935
I get error 1935 all the time when I try to install Acdsee Pro 2.5 on Windows 7 x64. I haven't been able to solve this problem, anyone have any ideas?

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 21:10.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App