Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: "Componet 'comctl32.ocx' not correctly registered

30 Jul 2014   #1

Windows 7 Home Premium 32bit
"Componet 'comctl32.ocx' not correctly registered

So I'm trying to run an application called Advance Text. It's used to edit the text in a ROM. Every time I try to run it an error message pops up, saying what is in the title- that comctl32.ocx or one of it's dependencies is not correctly registered. After a Google search, I entered "regsvr32 comctl32.ocx" (without the quotations of course) and I got an error message saying, "The module 'comctl32.ocx' failed to load." I have no idea where to go from here. Any and all help is appreciated!

My System SpecsSystem Spec
30 Jul 2014   #2

7 both versions

You might need to search that the ocx file tire trying to register is in the system32 or Windows folder (or in a recognised path). Do a file search to confirm
My System SpecsSystem Spec

 "Componet 'comctl32.ocx' not correctly registered

Thread Tools

Similar help and support threads
Thread Forum
Newly created user profile not registered correctly
Good Morning and a happy new year, helpful people :-) Yesterday I ran into a weird, and apparently unique, problem. The actual problem is described below the bold text, everything before that is just introduction. I wanted to create a user account on my netbook for my girlfriend. She has a...
General Discussion
Windows 7 x64 "COMCTL32.ocx Failed To Register"
Hi, i have a laptop running Windows 7 Home Premium x64, and i am trying to run a program called "Advanced-Mart" Its for hacking Pokemon games. when i try to open it, it says that "COMCTL32.OCX or one of it dependencies is missing." i tried registering it, but IT WILL NOT WORK :mad:! Its very...
all video files give error "class not registered" when trying to play
The title explains it all just restored my computer and now any kind of videos files i try to play give me the error "Class not registered" what do i do? btw, yes i did update all my video drivers.
Music, Pictures & Video
Help for Windows Media Player, "Class Not Registered"
-----RESOLVED----- Thanks To SledgeDG----- I've never seen a problem like this before, when i try to play a file for Windows Media Player, it says "Class not registered" >> Screenshot from Lightshot <<, Any resolves? Thank you. Sreenshots: Screenshot from Lightshot
Media Center
Q: Ok to change "Registered owner"?
Will I run into any problem if I change the Registered Owner (and Registered Company) for my system? (to fix a typo!) The method is described here: Registered Owner and Organization - Vista Forums I did see that some Registry installer sections for non-MS products have picked up the...
"...not genuine" but it is and registered
Win7 Pro, RETAIL package, 64bit install, on line registered. Lately I'm getting a message above the task bar (far right): Windows 7 Build 7600 This copy of Windows is not genuine Doesn't show all the time, just pops up every now and then.
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App