Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: .NET Framework 4 refusing to install after many solution attempts

22 Oct 2014   #1

Windows 7 Professional 32-bit
.NET Framework 4 refusing to install after many solution attempts

Hi there.

I posted this on microsoft answers before, but no one comes with an appropriate solution, and many seems to treat as this was a common recurrent installation problem.

So, please take note of these before answering:

* I've searched thoroughly for similar problems, no one ever had this exact problem with .NET 4 installer.

* I'm using a fresh and optimized installation of Windows 7 Professional 32-bit, all drivers installed and everything is functional (including the buil-in .NET Framework versions).

* I've already checked the installer integrity (i'm using the offline installer), the file system health, and all the permission issues on the hard drive and registry, everything is ok.

* The installation log is not being created, so the only thing i have is the windows report information.

* According to this information and to similar problems, it could be either a registry permission issue or an issue with the previous .NET version on the system, but, the previous version was built-in, so i had to purge it manually, there was no way to uninstall it.

* I wiped out every single trace of the previous .NET framework on the system, both from the hard drive and the registry, using every key related, like "netfx" "netframework" ".NET\" "aspnet" "" "net_framework" "net framework" "\" etc, and i complemented this manual purging with Wise Registry Cleaner, to remove any registry entries related to the deleted ones, and to solve any other issues created by this.

* The installer still refuses to install after all of this (yes, I'm surely executing it as administrator, and msiexec service is working fine, other similar installers work normally too).

*Edit: I've enabled Windows Update service too, once it may be required, but the installer still doesn't work.

*Edit: The process fails and roll back when trying to install the net framework 4 client profile

I had a similar problem trying to install Microsoft Office 2010, after the previous office installtion got corrupted, and i had to purge it manually, same thing, installer started, and then rolled back everything, and claimed to have registry issues, even after i purged everything i could from the system. I couldn't solve it, I had to re-install the whole operational system.

Here's the Windows Report data:

Problem Event Name: VSSetup
Problem Signature 01: Microsoft .NET Framework 4 Setup
Problem Signature 02: 4.0.30319
Problem Signature 03: 10.0.30319.1
Problem Signature 04: 1
Problem Signature 05: netfx_Core_x86.msi
Problem Signature 06: Install_I_Interactive_Error
Problem Signature 07: 1603
Problem Signature 08: 1406
Problem Signature 09: WriteRegistryValues
OS Version: 6.1.7600.
Locale ID: 1046


My System SpecsSystem Spec
23 Oct 2014   #2

Windows 10 Pro (x64)

What is this "optimized installation" of Windows you mentioned?
My System SpecsSystem Spec
23 Oct 2014   #3

Win7 SP1 + Ultimate 64 bit

Sounds like you have an issue with the user/temp folder security permissions.
If you go to the USER temp folder and right click on the folder then look @ the security section and see if there is a listing for SYSTEM like the pic I have uploaded, if not, you will need to add it by clicking the edit button on the right and then ADD SYSTEM as a security user then, give it full permissions.

It is a common fault with windows, it's worth a try.

Attached Images
.NET Framework 4 refusing to install after many solution attempts-temp.jpg 
My System SpecsSystem Spec

23 Oct 2014   #4

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
.NET Framework 4 issues

Well I'm no expert on this and can't give you a proper solution but I do remember having the same issue around a year ago. As far as I can remember there was a "failed pending update" for .NET Framework 4 that prevented installation. The solution was to run a couple of tools to fix and repair windows updates and once repaired - disable windows updates to prevent reinstallation of .NET Framework then run the .NET Framework cleanup tool to remove all versions except .NET Framework 2.0 SP2, 3.0 SP2 and 3.5 SP1. Then re-enable windows updates to take care of the .NET Framework install for the versions needed.

Also see: An update for the Microsoft .NET Framework may fail to install when the Microsoft .NET Framework 4 is installed and a restart is pending

It might be worth asking for advice in the Windows Updates section.
My System SpecsSystem Spec

 .NET Framework 4 refusing to install after many solution attempts

Thread Tools

Similar help and support threads
Thread Forum
Attempts to install KB3003743 repeatedly fail
I have kept my PC (running Windows 7 SP1 (64-bit)) updated with all Windows updates, but KB3003743 will not install. The update error code is 80070643. I have run SURT and sfc /scannow (no errors reported). I have been unable to upload a zip file containing all the files contained in the cbs...
Windows Updates & Activation
My HP ENVY 17-3090nr 3D Edition is refusing to install Audio Driver
Hello, My HP ENVY 17-3090nr 3D Edition is having problem with a newly installed windows 7. No back up, no recovery because i formatted my hard disk the hard way. So after installing some drivers, the audio driver keeps saying " THE HARDWARE DETECTED IS NOT SUPPORTED BY THIS IDT SOFTWARE...
Sound & Audio
KB2847311 refusing to install
800736B3 Tried numerous fixes. No luck yet When I downloaded SURT and ran it, it said 'update not apllicable for my computer' Also, I'm sure my computer is x86, but this update appears to be for x64 systems
Windows Updates & Activation
Updates refusing to install
I have been getting automatic updates for ages and they've been installing on the fly with no problems. Suddenly they just stopped installing and I can't fogure out why. They seem to install but when I then reboot it says 'Failed to install updates' and they go back to telling me again I need to...
Windows Updates & Activation
Numerous attempts to install Win7 64
Hello all hope you can save my sanity. Asus P5Q Turbo Core 2D 8400 4Gig 250G
Installation & Setup
MSI refusing to install
Every .MSI I try to run seems to fail installing, whenever I attempt to run one it comes up with "Windows Installer has stopped working...". Does anyone know of a way around .MSI install files so I could install my programs? Thanks, -DaveW

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:33.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App