Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: The Diagnostic policy is not running, help!

10 Nov 2014   #1

Windows 7 Ultimate
The Diagnostic policy is not running, help!

I took my adventure to google to try to resolve this issue, the reason why i ask is I try to repair my internet and I get this.

Here is what I have done so far.

-I tried all of those things and I finally got it fixed:

go to start ,search and type:- cmd, right click on returned cmd.exe and select "run as administrator" at the prompt type:-

net localgroup Administrators /add networkservice
press enter then type:
net localgroup Administrators /add localservice
press enter then type:
press enter and restart your computer

Open services and make sure the service is started.

-Follow these methods mentioned below and check,
Method 1: I would suggest you to follow these steps.
a. Click on Start button.
b, Enter services.msc in Start search option.
c. Right click the Diagnostics Policy Services and start the services.

Method 2: This issue may occur when the account Trusted installer is missing the permissions for the key below:
Permission needed: Full Control, Read
Note: Serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection,
back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
(Back up the registry - Windows Help )
a. In Registry Editor(click start, type “regedit” and hit enter), browse to the above mentioned key for which you need to add permission.
b. Right click the key, and click Permissions. (HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\DPS\Parameters)
c. Click “Add” Button under usernames. Make sure Locations is selected to be the local computer.
d. In the "Enter the object names to select field, type "NT SERVICE\mpssvc". Then click “Check name.”
e. Click OK.
f. Then select the account which appears in the list, and add the appropriate permission (Full Control, Read) for it.
g. When this is done, click OK.

-Remove/uninstall all the network adapters and do scan for hardware changes.
a. Click on Start button.
b. In the start search type Devmgmt.msc and press Enter.
c. Uninstall all the network devices you have there.
d. Scan for hardware changes, your device will then automatically be installed over again.

Now, try running the network diagnostic service, it should start.

-sfc /scannow

-enabled DiagLog

-Windows repair tool

My System SpecsSystem Spec
11 Nov 2014   #2

Windows 7 Professional X64

Go to Dev Mgr - Services.

Make sure it is started.

Attached Thumbnails
The Diagnostic policy is not running, help!-diag-policy-pic-2.jpg  
Attached Images
The Diagnostic policy is not running, help!-diag-policy-pic.jpg 
My System SpecsSystem Spec
11 Nov 2014   #3

Windows 7 Ultimate

I went into the services already and try to start but still says I can not.
My System SpecsSystem Spec


 The Diagnostic policy is not running, help!

Thread Tools

Similar help and support threads
Thread Forum
Windows Diagnostic Service Policy is not running
Hi as the title above says I am having trouble with the windows diagnostic service policy not running. When trying to fix it using troubleshooting it does not do anything. I have set all 3 diagnostics to automatic as some threads have suggested however when I try to enable the diagnostic service...
General Discussion
Diagnostic policy is not running and getting Error 5:Access denied.
Hi All, when I am trying connect wifi internet I am getting error like " diagnostic policy is not running " while diagnosing the local area connection. FYI, Please refer attached screenshots. And I had done system file scanning also. but In sfc.log showing below message but I can't...
General Discussion
Can't run Diagnostic Policy Service because of Error 5
This started happening when I accidentally turned off my computer whilst it was booting. I have tried sfc /scannow, I have done the CMD thing (net localgroup Administrator) and have tried manually starting the service, to no avail. Here is a screenshot of what I think appears to be the...
Performance & Maintenance
Unable to connect to internet; diagnostic policy service not running?
Hey everyone, if anyone could provide any information on this issue, i'd greatly appreciate it. My mom's laptop is detecting that our wireless internet connection is active, but it won't actually connect to the internet. When we troubleshoot the issue, it says that our diagnostic policy service...
Network & Sharing
Cannot start diagnostic policy service
i tried to diagnose my internet connection, and it informed me that the diagnostic policy service was not running. so i went over to services.msc right clicked the diagnostic policy service and got the following error: im at loss |:
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:13.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App