Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Program will not install on new build.

25 Nov 2014   #1

windows 7 Pro
Program will not install on new build.

I have been using the Omni Form Program since 1998. When I upgraded to Win 7 Pro a few years ago it installed without a hitch.

Now with a new build and a fresh install of another Win 7 Pro, it will not load.

Splash screen comes up for install. Click install and "Nothing"

Compatibility mode did not help.

I realize I have some other options. Virtual XP, and others, but I would prefer to keep business apps together.

What has changed? My other machine is still up and running but getting long in the tooth. I have many and more custom forms that I use and dread the thought of starting over with other software.

Is there something I'm over looking? It worked before with Win 7 Pro, why not now?

Any help is greatly appreciated.

Thanks in advance


My System SpecsSystem Spec
25 Nov 2014   #2

Windows 7 ultimate 64-bit

Have you tried running the install as a administrator? If not I would try that and see what happens. As Ive mentioned before in previous threads about programs not installing; By default; Microsoft designed Windows 7 default permissions so that even if your user name is a administrator; you still will have to give your user name the proper permissions to install programs. Im thinking at this point that is why your program wont install. So try and see if you can give your user name the proper permissions and try installing it again. If still nothing post back and we can go from there.
My System SpecsSystem Spec
25 Nov 2014   #3

windows 7 Pro

Thank-you for your reply.

I have read another thread here, on how to set up an "unrestricted" administrator account and have done so.


Insert CD containing the program. Splash screen shows up as before.

Click install "Omni Form" and ......Nothing.

I own an un-opened, unused, Win XP pro with service pack 3 and Sata drivers, but was told it would not run on my new machine using X99 Chipset and Intel's new CPU.

As I have some custom Excel Apps that only seem to run well under XP and Office 2003, Maybe I should try to install Win XP anyway and see if I can set up a dual boot machine as my other one is.

Or, go ahead and install MS XP Mode in the new machine to see if that will resolve the issue. I won't worry over security updates as I will not use the internet with XP.

Your Thoughts?


My System SpecsSystem Spec

27 Nov 2014   #4

windows 7 Pro

I decided on installing windows xp mode.

It seems a bit Clunky, but Omni form installed and I can now use the program.

We shall see how well it works over time.

Thanks for your efforts.


My System SpecsSystem Spec

 Program will not install on new build.

Thread Tools

Similar help and support threads
Thread Forum
Program refusing to install in standard program files folder
I have an Advent (PC World brand) Laptop that comes with its own custom On-Screen Display software. The software is made for 32 bit Windows with no 64 bit version available as far as I'm aware. I have upgraded to 64 bit Windows recently and everything seems to work great except the OSD. ...
Can't install program - Program Data folder permissions?
I'm trying to instal Skype on my PC and I keep getting this error message: 'An error occured while attempting to create the directory: c:\ProgramData\Microsoft\Windows\StartMenu. This is what I've done to try and remedy it: 1. Right clicked the installer file and tried to run as...
Unable to remove old program and thus can not install new program Help
Hello to all, Hoping someone can assist. I have been using a program called Raw Therapee. I downloaded a new version and on installing it quit saying the old version must be removed. I could not find it listed in Revo Unistaller Pro, so I did a forced uninstall with the location of the main...
Program Files Transfer for New Build
I'm just completing a new build and got almost everything reinstalled and transferred. I used Ninite to transfer programs but it only transfers the popular programs it has and I have a whole lot more that need to transfer. I don't have the installation info for a lot of these programs. What do I...
Installation & Setup
Can I install Icon Packs designed for Build 7600 on to Build 7601?
Can I install Icon Packs designed for Build 7600 to Build 7601? An Icon Pack was saying install on to 7600 only and after I checked my regedit, I learned that I have 7601 (Probably SP1, I don't know). Would I have any problems if I install the icon pack? Thanks.

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:08.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App