Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't install any program on my new PC

24 Dec 2014   #1

Windows 7 Professional x64
Can't install any program on my new PC

Hello guys!

I've just bought a new PC(part-based assembly), together with Windows 7 Professional.

I received it yesterday - the guys did a decent job and even installed the windows for me, so I got it ready-to-use. I've noticed there are some programs installed - Microsoft Security Essentials, Google Chrome and all the necessary components - NVIDIA stuff, etc...

I just renamed my user account and set a password and decided to start installing my software. I started with Aida64 Extreme, latest trial version from their website as I wanted to observe my specs and Dev C++ afterwards. For my great surprise, both installs fail in their own way. With AIDA, I could accept the license agreement and it failed upon the start of the installation process. With DevCpp, it doesn't even open any window, just the NSIS error. In another forum I found the link for the latest version of Windows Installer - 4.5 and downloaded it for 64-bit. It fails too. Please check the attached images for the exact error messages.

I've tried the Sfc /scannow tool and it reports everything is OK after it reaches 100%.

I've tried granting maximum permissions to the Program Files(and x86 one) to see if it has to do with permissions but Windows says I don't have the permissions to do it(my account is Administrator). UAC is set to the lowest level until this is fixed.

Microsoft Fix It tool (portable version) for installing/uninstalling software doesn't run at all. I double click it but nothing shows up.
Edit: My mistake - the Fixit It (Run Now) version doesn't show up. I then noticed the portable version, downloaded it and it reports an error too(last screenshot).

All these issues are experienced in Safe Mode too.

If it matters, I have both SSD and normal hard drive.
SSD: KINGSTON V300 240 GB 2.5 '' SATA3
HDD: SEAGATE 1000 GB SATA III, 7200 rpm, 64 MB

Windows7 is installed on the SSD for the sake of performance.

All the programs I want to install have been transferred via a flash drive to the PC, if it matters.

What I haven't tried so far:
Check Disc - I have read it may have the effect of marking bad sectors on a SSD - no moving parts, no sectors, so I refrain from running it.
Windows Repair - my PC has no CD/DVD drive(they forgot to put one?). I believe Windows has been installed by using the Microsoft tool for CD/DVD to flash drive. I have the disc in my hands but I need to make a USB drive in order to run the repair, at least this is what I think. Another option is that they used a temporary CD/DVD while installing.

I am looking for some ideas what can be failing all the installs. There can't be any virus because I haven't even connected to the Internet from that PC. It is a blank install. Unfortunately, I can't ask the company guys until Friday because 24th and 25th are holidays. It is very interesting how I got the NVIDIA drivers, Microsoft Security Essentials installed but can't install anything.

Thank you very much in advance.

EDIT: Problem solved.

For some reason, the flash drive I saved the files to is corrupted. And the corrupted files, copied to the SSD of the new PC are still corrupted and can't install from them. Using another external HDD, I was able to install and do everything as expected. For now the problem is solved.
Tricky one.

Attached Images
Can't install any program on my new PC-aida.png Can't install any program on my new PC-devcpp.png Can't install any program on my new PC-windowsinstaller45.png Can't install any program on my new PC-portable.png 
My System SpecsSystem Spec
24 Dec 2014   #2

Windows 7 Ultimate 64-bit, Windows 8.1 64-bit, Mac OS X 10.10, Linux Mint 17, Windows 10 Pro TP

I just renamed my user account and set a password
My thought would be that the renaming process messed things up, Windows doesn't really like that. Might try creating a New User as Administrator and try again, could use the same name but with one character difference like maybe a number at the end then reboot into it. If that works you could then delete the 'bad' account and if any data you want to keep you'll be given a choice to save it.
My System SpecsSystem Spec

 Can't install any program on my new PC

Thread Tools

Similar help and support threads
Thread Forum
How to install 32 bit program??
I am trying to download a program that will only work in 32 bit mode. It seems to me that some programs give you the option of either running in 32 or 64 bit but this program doesn't. The program has a *.msi extention. Don't know if that means anything ??
every program install asks what program to use.
Win HP dual core. I found several viruses and removed them. Now, if I want to install any program, the window pops up asking what program I want to use to open it.:huh: If this is the wrong forum, please advise. Thanks to all who help.
Program refusing to install in standard program files folder
I have an Advent (PC World brand) Laptop that comes with its own custom On-Screen Display software. The software is made for 32 bit Windows with no 64 bit version available as far as I'm aware. I have upgraded to 64 bit Windows recently and everything seems to work great except the OSD. ...
Can't install program - Program Data folder permissions?
I'm trying to instal Skype on my PC and I keep getting this error message: 'An error occured while attempting to create the directory: c:\ProgramData\Microsoft\Windows\StartMenu. This is what I've done to try and remedy it: 1. Right clicked the installer file and tried to run as...
Unable to remove old program and thus can not install new program Help
Hello to all, Hoping someone can assist. I have been using a program called Raw Therapee. I downloaded a new version and on installing it quit saying the old version must be removed. I could not find it listed in Revo Unistaller Pro, so I did a forced uninstall with the location of the main...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:01.
Twitter Facebook Google+