Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Issues related to missing api-ms-win-downlevel-advapi32-l1-1-0.dll

03 Jan 2015   #1

Winsows 7 Pro 64bit
Issues related to missing api-ms-win-downlevel-advapi32-l1-1-0.dll

Hi, hope I'm posting in the right area...

Also hope someone can shed some light on this issue, or rather series of issues.

Main manifestation is that folders open in new window (though set to open in same window), plus unable to drag & drop between folder.

However, IE wouldn't start either, throwing up an error;

The program can't start because api-ms-win-downlevel-advapi32-l1-1-0.dll is missing from your computer. Try reinstalling to fix this problem.
Downloaded IE11-Windows6.1-x64-en-us.exe, but it won't run/complete stating (partial);

'... more recent version of IE is installed'.

Uninstalled IE via Control Panel/MS Updates/Uninstall - no longer listed (though folder still exists in Program Files folder).

Installer error still suggests 'more recent version of IE is installed'.

Further; using Notepad, when initially saving several (beyond twenty) errors show concerning missing api-ms-win-downlevel-user32-l1-1-0.dll and api-ms-win-downlevel-shlwapi-l1-1-0.dll - click through all then able to save (subsequent saves of file not an issue).

I did read (elsewhere) that a Windows Repair would do the job but the Windows install disc won't run, a couple of errors come up one being api-ms-win-downlevel-user32-l1-1-0.dll, plus another including;

WinSetup.dll 'The file may be corrupt', and 'Error code: 0x7E'.

I think that is all I have encountered so far.

Is it a matter of installing the missing files? If so where would one get them?

(No real rush, as and when).

Thanks in advance.


My System SpecsSystem Spec
07 Jan 2015   #2
Sean Wang

Taipei ( 臺 北 縣 / 市 )

Hey !!

I think I am having quite the same problems here!!!! ><

Have your solved your problem yet?!?!

If you solved it, how?
My System SpecsSystem Spec
07 Jan 2015   #3

Winsows 7 Pro 64bit

Hi Sean,

I'm afraid I haven't yet resolved the issue. It is increasingly looking like the only option is a fresh install of Windows (and all that that entails). In the words of Bonnie Tyler:

I need a hero
I'm holding out for a hero 'til the end of the night
He's gotta be strong
And he's gotta be fast
And he's gotta be fresh from the fight
I need a hero
I'm holding out for a hero 'til the morning light
He's gotta be sure
And it's gotta be soon
And he's gotta be larger than life
Holding out until the end of the week, at least.

If you come across anything I'd appreciate a heads up.

Good luck!
My System SpecsSystem Spec

07 Jan 2015   #4
Sean Wang

Taipei ( 臺 北 縣 / 市 )

I found this thread, and after having some reading, thinking this man should having the same problem:
64 bit - How to fix missing DLLs and corrupt system files after updating Windows-7? - Super User
I think we can merge the discussion/respond there? ha

I think I will follow the instruction here, (later when i have more time):
Use the System File Checker tool to repair missing or corrupted system files
and use the method described:
"How to manually replace a corrupted system file with a known good copy of the file"
My System SpecsSystem Spec
11 Jan 2015   #5

Windows 7 Professional

The results from the following page helped me resolve my "dll missing" problem. May be they will help you guys as well:
My System SpecsSystem Spec

 Issues related to missing api-ms-win-downlevel-advapi32-l1-1-0.dll

Thread Tools

Similar help and support threads
Thread Forum
3 Separate USB Issues that I suspect are related!
I have 3 separate USB issues that for some reason I suspect are related, none of these issues were occurring 2/3 days ago but now they are all occurring. Here they are: Netgear WG111v3: This would usually instantly connect to my modem upon starting my computer, now it rarely does that and I...
Hardware & Devices
Last Updates Related Issues
I'm using 2009 Toshiba W7, etc... The other problem-- not related to browser --related to my start-up ---and that now appears to be fixed, since i went to my Toshiba page and downloaded some file. Sorry I forget what it was not BIOS related tho, as best as i recall(?) So first I...
Windows Updates & Activation
Partition Issues - Possibly MBR related
Hello everyone. It's a long story and I'll try to explain my problem in detail. So, please bear with me if it's long. :) First of all, the OS I was using was Windows 7 ultimate, 64 bit. The Background I had four partitions on my 1TB hard drive and I wanted another one to install Ubuntu....
General Discussion
31% of Windows 7 issues are related to OS installation
More at: 31% of Windows 7 issues are related to OS installation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:21.
Twitter Facebook Google+