Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: 0x643 .Net Framework Error... Can't install ANY net framework

09 Mar 2015   #1

Windows 7 64bit 7600 Professional
0x643 .Net Framework Error... Can't install ANY net framework

Tried everything. From adding full user control to trusted installer and creator/owner in Windows/Microsoft. net and Program Data directories to therepair service verifier, making sure virus scanner is off, fixit solutions, sfc /scannow's clean bill of health, uninstalling a few upgrades mentioned with .netframe 4.0 and 3.5 etc etc. I get a fatal error if I try to uncheck .net 3.5 (the only version I can see since all other have been uninstalled) in 'turn windows features on and off), smartmsizap, msiinv, Smart boot(cold boot? with the startup items not checked and initial boot config). I think something is wrong here with either registry or program permissions because the initial 4.5.1/4.5.2 install zips to a random c:/ directory and then it asks me to find netfx_core_x64.msi which I point to in that directory, but says it is not the netfx_core_x64.msi that came with the installation.

As of current, I do not have any working .net framework which is bad because 1) some progrmas, ie video games require it 2) my schoolwork/development environments need it for things like Git

Another weird thing is although I manually installed net framework 1.1, only 3.5 shows up in the 'turn windows features on or off' and I can't 'uncheck' it or add the sub trees underneath it. Almost like it is not there but doesn't want to install additional componenets or be completely uninstalled.

Drive files here:

My System SpecsSystem Spec
09 Mar 2015   #2

Windows 7 64bit 7600 Professional

BUMP please help ;(
My System SpecsSystem Spec

 0x643 .Net Framework Error... Can't install ANY net framework

Thread Tools

Similar help and support threads
Thread Forum
framework\v3.0\wpf error message
I installed a Neat Company product. It installed fine, but when I tried to run it, I got the following: “C:\Windows:\\Framework\3.0\WPF\wpfgfx_v0300.dll is either not designed to run on Windows or it contains an error” Can anyone tell me how to locate and install this...
General Discussion
. NET Framework 4 updates made before Framework 4 was installed – upda
I installed the latest updates to .NET Framework 4 and later installed software that required me to install .NET Framework 4. Would be updates still be in effect or should I install them again?
Windows Updates & Activation
.NET Framework Installation Error
I royally screwed up. I tried to fix the CLR error 80004005 by uninstalling all .NET Framework versions my computer. After that, I restarted and tried to install the .NET Framework 4 on my computer. It downloaded the files, installed for maybe 1 minute and then says "Installation failed" without...
Installation & Setup
Microsoft Framework 4 (x64) error
Hi all. I am trying to install Microsoft Network Framework v.4 (x64) and I keep getting error "Final Result: Installation failed with error code: (0x80070643), "Fatal error during installation. " (Elapsed time: 0 00:01:01)." The exact log file is attached: OS Version Information: OS...
General Discussion
Microsoft .NET Framework Error
Hello, I have a big problem. I have searched the internet for solution and try to make it self. But i cant make it. I had this error from Microsoft .Net Framework box. This was the message that i must type from the error box. And there is a Detail button that i can copy paste -.- . I...
BSOD Help and Support
.NET Framework Initialization Error
I want to begin by saying how stupid i am. My computer was starting to get slow, and i did a power clean in it. The thing is, i think i cleaned way too much. Now some links are not working, for instance if i press properties in Computer, in start, it won't do anything. But if i search for...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 08:31.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App