Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: UAC problem with one program only

14 May 2015   #1

win 7 64 bit professional
UAC problem with one program only

Hello all- here is my first post:

I installed a program call CWSkimmer (HAM radio usage). It will not properly run unless I run it as Administrator. This should not be the case.

I contacted the author but he is unable to resolve the issue, and says it's never been reported before. Also tried the program user forum, and was told "turn off UAC". which I don't think is a good idea.

when I start the program I get an error: violation at address 0040DD3 in module 'cwskimmer.exe'

Read of address 00000000

Author thinks some sort of Windows security issue. Running Win7, in a user account.

NO error if I run as Admin.

I went through all folders both in program files and App data. Found and fixed a few folders to FULL CONTROL. Also changed owner ship to my USER account.

Still have error

Any help would be appreciated.

Thanks Dan

My System SpecsSystem Spec
14 May 2015   #2

64-bit Windows 10 Pro

Hello Dan,

If you like, you could use option 5 or 6 in the tutorial below to set the program to always "Run as administrator" when opened. This way you wouldn't have to manually "Run as administrator" each time. :)

Run as Administrator
My System SpecsSystem Spec
14 May 2015   #3

win 7 64 bit professional


thanks for reply.

Yes I am aware of those work a rounds.

I am looking to get to the root issue, and correct it, so an not to require admin to run program.

bye the way, program runs as it should on my laptop, win 7 also, but home edition vs pro on desktop.

so what is the difference then to cause this problem?

thanks dan
My System SpecsSystem Spec

14 May 2015   #4

64-bit Windows 10 Pro

If you haven't already, you might see if uninstalling and reinstalling the program may help.
My System SpecsSystem Spec
14 May 2015   #5

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

I used to get very smilar error message when launching MJRegWatcher. All I can say is that it was down to security software - specifically Comodo's HIPS rules that needed modifying.

UAC problem with one program only-hips.jpg

So as a test I might suggest disconnecting from the internet then disabling any security software that could be interfering with the application - then try launching the application. If the problem remains - at least you've ruled out security software as the culprit.

My System SpecsSystem Spec

 UAC problem with one program only

Thread Tools

Similar help and support threads
Thread Forum
Program Problem - Program won't open - No Error Messages
Ahhh back to the experts. I have a rather unusual, 'never happened before', problem. When I click on one particular shortcut either on the desktop or elsewhere it flashes real quick on the screen but does not open. The program is Webroot Window Washer which is no longer available nor is support....
Problem with Program Allocation - need help please
Hello I have a problem on my Windows7 laptop when clicking on internet shortcut links... When I try to opening a link, Windows no longer knows what to open it with and tries defaulting to MS Word. I've tried selecting in the usual way and ticking the box to have either IE or Firefox to open...
General Discussion
problem with the Fax and Scan program
Hello , I am using the Fax and Scan program in windows 7 since 2009 with no problem al all until yesterday when a message on the screen put an end to this . Trying to send a Fax received the message : " The document couldn't be sent because the Media is write protected ." What should I ...
General Discussion
Problem regarding program shifting
I often get these weird bugs on my windows 7 where in i have trouble moving from one program to another via task bar, and if I use alt tab, the program underneath the program above is non responsive, and if I alt tab back to the program I was using previously that one works fine. I some times get...
General Discussion
startup program problem
hi. i have a problem with my startup programs. i've just installed the same version of windows that i had till now. the problem is that it won't run one of my shotcuts in the startup folder. it's the connection to the internet. it used to work, i just drag and dropped it in the startup folder in...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:55.
Twitter Facebook Google+