Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Testdisk Urgent Help

17 Jun 2015   #1

Windows 8.1
Testdisk Urgent Help

Hello community

i need urgent help here, i have a usb sony vaio 2.0, 2TB exfat, and i don´t know why, it´s been a headache to solve this, because all information regarding that kind of error, the CHS and LBA conflict, or is a mess to understand, or is incomplete, and i need someone that can tell me step by step please, how can i solve this problem to get my pen back

i have "None" partition table type has been detected
i click on "Intel" option
and get the
Warning: Bad starting head (CHS and LBA don't match)
Only one partition must be bootable
Space conflict between the following two partitions
4* Xenix Bad Block
1* Xenix bad block

i choose the intel option, and the result was the first photo

Now, i have made another analysis, and the result of this one, was different from that first photo (see 2nd photo attached).

Made another one and now i have only 2 options, and one of them is (create partition pressing in "A"), but i don´t know what to choose from here, because it asks me for the "Geometry, Head, Type, Sectors", and i don´t know nothing about this, i read all the articles related to this, but none has been conclusive, or none says me what to put under this configuration.

as a last resort i can do another analysis, and see where that log file goes and posted here, if that photo, and my description doesn't help you.

Thank you very much in advance, and if you can tell me something, that would be a great help.

Attached Images
Testdisk Urgent Help-1.jpg Testdisk Urgent Help-2.jpg Testdisk Urgent Help-3.png 
My System SpecsSystem Spec
17 Jun 2015   #2

Windows 7 Ultimate x64 SP1

Did you try partition wizard free to recover the partition/s?

How to Make Partition Recovery | MiniTool Partition Wizard Tutorial
My System SpecsSystem Spec
17 Jun 2015   #3

Windows 8.1

Hello my friend and thank you for your answer

the thing is that when i plug in the pen, it is recognized has a exFAT primary partition, but when i try to format, windows doesn´t let me, i tried all kind of programs to format the pen, but i didn't have success with no one.

so i tried testdisk, and i´m stuck in this problem, because i´m newbie with the program, and i already tried to look for an anwser, but no one reply to those threads that i found.

that´s why i need help
My System SpecsSystem Spec

17 Jun 2015   #4

Windows 8.1

Also when i try verifying the disk with the tool from windows, from bad sectors or corrupted, it says that have none and everything is ok

i just can´t understand what is happening
My System SpecsSystem Spec
17 Jun 2015   #5

Windows 8.1

Here are some screen shots of what happens after analyse

When i click create partition, appears some things that i don´t understand like "geometry", "Head", "Type", "Sectors", and here is where i get stuck, because i don´t know the wright values to input, and i can´t pass from this menu.

Attached Images
Testdisk Urgent Help-screenshot-2.png Testdisk Urgent Help-wpetestdisk012.jpg 
My System SpecsSystem Spec
17 Jun 2015   #6

Windows 7 Home Premium

I assume you are connecting your USB drive to a Windows 7 computer.

Why are you using the TestDisk program?

What happens when you plug in to the Windows computer? Does the USB Pen show up under "Computers"? If so can you right click on Computers and go to "Manage".
You should not need any other program to format your USB to exFat (windows 7 SP1 can do it) see
My System SpecsSystem Spec
17 Jun 2015   #7

Windows 8.1

Hello my friend and thank you for your answer

I´m running under win 8.1
The pen is detected, but i can´t do anything, with all related tools from widows, with it

Disk manager, she shows up, i try to format it, and just stays there without moving, then he ejects the pen by itself, and the drive disappears, i try to verify the pen with windows tools, for errors, says everything is ok.

When i start win. with the pen inserted, windows says it cannot recognize it, and advise me to unplug and plug in the pen again.
so i don´t know what is going on, and i read, and read, and read, and everything lead me to testdisk.

but now i´m stuck, because i can´t find the wright values/instructions from the menu that i´m in.

And this is the major problem, the pen is only recognized once, if i do anything, he eject the pen after he can resolve any issue with it, so i have to unplug an plug in again the pen, several times.
My System SpecsSystem Spec
17 Jun 2015   #8

Windows 7 Ultimate x64 SP1

Try with partition manager free, I thought you were trying to restore it. Can't link at the moment but search for imageusb osforensics and try that one too
My System SpecsSystem Spec
17 Jun 2015   #9

Windows 8.1

my friend thank you for your kind help, but the headache continues, and the results are;

imageusb osforensics i tried to zero the USB, failed was the result, i tried to reformat, error size unknown

Partition Manager, let´s me format the drive, but in windows, he presents it has exFAT, when i choose FAT32, and when i try to format under windows, same error windows can´t format it

Thank you my friend for your kind attention, other sugestions will be appreciated
My System SpecsSystem Spec
17 Jun 2015   #10

Windows 7 Ultimate x64 SP1

Hmm , Partition Manager might have been a typo
Try Partition Wizard free
Also Download BOOTICE 32-Bit - MajorGeeks make sure you get the correct bit version (64bit link on page)
My System SpecsSystem Spec

 Testdisk Urgent Help

Thread Tools

Similar help and support threads
Thread Forum
How do I make bootable media which includes TestDisk?
How do I make bootable media which includes TestDisk? I have TestDisk files ready to load onto a DVD and a USB stick; mostly for use on Windows 7 NTFS HDs. How do I create a bootable DVD and a bootable USB stick that will have TestDisk ready to go to work?
Backup and Restore
Recover a flash drive turned RAW – Partition Wizard and TestDisk.
Of late a lot of interest has been generated in using the Partition Recovey Wizard of MiniTools Partition Wizard (PW). Venerable gregrocker brought out a new feature – extending a partition with even non-adjacent space - in the MiniTools Partition Wizard (PW) here:...
Booting Issue (TestDisk / PartedMagic)
Here's an update: Original problem was that I was receiving an unmountable boot volume error with a BSOD. After taking a stab at a few solutions the situation is now this. Upon being able to enter the recovery console the only Windows 7 installation showing up on the list is the system recovery...
BSOD Help and Support
Hi Guys, This is quite a long story, So let me get straight to the point. :) On my Dell Optiplex 360 Computer (Windows 7-Ultimate) I partitioned the hard drive to make space for another windows installation. I then installed Windows Vista Ultimate on it. All of that went successfully but...
Installation & Setup
Anyone famliar with testdisk utility? hard drive problem.
my external harddrive seems to have crapped out on me. I'ts just one data partiotion.I go to computer/manage- disk manager and it takes like 5 minutes to even show the drive. Windows can't access the external harddrive. It was saying I had to format it and was being reported as raw. I'm running...
Hardware & Devices
[URGENT] All System Restore Point Gone!![/URGENT]
The problem occurred when I made a standard user account and through that i redirected to the admin profile under c:/Users/xxxx and i right clicked the profile>properties>security> and i removed the standard account access to that admin folder and got some "Access denied error". After i logged off...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 08:19.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App