Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: .net framework error

06 Aug 2015   #31
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

After going through this thread again I agree with UsernameIssues.
A repair install should fix your problem.
Before you start with the Repair Install make sure you have your COA key handy.

My System SpecsSystem Spec
07 Aug 2015   #32

Windows 7 VL (64-bit)

Thanks all for help. However, I am not going to repair the whole OS as I am afraid it will bring out further system issues after I do this.
My System SpecsSystem Spec
07 Aug 2015   #33

Microsoft Community Contributor Award Recipient

Win 7 x64 Home Premium (and x86 VirtualBox VM)/Win10

A Repair install is more likely to FIX system issues than to create them - unless you have a highly modified install.
My System SpecsSystem Spec

09 Aug 2015   #34
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

tkrojam can you tell us what kind of issues you think a Repair Install will cause you.
My System SpecsSystem Spec
06 Nov 2015   #35

Windows 7 Prof. x64

Hey guys,

I have the same issue I think. I posted it already at

This issue has a case-history --> Windows updates KB3001652 & KB2901983 installation problem (Error 643)

Now, the story goes on: I wanted to upgrade to .Net Framework 4.6. However the installation stopped soon - again - with error code 643 I tried to uninstall KB3008627, KB3000988 & KB2918614 (workaround which helped to install v4.5.2) but they weren't installed again by Windows update since I removed them some months ago. So I tried some FixIT solutions by M$ (.Net Repair ...), sfc -scannow (no errors) and other tips. Nothing helped and everything looked/looks like the first time: completely mysterious.

However I have found now two workarounds which help to get things working. It is definitely no solution which fixes the underlying problem but a shabby workaround.

ATTENTION: I don't know if these steps will cause other problems in future. Therefore you do this on your own risk!!! You need only one of those two methods to get it working. Don't ask me which one is less bad - I don't know.

First method:
1) rename folder "S-1-5-18" in C:\ProgramData\Microsoft\Crypto\RSA\ to "S-1-5-18_bak" or sth. like that
2) Run .net installer again. A new folder "S-1-5-18" should be created automatically during installation. More important: the installation should be successful now!
3) Interessting thing: if you don't install .net after the "S-1-5-18" folder was deleted, and you reboot your PC a new "S-1-5-18" folder gets created. If you open the folder you will be asked for permission. When you proceed and start the installation afterwards, it will fail as it did before! So accessing the folder (after having deleted it) will again prevent .NET installations! I don't know why and how this folder is interconnected with the issue... probably only M$ knows this. Perhaps.

Second method:
1) Whitelist the installer -> Link
2) Delete the registry hacks (if the issue occurs again in future with an M$ .msi package, you will have to add the registry keys again)

Here, I have a collection of some interesting links which are related to this "crypto-issue":

Error 997. Overlapped I/O operation is in progress: KB2918614 breaks Windows Installer Service - Microsoft Visual Studio/.Net Framework Setup & Deployment Tips & Tricks - Site Home - MSDN Blogs
installation - .NET 4 fails to install because SECUREREPAIR fails to CreateContentHash of file SetupResources.dll: for computing hash Error: 997 - Stack Overflow
Failed Visual Studio 2015 installation - Stack Overflow
.net framework error
What does C:\ProgramData\Microsoft\Crypto\RSA\S-1-5-18 use for ? why is it causing vcredist 2010 and 2008 not to install - windows 10 - Windows 10

It looks like this is a widely spread problem. And again: not only .NET Framework is affected but many other M$ applications respectively M$ .msi packages. For me it looks like update KB2918614 broke many Windows installations

Both workarounds work for me. In each case when I uninstall .NET framework and remove the used workaround the subsequent installation will fail again. So I can easily reproduce the installation issue.
Can someone help me finding the root cause? I hate workarounds (which may lead to future errors). Here are the two log files I get when the installation error occurs: OneDrive

Please tell me if I can provide you more information. Thanks
My System SpecsSystem Spec
05 May 2017   #36

Windows 7 VL (64-bit)

Quote   Quote: Originally Posted by pustekuchencake View Post
1) rename folder "S-1-5-18" in C:\ProgramData\Microsoft\Crypto\RSA\ to "S-1-5-18_bak" or sth. like that
2) Run .net installer again. A new folder "S-1-5-18" should be created automatically during installation. More important: the installation should be successful now!
This worked like a charm and allowed me to complete my installs. Hopefully someone else will find it useful.

My System SpecsSystem Spec

 .net framework error

Thread Tools

Similar help and support threads
Thread Forum
0x643 .Net Framework Error... Can't install ANY net framework
Tried everything. From adding full user control to trusted installer and creator/owner in Windows/Microsoft. net and Program Data directories to therepair service verifier, making sure virus scanner is off, fixit solutions, sfc /scannow's clean bill of health, uninstalling a few upgrades mentioned...
. NET Framework 4 updates made before Framework 4 was installed upda
I installed the latest updates to .NET Framework 4 and later installed software that required me to install .NET Framework 4. Would be updates still be in effect or should I install them again?
Windows Updates & Activation
Microsoft .Net Framework Error
Hi, Everytime that I boot my laptop a small error box pops up with the title 'Microsoft .NET Framework'. It says: Unhandled exception has occured in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will...
BSOD Help and Support
.Net framework application error
I am trying to run an application but coming across this error. It seems to run perfectly fine on another machine that i have which is near enough an identical build to the other one. Any help would be apprieciated. thanks.
BSOD Help and Support
Micorosft .NET Framework error
I've tried to reinstall net framework. still same error appears time to time...what to do?

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:54.
Twitter Facebook Google+