Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Rosetta Stone Version 2 won't run

12 Sep 2015   #1

Windows 7 Home Premium x64
Rosetta Stone Version 2 won't run

I own Rosetta Stone version 2 software and still have the original disks (2 disks, one to install, one to run). When I first bought it years ago I was able to install and run it just fine on XP and later, Vista.
Now I'm trying to use it on Windows 7 Home Premium SP1. I installed it successfully (from what I can tell) from the application disk, but the software does not run. When I open up the installed desktop shortcut (as administrator), or go into the run disk and open the .exe (as administrator), I get no reaction. It opens up 3 processes in task manager, but they last only about 2 seconds and no application is opened. This repeats exactly the same every time I try to run the .exe. If I DON'T run as admin, I instead get an autorun launcher that tells me I need to run with elevated permissions when I click its run button.
Here's what I've tried:
1. Ran as administrator. Only change was the autorun launcher didn't open.
2. I ran in all of the available compatibility modes for legacy OS's. I got the same results as described above for each one.

That's all so far...any ideas?

My System SpecsSystem Spec
12 Sep 2015   #2
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot

Is this just a recent problem? Like within the last week or two?
My System SpecsSystem Spec
12 Sep 2015   #3

Windows 7 Home Premium x64

Yes, because I haven't tried installing it on my Windows 7 PC until now. It's been years since I've used the software.
My System SpecsSystem Spec

12 Sep 2015   #4

OEM Windows 7 Ult (x64) SP1


As of 2011, Rosetta Stone version 3.0 was NOT compatible with Win 7.
See here: Can't install Rosetta Stone Version 3 in Window 7

So, I would guess that version 2.0 will not be compatible in 2015, either???

Might need to contact Rosetta Stone to see if there is some sort of compatibility pack?

Please let us know if you find a solution.

My System SpecsSystem Spec
12 Sep 2015   #5

Windows 7 Home Premium x64

Ah, I was having trouble finding anything about compatibility. Thanks for that. I'll let you know what I find out.
My System SpecsSystem Spec
12 Sep 2015   #6

OEM Windows 7 Ult (x64) SP1

Well, according to their website, the current version is v. 4.

Since this is paid software, my guess is that you are going to be out of luck trying to run such an outdated version on Win 7.
I would be surprised if it's supported and if they provide any means to do so.

You might have to pony up to renew your subscription or pay for the new version.

<just saying>

My System SpecsSystem Spec
12 Sep 2015   #7

Microsoft Community Contributor Award Recipient

Win 10 Pro x64

Microsoft claims it's compatible,

Rosetta Stone Version 2 won't run-2015-09-12_17h43_52.png

There is no option to choose architecture versions like there apparently was in 2011.

Windows 7 compatibility for Rosetta Stone Spanish Level 1-2 Personal version 2

My System SpecsSystem Spec
12 Sep 2015   #8
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot

It may be the copy protection. Microsoft has recently pushed an update which is causing no end of hassles with programs and games using SecuROM and SECDRV. I've experienced it myself.

Try this procedure. Execute the following commands in a batch file:

start cmd.exe /k "sc config secdrv start=demand" 
start cmd.exe /k "sc start secdrv"    
Then try running Rosetta Stone

After you're done, you can shut off secdrv by running this code in a batch file:

start cmd.exe /k "sc stop secdrv" 
start cmd.exe /k "sc config secdrv start=disabled"
The /k switch just keeps the windows open, you can change it to /c if you like, which will close the window for you. I put this into a couple of batch files so it's easy to run when I need to start Civilization 4, which is also affected by this little mess from Microsoft.
My System SpecsSystem Spec
23 Feb 2016   #9

windows 7 32 or 64 bit, vista, xp

in fall of 2015 windows published an "important" update that makes v2 Rosetta stone not work. A window pops up asking the used to log in with administrative privileges or some such. After some searching I figured out that the update is KB3086255. If you uninstall this, and don't let your computer automatically install it again (set the setting to where you choose which updates to install) your Rosetta Stone v2 with Student Management System will work fine in xp, vista, windows 7 and windows 8/8.1. I haven't had any adverse effects from uninstalling this that I am aware of.
My System SpecsSystem Spec
17 Jan 2017   #10

Windows 7 64-bit
Rosetta Stone version 2 will not load

Thanks, I searched for and uninstalled KB3086255 and all is OK now. Quick and easy.

Wish I had tried this before uninstalling and installing the RS application disc umpteen times and trying other remedies.
My System SpecsSystem Spec

 Rosetta Stone Version 2 won't run

Thread Tools

Similar help and support threads
Thread Forum
Fatal Application Error #1141 - Rosetta Stone Totale
When i try to open Rosetta Stone Totale, it gives the error "Fatal Application Error #1141" It's one of my customer's computer running windows 8. Thank you for help in Advance
Rosetta Stone advice
Spring greetings all! So here is my situation, I want to use the Rosetta Stone language learning software soon, but my old desktop mic died on me. I could replace it, but, I'm planning on buying a Bluetooth headset to pair up with my Nokia Lumia 900 running Windows Phone 7 when it comes out...
Can't install Rosetta Stone Version 3 in Window 7
My old computer recently crashed. It was 32 bit and the OS was Windows XP. Back when the Windows XP computer worked I bought and installed Rosetta Stone (Version 3). I am trying to install Rosetta Stone on my new computer but am having the following issue. When I insert the installation CD, the...
Windows 8 Nothing Is Set in Stone
What's This? The Rosetta Disk
Chillout Room

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:34.
Twitter Facebook Google+