Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows installer Service is not correctly installed

10 Nov 2015   #1
tnnr789

Windows 7 Ultimate, Service Pack 1, 64 Bit
 
 
Windows installer Service is not correctly installed

I'm currently trying to clean up an old laptop that we had laying around the house for possibly school. It had been ages when I had initially powered it on. I'm not sure who the last person to use it was, but they did a number on it.

So upon first boot, when it finally came to the desktop screen the task bar flashed into sight, and then gone, as well as desktop icons. I got a prompt saying windows explorer was no longer working, and would try and fix it upon next restart. I was stuck in that loop for a while until i finally got to where I could make a new account, which worked.

Once I got into the account, I started running avast immediately, full system scan. It found roughly 20 viruses, and then wanted to perform a boot scan as well. I restarted and let it run through it's scan. Found another 20 or so.

In the end, here I am trying to uninstall unwanted programs to hopefully speed up the machine a little bit. When trying to uninstall in normal windows, it just comes up with a prompt saying that it will begin the uninstall shortly. So i thought it might work, but two days later it still said that. So i restarted in safe mode in hopes that I could do it that way. Now I am getting "The Windows Installer Service could not be accessed. This can occur if the Windows Installer is not correctly installed. Contact your support personnel for assistance." any time that I try to uninstall from safe mode.

Any help would be greatly appreciated


My System SpecsSystem Spec
.
10 Nov 2015   #2
tnnr789

Windows 7 Ultimate, Service Pack 1, 64 Bit
 
 

Update: I'm also noticing that any time I go to shutdown my machine a handful of popup webpages show up. I had noticed when running my first full scan with avast that it would give its popup notification saying that such and such was being blocked, and that would popup roughly 200x during the scan. and prior to me being able to scan it would do that too.
My System SpecsSystem Spec
10 Nov 2015   #3
Pauly

Win7 Ultimate X64
 
 

If the machine is old and contains no useful data you could always wipe the hard drive and clean install windows for the best possible install and to get the machine running at its optimum speed ??

Clean Reinstall - Factory OEM Windows 7
My System SpecsSystem Spec
.

Reply

 Windows installer Service is not correctly installed




Thread Tools




Similar help and support threads
Thread Forum
Windows 7 installer service could not be accessed
I have tried all the suggestions I can find, including the ones listed here 2+ years ago. I tried MS's repairs, the unregister, etc. Any ideas?
General Discussion
windows defender service does not exist as an installed service
I get an error stating windows defender service does not exist as an installed service 0x80070000424 I don't have microsoft essential. It was working fine until today. When I open the program and click on tools and others it will not click at all. Also, real protected is off. Also, its not under...
System Security
The Windows Installer Service Could Not Be Accessed
Windows 7/64 HP Sp1 - I was brought 2 systems today with the above error, ie unable to install or uninstall software. Both system use different AV (McAfee in one case and AVG in the other). I have not seen this error on Win 7 before, then 2 come in a row! In the first case the client had tried...
Software
Windows Installer Service
I do not have a Windows Installer listed in my Services and keep getting error 1719 when trying to install software. Any help with this would be appreciated.
General Discussion
Windows Installer Service problems
After downloading an update for the latest version of Itunes, I keep getting a message saying 'Windows Installer Service' could not be accessed. I have checked that the Windows Installer is running and that I am not in 'Safe Mode'. Often (but not always) the Installer shuts down some time during...
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:04.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App