Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Runtime error trying to launch Cyberpower PowerPanel personal edition

31 Dec 2015   #1

Windows 7 Home Premium 64 bit (Service Pack 1)
Runtime error trying to launch Cyberpower PowerPanel personal edition

Hello all,

I can't run Cyberpower's PowerPanel on my Win 7, 64 bit computer. It downloads and seems to install ok but as soon as I launch it I get the common Visual C++ runtime error abnormal termination error. It at least launches (although doesn't operate quite correctly) when I change the user on my computer which leads me to think it has to do with security or permissions? It also runs fine on two other laptops we own. I have tried everything to solve this including:

installing and reinstalling PowerPanel multiple times
uninstalling and updating all Visual C++ runtime redistributables
virus scan (no problems)
sfc /scannow (no problems)
clean boot (disable all startup, disable all services)
safe mode
safe mode with networking
disk cleanup in system tools

None of the above solved the problem.

The fact that it will at least launch and run when I change users on my computer gives me hope! Otherwise I am pulling my hair out! Thanks for any help!

My System SpecsSystem Spec
15 Jan 2016   #2

Windows 7 Home Premium 64 bit (Service Pack 1)

Another tip on the above problem:

The program launches and runs perfectly only if I log in as Adminstrator. However it crashes with the C++runtime error if I log in as a regular user and run as regular user or use the "run as administrator" option while logged in as a regular user!
My System SpecsSystem Spec
20 Jan 2016   #3

Windows 7 Home Premium 64 bit (Service Pack 1)
Runtime error with Cyberpower Powerpanel (SOLVED)

This problem was solved (finally!) by deleting the following file folder and then reinstalling:

C:\USERS\username\Appdata\Powerpanel Personal Edition

I assume the security/permissions on the above program files or folder were somehow corrupted during the first installation and could not be fixed with a reinstall.
My System SpecsSystem Spec


 Runtime error trying to launch Cyberpower PowerPanel personal edition

Thread Tools

Similar help and support threads
Thread Forum
Microsoft Visual C++ Runtime Library - Runtime Error!
Hi everyone. I have a runtime error every time I try to load my SnapPea program, which I use to connect my android phone to my PC, to add photos. music, etc. It was working fine 2 days ago and I don't know why this is happening. I would really appreciate any help and I have attached the error...
BSOD Help and Support
Microsoft Visual C++ Runtime Library Runtime Error" error message
What do I need in order to fix this problem? This pop-up message appears when I patched my game
General Discussion
Runtime error this application has requested the Runtime to terminate
Hello, I hope someone can help. I have been using Cucusoft YouTube Mate for a long time and suddenly today I get this message: runtime error "this application has requested the Runtime to terminate it in an unusual way" I'm not very computer smart and I don't understand why this has...
General Discussion
Microsoft Visual C++ Runtime Library error, error message 00289x01849
Hi, I'm worried about this Microsoft Visual c++ runtime library error... It happens, whenever i'm trying to do anything with my malwarebytes anti-malware. And even if I open the folder where i put malwarebytes exe, there also it shows this error.. Can anyone help me.. Thnks...
General Discussion
Personal Project: Windows 7 maxFPS Edition...need help with setup.
Hey all, I am new to these forums but have been referring to them for tips for a few months now. I am a dedicated gamer and have decided to make a custom copy of Windows 7 Home Premium just for gaming...I have decided to title it "maxFPS Edition". This thread however isn't about the content of...
Installation & Setup
CyberPower PowerPanel Personal edition Script error
I have a CyberPower "Intelligent LCD Series" UPS CP 1000AVRLCD added to my win7 pc. Lately when I try to open the monitoring console I get a script error I have removed the software and reloaded it, but this is not working. Any help would be greatly appreciated! N2
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:00.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App