Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: pidgen.dll missing when installing Age Of Empires III

21 Feb 2016   #1

Windows 7 home premium 64-bit
pidgen.dll missing when installing Age Of Empires III

I've recently acquired the 3 CDs required to install & play an old Game, Age of Empires III, officially said run with Windows XP and earlier. But it can be run under Windows 7, though many have difficulties: a small number of reports describe successes, and think that those who are successful don't bother to publicize it.

Onto my problem. Having overcome "setup.exe is not a valid Win32 application" or however it read, by cleaning the playing side of CD1, I reach entering the key, after which a window appears titled 'invalid product key' (which I have checked a number of times) message saying: "Error loading the PID Generator DLL. The DLL could not be found! Please make sure the file is available in the installation directory and try again". When I trying the said file (pidgen.dll) to my HDD, it says 'file cannot be found' after looking like it has started some copy operation. That is with Windows 7 Home Premium 64bit I've tried compatibility mode for XP, and 'Run as Administrator' (for setup).

I have also tried installing on XP (different PC) and it progresses far into the installation before I get a repetitive please insert Disk 2 message.

Can anyone tell me tell me how to install on Windows 7 (without reference to the rubbish shot-in-dark, I-don't what's wrong-but-we-would like you to waste-a-day trying out-these microsoft offerings)


HP Pavilion dm4-1050ea - i5 430M, 8 GB RAM - Windows 7 Home Premium 64bit

My System SpecsSystem Spec
22 Feb 2016   #2
Microsoft MVP

Windows 7 Ult. x64

Dear Idiot : good luck
My System SpecsSystem Spec
22 Feb 2016   #3

Windows 7 Home Premium 64-BIT

My System SpecsSystem Spec

22 Feb 2016   #4

Windows 10x64 Build 1709

Hmmmmmmmmm .......... well Idiot , I can only wonder why you haven't done a web search. Instead you come here and insult the people who may help you. I ask about the web search because in under 10 seconds I located the .dll file you need, downloaded it AND scanned it for malware ...... all in under 10 seconds. Oh, as an added bonus, there's even a tutorial there on the correct way to install it. Good luck with your quest!
My System SpecsSystem Spec
23 Feb 2016   #5

Windows 7 home premium 64-bit

Well, I am sorry for insulting anyone.

I had already done a web search (many in fact) before I started this thread or topic, located a copy of the file named pidgen.dll, downloaded it, and scanned it for malware (AVG free) then copied it both to C:\local disk\windows\system32 and C:\local disk\Program files (x86)\Microsoft Games\Age of Empires III (I had to create the last directory)[as I understand it this is the procedure for installing this file - another internet search result], but the game still would not install - same thing. I did notice a peculiar looking thing, the pidgin.dll I downloaded is not the same size (being ~ a third smaller) than the one on the game CD1

I will try another copy of pidgin.dll from a different source.

I have an update: eventually, I installed the game on my XP system an it appears to play ok (have't tried all options). I ha problems consistently reading the CDs which did not happen on my W7 mine (HP Pavilion dm4), so I deduced that there is a problem with the CD player in my old XP machine.

My System SpecsSystem Spec
23 Feb 2016   #6

Windows 7 home premium 64-bit

The version of pidgen.dll which I downloaded and copied to my c:\Windows\System32 folder on my W7 system is the identical size (same number of bytes, about 24KB) to the one I found on my XP system so I assume the files are identical. This leaves unanswered the question 'why is the file named pidgen.dll on the AoE III 1st install CD a different size (~39KB) ?' different version, maybe ? that shouldn't make any difference as the smaller file is certain to be the same or later version.

My System SpecsSystem Spec
29 Feb 2016   #7

Windows 7 Home Premium

Can you do this for me:

Search your System32 folder for a dll called "mfc42.dll", if you can't find it head on over to "C:\Windows\ServicePackFiles\i386" and copy said dll to "C:\Windows\System32\" folder.

pidgin.dll is dependent on mfc42.dll hence your problem.
My System SpecsSystem Spec
29 Feb 2016   #8

Windows 7 home premium 64-bit

Hi Boris,

Thank you for your interest in this topic

My folder Computer\Local Disk\Windows\System32 does contain the files
mfc42.dll (and mfc42u.dll)
pidgen.dll (24KB, because I downloaded it and put there manually having read about a similar issue on a WinXP system)

note: the folder C:\Windows\ServicePackFiles\i386 does not appear to exist on my W7 computer

I believe that the installation process may be finding the 39KB pidgen.dll on the CD and therefore does not look for it in Computer/System Disk/Windows/System32, but for some reason it cannot read/open this .dll (although this suggestion is not what it says in the error message). Further, I then hypothesize that making a copy of the CD CD1 but omit the 39KB pidgen.dll would cause the installation process to look in the HDD folder where it actually resides (or maybe copy the CD and replace the original 39KB version with the 24KB version). Any thoughts on that chain reasoning ? (or anything else in fact ?)

My System SpecsSystem Spec

 pidgen.dll missing when installing Age Of Empires III

Thread Tools

Similar help and support threads
Thread Forum
BSOD - page_fault_in_nonpaged_area (after installing Age Of Empires 2)
Hi, I seem to have encountered a problem after installing an old copy of Age of Empires 2. I now see a BSOD when running certain programs. The two different programs it has happened for are: Firefox - after typing in a URL, the BSOD appears VLC - When opening a file (only some - others work...
BSOD Help and Support
Problem installing Age of Empires online
Hey guys, I have a problem when i try download or install age of empires. I start the setup and secs later he show me this error: I have already installed the update for windows (Service Pack 1), thinking that was the problem, but still...
installing off USB, bootmgr missing?
Hi, I am trying to install windows 7 off of my usb harddrive and I get a "bootmgr is missing, press ctrl+alt+del to restart", it works on any other computer but the one I am trying with... I have tried formatting and running bootsect.exe again to no avail
Installation & Setup
One HDD is missing after installing Windows 7
Guys I need help. I had on my PC windows XP. Today I installed Windows 7. After instalation one physical HDD 500GB went missing. I have 3 physical drives: One HDD 250GB was split in 2 partitions: (C: E: Windows XP was installed on C: I reformated it with Windows 7 CD and installed on...
Installation & Setup
Win7 missing after installing xp
My problem is bit different, I installed XP AFTER windows 7 (rc) to get functionality of the old driver models. Now after installation my windows 7 is gone. I got 1 HDD C: was my win 7 partition, D: was my games n stuff partition and then I made new E: partition for XP and installed it on E:...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:49.
Twitter Facebook Google+