Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Netflix doesn't work on Windows 7 Internet Explorer

17 Nov 2016   #1

Windows Vista Ultimate 64-bit
Netflix doesn't work on Windows 7 Internet Explorer

Netflix movie thumbnails (including their links) don't show up. There's one "dash" per row in their place that turns into finger on mouseover but doesn't do anything.
However you still see the arrow navigation controls with "page indicator".
Works on Chrome.

Failed attempts to solve problem:
Uninstalled and reinstalled IE 11 and Silverlight (does it still use this?)

Any suggestions?

Thanks! :)
My System SpecsSystem Spec
19 Nov 2016   #2

Windows Vista Ultimate 64-bit

I found the problem.

On Maximized mode, the Explorer Bar messes it up.

When I narrow the Explorer Bar a bit, the page displays properly. It also display's properly in Windowed mode. Like when I drag the windows off the Top Snap position, the page magically appears properly.

Does this happen to anyone else? Or am I the only one using Windows 7 still? :P
My System SpecsSystem Spec
13 Apr 2020   #3

Windows 7 Pro x64

Late to the party... add Netflix to Compatibility View; it will get rid of all the overlays and allow you to navigate and search accordingly
My System SpecsSystem Spec


Thread Tools

Similar help and support threads
Thread Forum
Search doesn't work in Windows explorer
The search in Windows explorer has been working inconsistently in my mother's computer for as long as I remember. There are several folders where no results are displayed whatsoever, no matter what you search for. Solutions I've tried so far: Using the Windows built in Troubleshooter for...
Performance & Maintenance
[HELP] Internet Explorer 10 doesn't work with some custom shell32.dll
I've modified the icons in my shell32.dll using Resource Hacker and when I've applied it Internet Explorer fails to start. It gives an error which reads, "iexplore.exe - Entry Point Not Found" The procedure entry point shell32.SetCurrentProcessExplicitAppUserModeID could not be located in the...
View downloads doesn't work-Internet Explorer 9
neither ctrl +j does. Even if i download a file and press "view more" (or sth like that sorry i dont have english windows ) nothing happens. -Ive tried reseting ie 9 -deleting all personal data(cookies ,etc) -deleting all files in "appdata/internet explorer -unistalling and installing again...
Browsers & Mail
VMC Remote Control doesn't work with Netflix streaming
My remote control (Windows 7 Vista XP Media Center MCE PC Remote Control and Infrared Receiver for Home, Premium and Ultimate Edition) doesn't work with Netflix online streaming. The pause button works fine with live tv, recorded tv, and DVD playback but not Netflix. Any suggestions on getting...
Media Center
Bug in Windows Explorer: Doubleclick doesn't work
Trying to open an Excel sheet with a doubleclick in Windows Explorer I always get the following message: An error occurred in sending the command to the application. Error Number: 1156 (0x484). Error Code: ERROR_DDE_FAIL. The files are ok, I can open them from Excel. The file association with...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:40.
Twitter Facebook