Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: DCHP service cannot start - error code 1168

24 May 2017   #1

Windows 7 Home Premium 64bit
DCHP service cannot start - error code 1168

Hi all.

I have a PC that cannot connect to a network. Adapter is enabled, but not connected.

When I insert the cable the adapter changes status from "Network cable unplugged" to "Enabled". However as far as the computer is concerned there are "no connections available" (as per the icon with the red cross in the start bar). If I go to the adapter properties I cannot change the IPv4 properties (the button is greyed out).

The cable and all that is fine, I've tested it with another computer.

I tried rolling back the network adapter driver. I tried deleting it and letting Windows install the driver. No change.

When I check Services, "DHCP Client" is not running. When I try to start it the following error appears:
Windows could not start the DHCP Client service on Local Computer.
Error 1168: Element not found.

I followed the steps here:

The SFC scan showed no integrity violations.

There were no entries containing YMTDI or NISDRV in the listed registry locations.

I did a full disk check on startup. I don't know what half of the log means, but it says "0 bad file records processed" at one point, and "0 KB in bad sectors" near the bottom. Windows made some corrections to the file system. I assume this means HDD is fine.

I've tried checking for SMART errors (wmic > diskdrive get status), and drive status was all OK.

Ran the SFC scan again. No errors again.

Still cannot start the DHCP service.

Does anyone have any clue how to fix this? (short of a full recovery).


My System SpecsSystem Spec
24 May 2017   #2

win 8 32 bit

Try simpley giving it a fixed IP then there is no problem. If you have another PC on the network from a CMD prompt type
IPconfig /all
Post results so we can tell you setting for fixed ip
My System SpecsSystem Spec
24 May 2017   #3

Windows 7 Home Premium 64bit

Sorry to say that I just did a factory reset and it is working fine. I would rather have tried to find a real solution but it is my bro's and he doesn't have time for me to play around with it.

That said, how could I have set a fixed IP? Because that was the first thing I tried. If I went to the adapter properties and selected the IPv4 protocol, the Properties button is greyed out and can't be clicked. Is there another way to do it?

But would that help at all if the DHCP service can't run? It seems to me that that is a pretty fundamental problem.

I also realised there was Windows Defender, AVG and Avast all installed. I know multiple antivirus' can cause issues, but even after uninstalling and attempting a restore point the problem remained.

I also tried startup repair but that couldn't fix anything.

Obviously I can't troubleshoot it further, but I'm still curious as to a possible cause and/or potential fix.
My System SpecsSystem Spec


 DCHP service cannot start - error code 1168

Thread Tools

Similar help and support threads
Thread Forum
Windows 7 Service Pack 1 won't install (error code: 800B0100)
Hi all, I'm having trouble trouble installing Windows 7 SP1 64-bit (error code: 800B0100). I've tested numerous methods to solve the problem (including the steps found in your post instructions) but to no avail. I've attached the CBS file as requested. Any help would be greatly...
Windows Updates & Activation
Failure Downloading Service Pack SP1, Error Code 80070005
Hello, I'm new to these forums so I apologize ahead of time if I don't manage to explain everything I should. If that is the case, please ask for whatever information I need provide and I'll do my best to find it. The problem goes as this: I've tried automatically and manually installing the...
Windows Updates & Activation
Service package 1 not installing properly error code: 800f081f
hey guys im new to this and havent been in the pc "game" in a while so im a bit rusty so please bear with me. SO ive been trying to install ARK: survival evolved on steam and ive installed it properly but when i try to run the game i get an error code saying "MSVCR120.dll" is missing or something...
Windows Updates & Activation
Windows Firewall service will not start, Error Code 5: Access Denied
Hey guys, I am running Windows 7 Home Premium 64bit. I can not start Windows Firewall, Diagnostic Policy Service, Diagnostic Service Host, or Diagnostic System Host. When I try and start them manually in services.msc, it gives me Error Code 5: Access denied. Both BFE and Windows Firewall...
System Security
Service Pack 1 error code on install
Hello, I upgraded my computer from Vista to Windows Home Premium 32Bit with no problems that I could detect. Windows Update offers me the SP-1 Upgrade but it fails to install. I receive an Error Code: 80073701. Based upon its spec's, although the upgrade to Windows 7 went without a hitch,...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:21.
Twitter Facebook Google+