Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: OneDrive refuses to open

04 Jan 2018   #1

Windows 7 Professional 64 bit
OneDrive refuses to open

Hi all,
I seem to be having an issue with OneDrive flat out refusing to open. I have recreated this problem on multiple machines (ones on and off domains) and it has me stumped. Hopefully the great people on here can provide some insight.

Here are some things I've done so far:
Restarted to see if that'd fix it
Uninstalled and performed a clean boot
Reinstalled with the same result.

I've tried running %localappdata%\Microsoft\OneDrive\onedrive.exe /reset and

My end results have all been the same where I have no process running in the back ground for it, no system tray, no pop up error, and am frankly at a loss. Any help would be greatly appreciated!

Thank you in advance, ladies n gents.

*PS: If there is any information that you may need please don't hesitate and I will give as much as I can.

My System SpecsSystem Spec
04 Jan 2018   #2

Win 10 x64, Linux Lite, Win 7 x64, BlackArch, & Kali

Hi bclaverie,

Have you tried the OneDrive Troubleshooter?
If you run the tool and click advanced you will be provided the choice to repair automatically!
My System SpecsSystem Spec
05 Jan 2018   #3

Windows 7 Professional 64 bit

Good morning Snick,
I tried running the troubleshooter on my laptop and it told me that it was disabled because it won't work on this PC. I did run something similar yesterday (don't recall if it was the same one) but did receive similar results.

Here is a snip of the troubleshooter result.

Attached Images
OneDrive refuses to open-onedrivets.jpg 
My System SpecsSystem Spec

08 Jan 2018   #4

Windows 7 Professional 64 bit

Update: Did some digging and found this registry key: HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Windows\DisableFileSyncNGSC
Deleted it and voila OneDrive opened. Must have been from a new GPO that was pushed out.

Snick, thank you for trying to help!
My System SpecsSystem Spec

 OneDrive refuses to open

Thread Tools

Similar help and support threads
Thread Forum
Junction with OneDrive
I'm having a problem with junctions. I posted the problem here, considering the last post was months ago; not sure it will get noticed for a while, so I decided to re-post as a new thread. I created a junction whereas the link is the source folder, and the target is the junction as displayed in...
General Discussion
The new OneDrive API
Documents and Settings refuses to open. Win7 Ultimate
I tri to open D&S directory on the left side column. ERROR: Access is Denied. The icon has a curled blue arrow on it. I can open it from the right column . The Properties/security show that I,System,Administrator and Everybody have FULL ACCESS. I think that blue arrow is a clue. Thanks, G
General Discussion
Ridiculous issue: Only GMail refuses to open
This has suddenly started to happen since yesterday. I'm on through a college internet connection through the college proxy. Every other thing works well, it's just GMail PLUS the entire google login system which refuses to work. If I open Gmail in Chrome, I get a blank page, with loading in...
Browsers & Mail
Firefox refuses to open new windows in a new tab
any ideas? "open new window in a new tab" is selected, it makes no difference they always open in new windows
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:22.
Twitter Facebook