Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Unable to install some programs, sfc /scannow stuck at starting

29 Sep 2018   #1
bori02082014

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
Unable to install some programs, sfc /scannow stuck at starting

I have been having problem to install programs for my laptop. My laptop is Windows 7 Pro with 64 bit. I checked online and there is a guide to use cmd and "sfc /scannow" to fix the problem. It came out as:
"Windows Resource Protection could not start the repair service". I tried to run services.msc, and check "Windows Modules Installer" and ensure that the service is started. When I check the status, it reads as "Starting" but never "Started". I also run in cmd "net start trustedinstaller", and it said "The service is starting or stopping. Please try again later."

Is the problem of unable to installing programs due to "Windows Modules Installer"? Also to note my computer has been unable to shut down. It stucks at the Shutdown screen with the circle keeps running. I waited overnight but still unable to shutdown. But if I started my computer in Safe Mode or if I started my computer and don't log in to any account, I'm able to shutdown in a few min. Is there a way to what cause the shudown error? I already tried system restore but last time it failed both in safe mode and normal mode.

I've also scanned using Malwarebytes and found no problem.


My System SpecsSystem Spec
.
29 Sep 2018   #2
Snick

Win 10 x64, Linux Lite, Win 7 x64, BlackArch, Kali, VMWare Workstation Player, OpenVPN
 
 

Hi bori02082014,

Please update your system specs with this tutorial

How to See Your System Specs with "System Info"

Please run
SURTx64 tool

When it completes, please post CheckSUR.log
location: C:\Windows\Logs\CBS
Nic
My System SpecsSystem Spec
29 Sep 2018   #3
bori02082014

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

I already updated System Info automatically. I tried running SURTx64 tool but has been running on "Searching for updates in the computer..." for at least 30 min with the green bar keeps moving continuously.

NOTE: Indexing in my computer is not active. When I checked services.msc, "Windows Search" status: "Starting". But it never got to started. Maybe I need to resolve with the indexing issues first? When I want to search files such as docs from Start, unable to. And also my AVG antivirus has been stuck at 10% scanning my computer for few hours. Although Malwarebytes able to finished scanning my computer. I've tried to rebuild the indexing option, but after clicking the rebuild didn't see any windows pop out or cmd program running.
My System SpecsSystem Spec
.

29 Sep 2018   #4
Snick

Win 10 x64, Linux Lite, Win 7 x64, BlackArch, Kali, VMWare Workstation Player, OpenVPN
 
 

Patience please! Read my footer!
Temporarily shut down your AVG
Run SURT, wait for it to complete, if there are numerous issues, it takes a while.
Then post CheckSUR.log
My System SpecsSystem Spec
30 Sep 2018   #5
bori02082014

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

I will try leaving it on for the whole day for the link you gave. It is a Windows Update Standalone Installer. (Windows6.1-KB947821-v34-x64.msu). And thanks for the response. :)
My System SpecsSystem Spec
30 Sep 2018   #6
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

Hi bori02082014,


It does appear that something else is processing


Trusted Installer
can you check if yours is this, see screenshot.

AVG
unfortunately dissabling it wil not stop a currently processing scan, you will need to uninstall it via safe mode using thier uninstaller

Roy


Attached Images
Unable to install some programs, sfc /scannow stuck at starting-tivalue.png 
My System SpecsSystem Spec
30 Sep 2018   #7
bori02082014

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

I've checked TrustedInstaller Start value is the same as above 0x00000003 (3). When I double click to open the Value data: 3 and the base is in Hexadecimal.

For the "Windows Update Standalone Installer", I've waited for at least 6 hours and still waiting for the it to finish. I have also disable AVG beforehand.

To summarise the problem of my laptop:
1) Unable to Shutdown properly in Normal mode (waited overnight and still not shutting down, stuck at screen where the blue circle keeps moving. But in Safe Mode or when I didn't login to my user account able to Shutdown properly in a few min.
2) Unable to install or uninstall some programs. I tried to run services.msc, and check "Windows Modules Installer" and ensure that the service is started. When I check the status, it reads as "Starting" but never "Started".
3) Indexing isn't active and can't turn it on. At the screen of indexing, no folders listed. When trying to rebuild, there is no response. In services.msc, "Windows Search" status: "Starting". But it never got to "Started".
4) Tried running "sfc /scannow" to fix the problem. It came out as:
"Windows Resource Protection could not start the repair service".
5) Malwarebytes finished scanning with no problem. But AVG unable to finish the scan as it is stucked at processing at 10%.

Any troubleshoot? Seems my computers got a lot of problem.
My System SpecsSystem Spec
30 Sep 2018   #8
Snick

Win 10 x64, Linux Lite, Win 7 x64, BlackArch, Kali, VMWare Workstation Player, OpenVPN
 
 

Thanks again for your input torchwood!

bori02082014, please post WindowsUpdate.log location: C:\Windows

& try running sfc /scannow and SURT from safe mode!

If sfc /scannow completes, unzip and run below batch file and post log sfcdetails.txt which will appear on your Desktop.
SFC_Details_to_Desktop.zip

If SURT completes post CheckSUR.log
C:\Windows\Logs\CBS\CheckSUR.log


My System SpecsSystem Spec
01 Oct 2018   #9
bori02082014

Microsoft Windows 7 Professional 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

I've attached the WindowsUpdate.log.


When running sfc /scannow, the response is:


"Windows Resource Protection could not start the repair service."


I tried running SURTx64 tool. Popped out:


"Installer encountered an error: 0x8007043c


This service cannot be started in Safe Mode"


Attached Files
File Type: log WindowsUpdate.log (1.41 MB, 1 views)
My System SpecsSystem Spec
01 Oct 2018   #10
Snick

Win 10 x64, Linux Lite, Win 7 x64, BlackArch, Kali, VMWare Workstation Player, OpenVPN
 
 

Please download and run SevenForums
Reset_Windows_Update_Full.bat
All windows update components will be reset and reregsitered, the software distribution folder will be renamed SoftwareDistribution.bak
Try Win Update again please.
My System SpecsSystem Spec
Reply

 Unable to install some programs, sfc /scannow stuck at starting




Thread Tools




Similar help and support threads
Thread Forum
SFC/SCANNOW Unable to Repair Files. Unable to Install Security Updates
I was unable to install January and March, 2017 Security Rollups KB3212646, KB4012215. I am able to install other updates. I have followed a number of repair strategies (can't recall exactly) over the last 2 months and have had no success. I do remember thinking I probably had a problem with...
Performance & Maintenance
Stuck in an install loop (unable to locate harddrive for installation)
Hello. What steps should I follow with my HDD to insure a proper installation? Previously, I was stuck in an installation loop between BIOS - which saw my western digital black harddrive - and the windows installer which got to "where do you want to install windows" and then gave me a message...
Installation & Setup
Toshiba OS failure to re install stuck on 'Setup is Starting'
My laptop recently got knocked over, after impact the screen went to a zigzag pattern in weird colors with a high screeching noise. The only way to turn it off was to take the battery out. After trying to start it up it worked fine and loaded correctly, soon after i loaded my game and ran around a...
Installation & Setup
Stuck on 'Starting Windows' screen during install
I've found others on the forum attempting the same thing as me, but with different problems. I'm hoping this isn't a duplicate. I recently purchased a Dell XPS 15 (l521x) that came with Windows 8. The system boots from the hard drive through UEFI by default, so I think the hard drive is already...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:18.
Twitter Facebook Google+