Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Folders stuck being Read-Only

05 Jan 2010   #1

Folders stuck being Read-Only

My dad recently bought a new computer with Win 7 on it. We took one of the hard drives from the previous computer and installed it on the new computer. However, now all of the documents and folders on the transferred drive are read-only. We uncheck the read-only box and go through all of the stuff but when we bring back up the properties it is still read-only. I went through and took ownership of the entire transferred drive, but that doesn't work either.

I also have this same problem on the computer I just upgraded to win 7. However I backed up my documents on an external and then put them back on after I installed 7. I have this same problem as well.

Any thoughts?

My System SpecsSystem Spec
05 Jan 2010   #2

Windows 7 Ultimate 64Bit

Hi Silentcom, from the surface of things, either the drive that you have physically placed into the new machine is encrypted of the username u logged on with doesn't have enough rights. Have you tried adding in the security tab a username with admin rights, give it full control, log on using that username (assumming you already logged on as such), then attemp and take ownership or edit the files.
My System SpecsSystem Spec
05 Jan 2010   #3

Win7 Ultimate X64

I had to take ownership & change permissions of files to gain full control
If done at the root this will apply to all subfolders to
My System SpecsSystem Spec


 Folders stuck being Read-Only

Thread Tools

Similar help and support threads
Thread Forum
Folders stuck on "read-only" mode?
This is the closest I could find as far as a relevant forum section for this problem. The sub-folders within my "My Pictures" folder won't let me save directly to them. For example, I would just save an image from the internet directly to a specific folder for organizational reasons, but it says...
General Discussion
All folders are read-only
Hi all! Problem is as follows: as far as I can discern, all the folders on the PC are read-only. The read-only tickbox under the properties is greyed out under one admin account and appears as a blue square under the other. I can remove the tick/square and hit apply, it will go through the all...
General Discussion
How come I can't remove read only from folders?
I noticed that under properties of my user name that read only is checked, I am the admin and the only one on my pc. I've unchecked it twice and it applies changes but when I go back in it is checked again? I've tries restarting thr computer but still no luck?
General Discussion
stuck on Read only
I'm trying to setup WoW on my new computer with windows 7 but everytime I run it it tells me it needs permission to write to its own folder, s I go to the folder it needs, and disable "read only", I select the only option it will give me, "apply to all sub folders" and that should work, or at least...
General Discussion
Stuck on 'read only' after ownership, permission change
I'm set as an administrator, I've taken ownership of Program Files folder via my account, and I've set myself to full permissions - yet I STILL can't get it to release from Read Only, which makes it impossible to install certain softwares. WTH?
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:22.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App