Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: installed pre-W 7 program having access problems

30 Jan 2010   #1

Windows 7
installed pre-W 7 program having access problems

PaintShop Pro 9.1 is an older photo program I am very attached to. I installed it in W 7 using my default user account which has administrator powers. It starts up and runs fine (W 7 automatically removes the aero desktop to run it). It installed in the default c:\Program Files (x86) folder.

I can open any image in it and it opens fine. But, if I click on an image file and ask it to open with PSP it asks me for permission to run the command, I say go ahead, and then I get:

a) a popup saying "There was a problem sending the command to the program" and when I click on OK
b) PSP opens but *without* the image I clicked on.

How do I fix this in W 7?

I gave psp.exe "run as administrator" but that did not change the behavior described.

Thanks. Jeff

My System SpecsSystem Spec
30 Jan 2010   #2

Windows 7 64 bit build 7600

Even though the run as administrator is helpful, you can also chose to install or run the program in compatibility mode. Right click the executable and properties, and compatibility tab, and run in compatibility with an earlier version of windows. If this doesn't work, you can run the actual installer in compatibility mode.
BTW, if that doesn't work either, then your only option is to either get a newer edition of the software, or run it from virtualbox, or xp mode (requires windows 7 professional or ultimate and a processor with virtualization technology)
My System SpecsSystem Spec
31 Jan 2010   #3

Windows 7

Problem was solved. I'm posting the solution here in case someone else needs it. It required a registry change as follows (courtesy Jim Morison). (I tested it too and it works).
In Windows 7, double clicking on an image file that should open in PSP 9 will open the program with an error message but without the image on most machines.
PSP 9 uses an old Windows system called DDE to pass the image to the
program. DDE is still part of Windows 7, but is prevented from working by 7's tighter security.
One solution, though perhaps a risky one, is to disable UAC.

The other solution was posted by "bpark37" on the PSPUG forums
(PSPUG Message Board - PSPUG Message Board) -

"NEW SOLUTION! Tested on 2 PC's.
I have successfully applied this fix using Paint Shop Pro 9 (PSP 9) with Windows 7 (win7) x64 on 2 different PCs.
(1) Open Regedit
(2) Go to the following string: HKEY_CLASSES_ROOT\Applications\Paint
Shop Pro 9.exe\shell\open\command
(3) Change the "Default" entry to
"C:\Program Files (x86)\Jasc Software Inc\Paint Shop Pro 9\Paint Shop
Pro 9.exe" "%1"
(4) Delete the following string (which is immediately below the string you just edited):
HKEY_CLASSES_ROOT\Applications\Paint Shop Pro 9.exe\shell\open\ddexec
(5) Exit Regedit
(6) Open a picture file as you typically would from windows explorer and it should open without error."

I've tested this on both 32 bit and 64 bit versions of Windows 7 and it
worked fine.
Tim Morrison
C-Tech volunteer
My System SpecsSystem Spec

22 Nov 2010   #4


I LOVE YOU,,, THANKYOU SO MUCH. Been trying to sort that for ages.
My System SpecsSystem Spec

 installed pre-W 7 program having access problems

Thread Tools

Similar help and support threads
Thread Forum
Can't access most programs from program (x86)/Program/ProgramData
Yesterday I noticed that I couldn't launch a program since my computer couldn't find the file "LIBEAY32.dll" and checked what could cause this. Then I noticed that my antivirus "System Center Endpoint Protection" wasn't running, tried to start it, but no matter what methods I tried I could not...
System Security
Program installed in Program Files requires elevation?
I have a program that wanted to install in a document folder :mad: I have installed it in Program Files, but it requires elevation or it produces errors when running. I know I can tick the Run As ... box in the shortcut, but is there a better way, such as taking ownership of the install folder?
System Security
Can't run installed program within Program Files (x86)
Am not sure if this is the right place to ask for this problem, let me know. I gave a try to the Setup Project of VStudio 2008 to create and distribute an x86 installer of a program I develop in win7. After installing, uninstalling and executing over and over some of the features of my...
Installed a Phenom II x4 965 - getting program crashes and problems
Hi everyone. Not sure if my spec will show up under this post. If not, will upload on response. Bottom line,I have just installed a new AMD Phenom II x4 965 3.4ghz quad(it's showing 4ghz on core temp) Black Edition, upgraded from my Athlon 64 x2 chip. I have an am2+ mobo, that was flashed...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:13.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App