Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "No programs are installed on this computer" error

25 Feb 2010   #1
fire cat

Windows 7 Home , Windows Vista Home, Windows XP Home, Windows XP Pro, Windows Mobile, Ubuntu Studio
 
 
"No programs are installed on this computer" error

Hey everybody!
I'm new to the windows 7 forums.
So here is my problem: when i go to the Add/Remove Programs list, instead of seeing the list of installed programs it displays "No programs are installed on this computer". I tried rebooting the computer but that did do anything. Haven't turned on the computer since sunday 21.
I have attached a screenshot.
I am running Windows 7 Home Premium on the Samsung N310. I haven't had any problems befor this.
What can I do to solve this? Please help!

Thanks
Fire Cat




Attached Thumbnails
"No programs are installed on this computer" error-no-installed-programs.png  
My System SpecsSystem Spec
.
25 Feb 2010   #2
Jonathan_King

Windows 7 Professional x64
 
 

Try using a third-party program such as Revo Uninstaller to see those programs.

BTW I see you're new. Welcome to SevenForums!
My System SpecsSystem Spec
25 Feb 2010   #3
fire cat

Windows 7 Home , Windows Vista Home, Windows XP Home, Windows XP Pro, Windows Mobile, Ubuntu Studio
 
 
Not quite what I was looking for...

Thanks a lot Jonathan_King , I looked around the website and it software looks nice and has nice feature, but... I am trying to repair the error, not use something to replace it . Especially, I want to avoid installing big programs on my W7 computer, because as I said:
Quote   Quote: Originally Posted by Fire Cat
I am running Windows 7 Home Premium on the Samsung N310
And if you look at it, you will see that the N310 isn't the biggest of computers, and I am allready using a lot of heavy softwares on it, eg: Virtual PC...
My System SpecsSystem Spec
.

25 Feb 2010   #4
Jonathan_King

Windows 7 Professional x64
 
 

Well please install Revo anyway. If it has the same problem, we know we have a bigger issue.
My System SpecsSystem Spec
25 Feb 2010   #5
fire cat

Windows 7 Home , Windows Vista Home, Windows XP Home, Windows XP Pro, Windows Mobile, Ubuntu Studio
 
 

I did as you said, Jonathan_King, but some of the programs are not displayed, eg: adobe flash and shockwave, teamviewer and most importantly Office 2010 Beta.

*Edit*: Now the windows list of installed programs displays the Revo uninstaller.
My System SpecsSystem Spec
25 Feb 2010   #6
Jonathan_King

Windows 7 Professional x64
 
 

Looks like somehow Programs and Features lost the list of installed programs. Seems obvious, I guess.

You can try a System Restore to a point before the troubles.

If that doesn't work, I'm 90% sure a Repair Install will.
My System SpecsSystem Spec
25 Feb 2010   #7
fire cat

Windows 7 Home , Windows Vista Home, Windows XP Home, Windows XP Pro, Windows Mobile, Ubuntu Studio
 
 

System restore worked fine! Thanks a lot!
I just created an additionnal restore point and backup in case it ever happens again!
I have a feeling Hypercam 2 is to blame...it is known to damage system files. Very happy to know it wasn't a virus!

Thanks a lot again,
Fire Cat
My System SpecsSystem Spec
25 Feb 2010   #8
Jonathan_King

Windows 7 Professional x64
 
 

No problem. Let's just hope it doesn't happen again!
My System SpecsSystem Spec
26 Mar 2010   #9
punkshot

windows 7
 
 

Firecat,

I have the same problem you had before, but when I use the System Restore it says that it can't work because there is an antivirus running. I disabled all the options of the Norton Internet Security and the Windows Firewall, and it's still saying that, I tried a lots of times, but it doesn't work, What you did to run the System Restore?
I know it was 4 weeks ago, but if you remember what you did, pleas help me.

PD: Sorry about my english, it's not my first language and I am still learning.
My System SpecsSystem Spec
27 Mar 2010   #10
Jonathan_King

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by punkshot View Post
Firecat,

I have the same problem you had before, but when I use the System Restore it says that it can't work because there is an antivirus running. I disabled all the options of the Norton Internet Security and the Windows Firewall, and it's still saying that, I tried a lots of times, but it doesn't work, What you did to run the System Restore?
I know it was 4 weeks ago, but if you remember what you did, pleas help me.

PD: Sorry about my english, it's not my first language and I am still learning.
Welcome punkshot!

Try uninstalling Norton completely using the Norton Removal Tool.
My System SpecsSystem Spec
Reply

 "No programs are installed on this computer" error




Thread Tools




Similar help and support threads
Thread Forum
Multiple programs crash on fresh Install, with "StackHash" Error
My mother was having problems with her computer at work and we decided to do a fresh install of Windows 7. Now, multiple programs, including Windows Explorer, are crashing with a "StackHash" error and I don't know what that means. Attached is the picture of the error when I right-click Computer and...
General Discussion
Hard Disk can't read in "my computer ", "initialized",I/O device error
I have a big problem here, I have used my hard disk for 9month, Yesterday when I watched movie on the half way, My hard disk suddenly disfuntion, And I thought my laptop problem due to always lagging so I restart my computer. But after that I can't read my hard disk (WD)in my computer. It can...
Hardware & Devices
Computer keeps deleting and uninstalling programs from "program files"
Hi, Over the last month or so my computer keeps uninstalling and deleting installed programs, i have no idea on whats happening to my computer, i have ran scans and they have came back negative, i know its not a faulty HD, it keeps happening every few days and its really annoying me, re-installing...
Performance & Maintenance
All programs say "not responding" then my computer crashes-please help
When I turn on my computer, everything seems fine at first. After I open a program, the program usually doesn't run. Programs I've tried include iTunes, Google Chrome, and simply trying to open files stored on my computer. After about 30 seconds, whatever program I'm using says "not...
General Discussion
Sound error "no audio output device is installed"
Recently when I was trying to enable my sound card so I could make YouTube videos, I managed to somehow break my sound. I have a windows 7 64bit computer that runs realtek hd audio and nvidia hd audio. I have tried reinstalling windows and that does not work, as it comes up with an error message...
Sound & Audio
"No audio output is installed" error
Recently, I bought a new computer and installed it. Everything is fine but I have a problem, the sound. In the bottom right corner the sound symbol appears with a red "X" and when I roll over it I get the error you can see in the title. Tried what other guys said in other threads and in other...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:54.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App