Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Can't Install Adobe AIR

29 Jul 2011   #31


I am troubled by this problem a long time.
Here are things I have done to try to fix the problem::)

1) Uninstalled
2) Used Windows Installer Cleanup
3) Used CCleaner registry cleaner to remove all traces of Adobe AIR
4) Deleted "Adobe AIR" folder in the "C:\Program Files (x86)\Common Files" path
5) Installed with administrator privileges

My System SpecsSystem Spec
21 Jun 2012   #32

Win 7 x64

Guys, I know this is an old thread but still comes to the top of the results when searching in google reagrding issues installing Adobe air and the resolution does not seem to be out there on the WWW.

Within windows 7 in order to install Adobe Air you need to do a silent install, so copy the AdobeAIRInstaller.exe locally for quick sakes and assuming you have admin rights to the machine, at the command prompt type the following:

adobeairinstaller.exe -silent
My System SpecsSystem Spec
01 Aug 2012   #33

Windows 7 Ultimate x64

Hi guys, i've found solution.
Remove from registry keys for adobe air:
HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Compatibility Assistant\Persisted
My System SpecsSystem Spec

01 Oct 2012   #34

MS Windows 7 Home Premium 64-bit SP1
What worked for me....

This thread is one of the top items returned in a Google search, so I'm adding my solution here in hopes others can be spared the misery of Adobe Air install problems. Windows 7 64 bit; just did a clean install and am reloading programs. Current version of Air would not install, I kept getting this in the install log: (user name changed to protect the innocent)

[2012-10-01:11:18:35] Runtime Installer begin with version on Windows XP x86
[2012-10-01:11:18:35] Commandline is:
[2012-10-01:11:18:35] No installed runtime detected
[2012-10-01:11:18:43] Starting runtime install. Installing runtime version
[2012-10-01:11:18:43] Installing msi at c:\users\XXX\appdata\local\temp\airc667.tmp\setup.msi with guid {14DC0059-00F1-4F62-BD1A-AB23CD51A95E}
[2012-10-01:11:18:44] Error occurred during msi install operation; beginning rollback: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="2" errorID=0]
[2012-10-01:11:18:44] Rolling back install of c:\users\XXX\appdata\local\temp\airc667.tmp\setup.msi
[2012-10-01:11:18:44] Rollback complete
[2012-10-01:11:18:44] Exiting due to error: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="2" errorID=0]
[2012-10-01:11:18:54] Runtime Installer end with exit code 7

I deleted all references and remnants of the program from the hard drive, including deleting the registry key as posted earlier in this thread without any improvement. (BTW, CC Cleaner does not find and eliminate that key.) But then I tried it all again AND changed permissions for c:\users\XXX\appdata\local\temp\ so that SYSTEM had full permissions. Previously SYSTEM had none. Air installed flawlessly after that.

Hope this helps someone.
My System SpecsSystem Spec
01 Oct 2012   #35
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Welcome to the Windows 7 Forum. I don't understand how System lost its permission. The only thing I can think of is that the UAC was not administrator.
My System SpecsSystem Spec
02 Oct 2012   #36

MS Windows 7 Home Premium 64-bit SP1

Layback Bear: That fix has worked for me on two separate Win 7 installs, both with a single user/admin. It is odd that SYSTEM had no permissions for that folder. I have the bad habit of "taking ownership" of folders willy-nilly when something doesn't work, and I can't remember whether I did so for this folder or was always owner. But taking ownership shouldn't remove existing permissions for SYSTEM should it?
My System SpecsSystem Spec
02 Oct 2012   #37
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

I don't really know because I have never tried. You had it happen on two different installs so I'm guessing that it does.
My System SpecsSystem Spec
06 Jul 2013   #38

win7 x64

Quote   Quote: Originally Posted by TOF View Post
First off, type into your search engine "Windows Install Clean Up". Run the application and find Adobe Air and delete it using the application. You should then download the latest version of Adobe Air and install it. Problems solved.
Thanks, it works like a charm for me.
My System SpecsSystem Spec

 Can't Install Adobe AIR

Thread Tools

Similar help and support threads
Thread Forum
Adobe issue during install
SO I downloaded the new Adobe 11.0.07 and I went to install the program and I get this error messege during the installation (see picture) So I went to the Event Viewer and I see this Product: Adobe Reader XI (11.0.07) - Update 'Adobe Reader XI (11.0.07)' could not be installed. Error code...
Is it possible to install Adobe CS4 and CS5 onto same machine?
Hi, I have had Adobe Premiere Pro CS4 and Adobe After Effects CS4 in the past, but recently upgraded last year both to CS5. I have no problem running AE CS5, but PP CS5 is giving me problems when trying to add transitions. Something about it can't add until I remove some parts of the footage...
Cant install any adobe products?? help plz!!!
I am using a windows8 x64 version.. i installed 3ds max and worked well for days, but now when i open it it says 3ds max has stopped working.. Also when i install adobe cs5 suite some applications were unable to install.. I also tried installing after effects cs4.. but at middle of installation it...
Installation & Setup
Can't install Adobe Reader
I had Adobe Reader 9.3 installed, but it was uninstalled as part of my trying to install Adobe Reader 9.4, which won't install. I successfully downloaded the Adobe download manager in Firefox, but at the end of the Adobe Reader installation, I get two messages. Both want me to verify that I have...
Cant install adobe shockwave in win 7
Every time i setup adobe shockwave player is corrupted/damaged and is not working. Any idea?

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:57.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App