Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Many 32Bit programs won't open - Windows 7, 64 Bit

09 Apr 2010   #21

windows 7

I also had the same problem with the 32 bit and 64 bit programs

After you install it twice it gives a pop up saying let windows recommend the installation and then it works fine

My System SpecsSystem Spec
09 Apr 2010   #22

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE

Quote   Quote: Originally Posted by DeaconFrost View Post
Quote   Quote: Originally Posted by seekermeister View Post
Okay, I probably misread what I thought said that it was. That alters my stance about recommending the program, but not whether I will use it again, because it caused a conflict between it and my firewall.
That's why I suggested you read around and find out the facts, rather than tell me I was wrong and that my advice was bad. I know it's easier to just point the finger at other people and call them wrong, but aren't we trying to give good, factual advice to people?

We are, and that's why I'll continue to suggest MSE.
I have been debating with myself for hours about whether to repond to this post, because as I said, it seems obvious that you aren't going to listen, regardless of what I say. However, since we seem to agree that the priority should be the quality of our advice to others, I decided that I would be remiss if I didn't post the link below.

You can sift through the test results or if you wish, just scroll down to the rankings provided, and you will find that MSE is currently considered a second rate AV, despite the fact that it does have some qualities which are good. While I'm sure that it will improve over time, that has no bearing on the prudence of recommending it at this time, because as I said, there are better AVs available.

When I said that I changed my stance regarding it recommendation, that only pertained to my the hardline stance that I had previously taken. If for some reason, you still feel it necessary to continue recommending it, feel free. But while I will not openly oppose you, I shall not agree with you either.

P.S. This is a far better reference than to be found among the variety of opinions to be found by simply browsing through forums/
My System SpecsSystem Spec
12 Apr 2010   #23

Windows 7 64Bit

Clean install worked, the second time anyway! I think it was something to do with the software for my sound card (Asus Xonar DS). I don't see why that would mess things up, but downloading drivers instead of using the DVD seems to have fixed this weird behaviour. Who knows!

Thanks for the points everyone.
My System SpecsSystem Spec

13 Apr 2010   #24

Windows 7 Ultimate x64 SP1

Quote   Quote: Originally Posted by seekermeister View Post
But while I will not openly oppose you, I shall not agree with you either.

P.S. This is a far better reference than to be found among the variety of opinions to be found by simply browsing through forums/
I'm not looking to have people agree with me. It is a free planet (most of it), and I don't mind a good debate, as they usually provide a learning experience for one or both involved. You're link is a great reference, but there are plenty of others to consider as well. Maximum PC just gave MSE some great ratings. I don't like to give opinions or personal experiences as proof of anything, but my some of my users have decided to catch the nasty Security Tools virus that's floating around. MSE is the only active AV scanner I've tried that can detect and remove it on the fly. Malwarebytes can, but I don't consider that as an active scanner, because I stick to the free version.

The beauty of this debate is that we don't have to agree, as there are many good choices for people to install, including some that are free.
My System SpecsSystem Spec
05 May 2012   #25

Windows 7


I had this problem today.. 2012!
I have the Xonar driver aswell.. Its a bug in the driver included in the CD form ASUS.

Asus have a small patch that fix the 32 bit executing error on their website.
Still not anouncing about it, changed from Creative to Asus to avoid bad drivers and here comes the welcome flag.

More info:
ASUSTeK Computer Inc.-Forum- Latest Win 7 Drivers for Xonar DX are worthless

Run the patch from : 2009.06.16
ASUSTeK Computer Inc. -Support- Drivers and Download Xonar DX

Tony Haagen
My System SpecsSystem Spec
08 Jun 2012   #26

Windows 7 Profession x64 Service Pack 1


I seem to have the same problem (32 bit programs never seem to start), but 64 bit programs run fine. I checked my sound drivers and they are ATI and VIA. This is on a system that worked without any problems until today. Any ideas? I've run MSE quick and full, found some java virus which has been removed. I still have problems. I write code for a living so I thought maybe I could create a 32 bit and 64 bit app and see what happens. Too bad visual studio is written in 32 bit!

My very novice approach
Internet Explorer fails to start (runs from x86 dir)
word doesn't start
Firefox doesn't start
Chrome doesn't start
Nothing in Program Files (x86) seems to start. i.e. gimp, notepad++ (can't find 64 bit version)

(Windows) Explorer (of course starts so I'm assuming it's 64 bit)
Internet Explorer starts (when run from generic Program Files directory)
cmd.exe runs fine
notepad runs fine (assuming this is 64 bit?)
other programs in the generic Program Files directory i.e. Sandboxie starts, Ventrillo starts

so basically I'm basing it off of Internet Explorer. The 32 bit doesn't run, but 64 bit does.
My System SpecsSystem Spec
08 Jun 2012   #27
Layback Bear

Windows 10 Pro. 64/ version 1709 Windows 7 Pro/64

Dan007, I'm sorry you have problems but please remember that once a virus has been removed from a computer the problems/changes that it has created can still be there. If you know when this virus entered your computer you can go back a good bit farther to a restore point. Then remove all other restore points because the virus might be hiding there. Then run complete updated scans with your anti virus and Malwarebytes Anti Malware to make sure you are clean. Then I would run sfc /scannow 3 times booting between each time to make sure Windows 7 system files are okay. Lastly I would wipe the free space. The $Recycle Bin is wiped clean when doing this. I use Ccleaner to wipe the free space, (lower left corner).
My System SpecsSystem Spec
08 Jun 2012   #28

Windows 7 Profession x64 Service Pack 1

Hi, cool ty for the suggestion. I will give it a try. I'm pretty sure I'm having a problem with wow64 (windows 32 bit emulator though). I have tried the system restore already but it didn't work.

I've also tried stopping all start up items (via msconfig), and all services (via msconfig) and booted into windows safe mode. Again same results. Only ie 64 bit starts up (of course no networking so it fails, but atleast a window comes up).

I will try the sfc 3 times and report back.

Updates(Reporting back):
I tried system restore again to an earlier one and machine failed to even boot I used a combination of windows repair? and sfc (and copying corrupted files back to windows, Thank you Brink!) and now have it back to my state earlier. i.e. no 32 bit apps seem to run. I've run sfc 3 or 4 times now in windows safe mode dos window and from a dos shell on the windows desktop. I'm hesitant to try anything to do with windows restore now and if that's my only option. I guess I'm stuck with only 64 bit apps on my Windows 7 machine

Opps didn't follow your instructions complete, now going back to full disk virus scan, then will run sfc 3 times and then try and find Ccleaner (didn't see anything in lower left). I hope it's 64 bit app cuz I'm pretty sure it won't run if it's 32 bit app. Anyhow will report back in again on success or no results or complete failure (if this happens it will be a while before I can report back lol cuz my machine will be down and out!)

Just tried to run SF diagnostic tool and it won't run either. Was hoping I could gather more information to help diagnose problem Is there a 64 bit version of the tool?

Update 6/10/2012
-2 Full MSE scans, 2 sfc nothing found by either.

Update 6/11/2012
- Ran 3 sfc nothing found
- schedule scandisk /F /R on reboot
- Set using msconfig no start up items, all non-microsoft drivers disabled
- rebooted and began scandisk /F /R
- Ran 3 sfc nothing found (other sites say it's important to run it 3 times so I'm doing it)

Problem still exists, 32 bit applications never seem to start, they don't crash, don't appear in process monitor, and window for application never shows up. 64 bit applications work without a problem. I will then try and replace the wow64.dll, wow64sys.dll and wow64Cpu.dll, then if I still have problems, muck with win32k.sys and registry. After that I think I have no choice but reinstall win7? I'll continue to monitor this thread for a few days before I do a reinstall of win7 in case someone has some suggestions.

Update 6/15/2012
Not sure what fixed it since nothing was reporting errors as fixed or problem found, but I did try to download Malware, it didn't run of course since it's 32 bit. So then I tried to boot off a different os to run Malware. Wasn't able to get it to run in DOS, and failed attempt to install another windows 7 volume, and after all that I booted back in to search for windows 7 install problems, but voila my machine got fixed! 32 bit apps now run! :)

Update 6/17/2012
Apparently my problem still exists. As everyone seems to suggest that I have malware, I was finally able to run the Malware installer (32 bit), when my machine came back up. Bad news, Malware wanted me to reboot. So reboot I did, and my problem came back. 32 bit programs don't run. Malware doesn't run. I tried to boot off my failed windows 7 again to check the error, and then rebooted back into my current volume (to use the web to research) and voila! Machine fixed again? 32 bit apps run. Anyhow long story short, I seem to have to boot into the failed partition first and then boot my other partition and it works. I have run many sfc's as well as Malware full scans and I still have the problem. For now I will live with the manual boot to failed volumne then boot to other volume to get things to work.
My System SpecsSystem Spec

 Many 32Bit programs won't open - Windows 7, 64 Bit

Thread Tools

Similar help and support threads
Thread Forum
How can I run 32bit programs on a 64bit machine? Windows 7 / Ultimate
I want to upgrade a 2008 Win7 Pro 32bit computer to Win7 Ultimate 64bit. Have new mobo, processor, 16gb memory, 256gb SSD. Would like to be able to use my 32bit programs for a while, until I can replace them with 64bit progs. How can I do this? Or do I need to have two machines? I have...
Installation & Setup
My Windows programs will not open images, I can open them with PSP
For a while my windows 7 64 bit would open my images in Documents. Now when I try they appear as a garbled strange format. If I go to PSP ProX2 they open fine. This is a problem for me since I often need to add images to document Newsletters I send out. :confused: Thanks, Char
Can't open programs in WINDOWS 7 Pro 32bit
I can not open some programs in windows 7. This is a brand new Dell Laptop. I install all of these programs 4 days ago and they worked fine. Now when I try and open these same programs. I get the motion circular object as if the program is opening, however the programe never starts. If you click on...
General Discussion
Windows 7 64bit - 32bit programs corrupted
Hey guys, I'm in a very desperate situation... I have an Alienware M17x with as many upgrades as I could have got. I use my computer for work, and i have to be up in 5.5 hours to get a lot of stuff done.. Today, something strange was happening with IE8, where google results would open in...
General Discussion
W7 64bit:Ok to install 32bit programs outside the 32bit programfolder?
OS: Win 7 64bit. Is it generally not a problem to choose to install a piece of 32bit software outside the win 7 default program folder for 32bit software? Or is 32bit software only supposed to be running flawlessly, if installed in that default 32bit folder? Thanks.

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:22.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App