Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Win7 multiple buggy issues

11 Jun 2010   #1
boogers

Win7 Ultimate x64
 
 
Win7 multiple buggy issues

Hi all. My problem spans over a wide range of issues so I hope I am posting in the right place. I will try to give all the information I can and maybe somebody can tell me if it really is a buggy installation or if it's the cause of something else. Here goes (and thanks for taking the time to read.)

!. I have been running a Win7/WinXP dual boot (1 OS per HDD) since the RC was released late last year. I had no problems until about 1.5 months ago when all of a sudden I was no longer able to boot into Win7. After a full hardware diagnostics and attempting to repair the installation to no avail I decided to start fresh. Along with this decision for a complete reinstall I also decided to do away with WinXP.

2. Everything went smooth with wiping the HDDs and reinstalling Win7. No problems at this point.

3. After a couple days I started to lose the DVI signal to my monitor. At first I was able to switch the cable to VGA and manually set my monitor back to DVI and all was good. I tested the monitor's DVI input on a second computer with the same cable I have always used and it worked fine for the whole day. The other pc was running WinXP.

4. Now, the DVI signal refuses to work. It is really weird because my GPUs only have DVI and I have to use an adapter on the VGA cable to make it work. BTW, POST shows through when I use the DVI but the screen goes blank once Windows starts to load. A second time of moving the monitor to the second machine confirmed the DVI worked fine there.

5. I have been unable to get autorun to work. I double checked the settings in Control Panel -> Hardware and Sound -> Play cd and other media automatically. Everything is set as it should be but autorun does not work for anything....cds, dvds, games, software....

6. I am unable to get CoDWaW to properly install. I am having to open the disc from Computer and start the autorun.exe file manually. First run everything installed fine, or so I thought. I applied all the patches (to 1.7) but when I tried to start it there was a dx.dll file missing. Can't remember which one off the top of my head, but I found it online, downloaded it and installed it into the %systemroot%. That didn't work so I applied it to the CoDWaW folder. This allowed the game to run.

After getting into the game for the first time I closed it out and installed my profile backups. Loaded the game back up and there was no sound. Checked all settings and searched for an answer online to no avail. So I uninstalled it.

6. I reinstalled CoDWaW by manually starting the autorun.exe file from the disc again. This time I set right at the machine the whole time to make sure there were no errors or anything that I had missed last time. Install looked good.

There were no shortcuts so I opened the Activision folder to go to it directly and the game is not completely installed. There are 3 subfolders (main, pb, docs) and an exe file that is 0kb.

7. I have also ran Stardock fences and had constant trouble with it. Icons bouncing out of fences when I double click them, some icons disappearing completely and options to exclude mysteriously disappearing after a few hours of being installed. I don't think this is a problem with Win7 as there are a lot of issues documenting this type of activity on their forums. But just wanted to mention it in case...

8. The last thing I want to mention is the problem with some apps shortcuts. Sometimes (not always though) apps will not launch from the desktop shortcuts. i can go to program files and launch them no problem every time. I've tried removing the shortcuts and creating new ones but this doesn't see to make a difference.

I tried a restore to a few days ago but that did not seem to help.

I am really lost here. I don't know if this is a corrupt file somewhere, a hardware issue (everything has tested fine) or just an incompatible program somewhere causing all these problems. I didn't notice that these problems started after a particular program was installed. Also, I did not notice all the problems starting at once. It has been a progression over the past few days.

I do have x64...don't think I put that in my specs when signing up on this site.

If anybody has a suggestion on where to start that would be great. Thanks for taking the time to read and offer advise.

Boogers


My System SpecsSystem Spec
.
11 Jun 2010   #2
fseal

Windows 7 x64 Ultimate
 
 

Boy that is a LOT of issues all at once

Any time there seems to be such a long list of issues I tend to think of hardware problems. Videocards going bad (I've lost two recently) or the main culprit, memory issues. THough memory issues generally always end up givingyou random blue screens.

The other thing is viruses but on such a new install... Unless you were running compeltely unprotected live on the external internet address from your ISP, that would seem less likely. But RUnning AV and Malware scans just in case might still be called for.
My System SpecsSystem Spec
12 Jun 2010   #3
boogers

Win7 Ultimate x64
 
 

Thanks for the reply.

Ran an AVG full scan and Malwarebytes full scan. Both turned up no infections.

I would lean more towards hardware as well if I had problems in WinXP. I've ran WinXP from the first day on this machine and have never had one issue. Problems only seem to come up in Win7. That's why I'm thinking more along the lines of a corrupt or incompatible program or driver.

Before reinstalling Win7 I was getting BSoDs, but only when booting into it. WinXP booted fine. The BSoDs were 0x0000003 which is "INVALID_AFFINITY_SET." The info I read on this code says it could be caused by either a hardware issue or a device driver. I let Win7 install all of the drivers automatically so my next step will be to get all of them manually.

I will post any updates. Any and all suggestions are welcome. Thanks again for the reply!

Boogers
My System SpecsSystem Spec
.

12 Jun 2010   #4
Adrian

 
DVI

Welcome to Windows 7 support forums,
Boog, a couple of questions for you before we begin trouble shooting,
were you sucessfully able to accomplish installation of XP? If so, what version and bit size?
You state that your gfx dvi were able to run DVI at the beginning of the install but started to erode? You have dual gfx cards? Also do you have the onboard card which for your MOBO is the ATI 3300?
Its possible that the drivers for your card never updated.
Let us know these further details so we can provide more assistance.
My System SpecsSystem Spec
13 Jun 2010   #5
boogers

Win7 Ultimate x64
 
 

Hi Adrian. Thanks for the reply.

I had installed XP x86 when I first built this system in late 2009. Since then mobo and CPU have been upgraded. I never had a problem with installation or BSoDs with it. The only problems I ever experienced in XP was related to ATIs drivers. I had to use older drivers to keep the cards from crashing randomly. Other than that everything ran smooth. I think the drivers were v8.6 but cannot be 100% sure now that XP is wiped.

DVI problems only reared their head after installing Win7. Never had that problem in XP.

I do have dual GPUs. Both ATI Radeon 3870s installed when the system was built. As I mentioned above I've had some bad luck with ATIs drivers, so I would not be surprised if this is actually the cause of my DVI problems. I have also noticed since posting that the video drivers have stopped responding a few times while in WMP. This has not happened as of yet while gaming. I also did not install CCC so I'm not sure if crossfire is working or not, but by the FPS I see in CoD4 it looks like it is. I have downloaded chipset, CPU, and graphics drivers (along with CCC) and plan on installing them one at a time, starting with graphics, to see if that will correct any of the issues I'm having.

I will try DVI from the onboard to see if that works.

When I get the chance I will start updating drivers, one at a time, and waiting a few days in between to monitor the system. If you have any suggestions I would love to hear them. This one is stumping me.

Thanks again! I will update with any new developments within the next few days.
Boogers
My System SpecsSystem Spec
18 Jun 2010   #6
boogers

Win7 Ultimate x64
 
 

Ok, got an update. I uninstalled the video drivers for my cards, then reinstalled with the latest version. DVI signal is back up and has been stable for a few days. However, I was unable to install CCC which I downloaded with the drivers. Don't know why it did not install but I checked and rechecked and it's no where to be found. I'm thinking this may be tied to the same issue as I'm having with CoDWaW, but I haven't tried reinstalling it again.

Other things that have not changed include being able to get autorun to work (tried again in both drives), unable to get WaW to install correctly (update on details below), and some shortcuts still don't work all the time.

I went back into the control panel and checked my autoplay settings and set the programs option to automatically launch or install when I put a disk in the drive. I pop a disc in, the light blinks and looks like it's reading it (fast blinking) but nothing ever pops up. I tried this with WaW, BFVietnam, MoHaa, a couple music cd's (also set to automatically play) but nothing. Neither drive works with autoplay.

Don't know if PnP would be in any relation to autoplay, but it works without a problem. Plugged my camera in, it installed drivers then gave me the option to open folder to view files.

This is getting frustrating...The deal with WaW now is the same through the installation. This time I got an error about directx not installing properly. I checked both the dxerror.log and the directx.log. dxerror showed permission denied as the error. directx.log show a ton of plugins are missing. This was all from trying to install it manually from the WaW disc.

So, I downloaded the directx install files and ran the setup. No errors this time and I opened the dx diag and it shows everything working fine. Then I look at the WaW folder in the program files and it has 4 folders (docs, main, pb, zone) and nothing else. No exes or anything. All folders look like they installed completely, just nothing to launch the game.

The disk is flawless...no scratches or smudges. I've tried installing from both of my dvd drives and there is no difference in the end results.
I will move on to the next drivers and do a uninstall/reinstall. If anything changes I will update here.

Boogers
My System SpecsSystem Spec
18 Jun 2010   #7
Lomai

Win7 HP (x64)/Win7 Ultimate (x64)
 
 

Are your DVD-drives IDE or SATA?
If IDE - are the jumpers for master and slave in the correct locations?
Could you post the size of the WaW directory that's on your C (Programs) Folder?

Could you also let us know on the age/make/model of your power supply?

Regards
My System SpecsSystem Spec
18 Jun 2010   #8
boogers

Win7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Lomai View Post
Are your DVD-drives IDE or SATA?
If IDE - are the jumpers for master and slave in the correct locations?
Could you post the size of the WaW directory that's on your C (Programs) Folder?

Could you also let us know on the age/make/model of your power supply?

Regards

All drives are SATA.

WaW directory is 6.72GB. It appears that all the files were installed. However, there is no executable to launch the game. I have not applied any of the patches.

PSU is Corsair tx650 and it is a little less than 2 yrs old.

Thanks for the response!

Boogers
My System SpecsSystem Spec
19 Jun 2010   #9
Lomai

Win7 HP (x64)/Win7 Ultimate (x64)
 
 

Hi Boogers

Figured we are on opposite sides of the planet
Long-shot - do you have any other devices connected on USB to your PC? Have you tried disconnecting your external peripherals to just the mouse and keyboard and checking if there are any changes?
In relation to CCC - have you tried re-downloading the CAT version and reinstalling over your existing driver?
My System SpecsSystem Spec
21 Jun 2010   #10
boogers

Win7 Ultimate x64
 
 

Ok, keyboard, speakers and wireless mouse adapter are the only usb peripherals I have hooked up. I disconnected speakers but there was no change that I could see.

Updated chipset drivers from Asus website yesterday and it installed CCC for the onboard graphics, but gives me access to my GPUs. So, that problem is solved.

On to WaW again....I found my profiles were still installed from my first attempt (when the sound didn't work) and removed them from the appdata/local/activision folder. Then tried reinstall again and got a message asking if I wanted to completely uninstall WaW and profiles and settings. Said yes and attempted reinstall.

Install went as it has and during finalization dx setup failed with error logs. Checked logs (dxerror.log and directx.log). The dxerror.log had 4 files but they were dated from 6/10. All said access was denied from C:/users/boogers/appdata/local/temp/ for deleting the dx temp files.

More interesting is the directx.log file. It is a mile long but here are the ones dated for 6/21:

06/21/10 07:38:23: infinst: Installing C:\Users\Boogers\AppData\Local\Temp\DXBE70.tmp\d3dx9_24_x64.inf [DefaultInstall]
06/21/10 07:38:23: infinst: Target file: 'C:\Windows\system32\d3dx9_24.dll'
Target file is Version 9.5.132.0
Source file is Version 9.5.132.0
06/21/10 07:38:23: infinst: C:\Windows\system32\d3dx9_24.dll have been installed already.
06/21/10 07:38:24: infinst: Installing C:\Users\Boogers\AppData\Local\Temp\DXBE70.tmp\d3dx9_25_x64.inf [DefaultInstall]
06/21/10 07:38:24: infinst: Target file: 'C:\Windows\system32\d3dx9_25.dll'
Target file is Version 9.6.168.0
Source file is Version 9.6.168.0
06/21/10 07:38:24: infinst: C:\Windows\system32\d3dx9_25.dll have been installed already.
06/21/10 07:38:25: infinst: Installing C:\Users\Boogers\AppData\Local\Temp\DXBE70.tmp\d3dx9_26_x64.inf [DefaultInstall]
06/21/10 07:38:25: infinst: Target file: 'C:\Windows\system32\d3dx9_26.dll'
Target file is Version 9.7.239.0
Source file is Version 9.7.239.0
06/21/10 07:38:25: infinst: C:\Windows\system32\d3dx9_26.dll have been installed already.
06/21/10 07:38:26: infinst: Installing C:\Users\Boogers\AppData\Local\Temp\DXBE70.tmp\d3dx9_27_x64.inf [DefaultInstall]
06/21/10 07:38:26: infinst: Target file: 'C:\Windows\system32\d3dx9_27.dll'
Target file is Version 9.8.299.0
Source file is Version 9.8.299.0
06/21/10 07:38:26: infinst: C:\Windows\system32\d3dx9_27.dll have been installed already.
06/21/10 07:38:27: infinst: Installing C:\Users\Boogers\AppData\Local\Temp\DXBE70.tmp\d3dx9_28_x64.inf [DefaultInstall]
06/21/10 07:38:27: infinst: Target file: 'C:\Windows\system32\d3dx9_28.dll'
Target file is Version 9.10.455.0
Source file is Version 9.10.455.0
06/21/10 07:38:27: infinst: C:\Windows\system32\d3dx9_28.dll have been installed already.
06/21/10 07:38:28: infinst: Installing C:\Users\Boogers\AppData\Local\Temp\DXBE70.tmp\d3dx9_29_x64.inf [DefaultInstall]
06/21/10 07:38:28: infinst: Target file: 'C:\Windows\system32\d3dx9_29.dll'
Target file is Version 9.11.519.0
Source file is Version 9.11.519.0
06/21/10 07:38:28: infinst: C:\Windows\system32\d3dx9_29.dll have been installed already.

BTW, I tried installing from both the disk and downloading and running dxwebsetup from MS website.

Is it recommended that I completely remove DX and try installing from scratch?

Concerning the other problems I've had....
All shortcuts have worked since chipset drivers were updated. But, I'm not holding my breath on that and will update in a few days, hopefully with good results.
My icons on the right side of my screen pile themselves on top of each other in the center after closing COD4. They are not inside of the windows sidebar area.
Autoplay still does not work on either drive.
DVI signal still seems to be stable so no problems there.

Last thing....If dx is getting errors why is it that COD4 runs without any problems? The errors in that log are related to dx9 and I'm pretty sure that's what COD4 uses.

I will watch for new posts and update any changes. Thanks again for all the support guys!

Boogers
My System SpecsSystem Spec
Reply

 Win7 multiple buggy issues




Thread Tools




Similar help and support threads
Thread Forum
Dual Boot issues.. Win7 64 bit & Win7 64bit
OEM SSD Win7 64 bit on C: I installed a new SSD with Win7 64bit to use as a test drive, but I can't boot to it. I can see the new SSD drive when I am in C:. It is labeled as E: I never gave it a drive letter. Does Win7 issue drive letter sutomatically? When I go into the BIOS at boot up I can't...
Installation & Setup
Ad-Hoc Network buggy
Hello, I created a Ad-Hoc Network for my Mac. When I finishd, I deleted the network via Manage Wireless Networks in Control Panel. But it says it's deleted in the Netowork and Sharing Center. But when I go click the networking icon in the taskbar, I can still see my ad-hoc network! How can...
Network & Sharing
IE9 is so Buggy
im running win7 64bit and since i upgraded my ie to 9 it seams odd i keep getting notice program crashed and other things where it wont load things like in facebook and when u tell it its ok it resets the page. just wondering if anyone else is having this much trouble with it. Alice
Browsers & Mail
Windows 7 Buggy
Hi, Ive just logged in to windows 7 today and found that i couldnt view my network. Ive looked around and saw mrstub.exe and files like that. Can anyone help me? ------- ALSO
Network & Sharing
Buggy HomeGroup?
Simple problem: After installing Windows Seven Professional x86 on my Mom's laptop a couple o' days ago, I set up a HomeGroup so we can share files. My mom can easily access my files even from the bedroom (room furtherest from my pc), but when I want to get something from her libraries I usually...
Network & Sharing
Why are libraries so buggy :/
See my other thread complaining about the lack of library-sharing customization here: https://www.sevenforums.com/network-sharing/20756-libraries-auto-shared-through-media-streaming.html You can argue that thats intended, even if its stupid. But I've recently been finding folders that are NOT...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:50.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App