Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: permissions (maybe) causing audio issues

31 Jul 2010   #1

Windows 7 64bit
permissions (maybe) causing audio issues


I used to use XP (32 bit) and never had any problems like I'm about to describe. Recently I decided to dual boot 7 64bit Professional with XP. I like windows 7 for the most part except for the stupid permissions and authority issues with files and applications. Also, various things dealing with audio are messed up and convoluted in 7. I've made absolutely NO hardware or software changes since I started dual booting. All these problems must be caused by how 7 handles things compared to XP. The soundcard I use is an HT Omega Striker 7.1.

So here we go.

I cannot play compressed wave files. If the bitrate is anything other than 1411kbps, no application can play the file, except for Audacity. WMP can't play it, wavosaur can't play it, and FL Studio can't play or load it. (FL Studio is a DAW software I use because I'm a music composer and producer). Now, one would think that this could be solved by downloading a codec for these applications to be able to play compressed waves. But one would also think that such a commonly used codec would be included with windows. And it is included; I've sent these compressed waves to friends running 7 64bit Pro and they are able to play it fine.

Now, Fl Studio comes with a vorbis codec installer, which their forums have told me will allow Fl Studio to load and play compressed waves. In the Fl program files folder, there is a vorbisacm.inf installer file which is supposed to install the vorbis.acm file. I "Install" from the vorbisacm.inf context menu and it seems to copy the files it needs, but there is no message of successful or nonsuccessful installing, and when I check the registry, the entries that I believe the vorbisacm.inf file is supposed to create aren't there. I can paste the contents of vorbisacm.inf if someone wants. So anyway, it seems that codec isn't installing properly.

Fl Studio has a diagnostic tool, and here are selected bits of the report it generates:
System test results
You are running Microsoft Windows Vista, version 6.1 (64bit)
       You don't have a servicepack installed
       Windows is installed in "C:\Windows\"
       The program files location is "C:\Program Files (x86)\"

FL test results
No installations of FL were found
1. Invalid!
Location: "C:\Program Files (x86)\Image-Line\"
So it's detecting that I'm running Vista, which is odd. But more oddly is that it's not finding the installation of Fl I have. I made a thread on the Fl forums that might be of use to read: Image-Line :: View topic - permission issues in windows 7 preventing proper installation of all features

Another problem that may be related is that I can't hear sound from Fl Studio while any other media player is playing, or vice versa. For Fl, I use Asio4All. In the Asio4All panel, I have one in and out for "HTO STRIKER 7.1 Audio Device", and I have one in and two identical looking outs ("2x 44.1-48kHz, 16bits") for "HTO Striker 7.1 Audio Digital". I can fiddle around with them, turning them on/off, until I get the sound switched from Fl to the media player or vice versa. But back when I used XP, I could hear Fl and any other audio application at the same time, even though I had the same set up, using Asio4All in Fl.

Please do not suggest anything like "try installing/running as adminstrator" or "try switching UAC to never notify" or "try reinstalling windows" or "try updating your soundcard drivers" or "try changing settings in the sound control panel". The obvious things never work, and I wouldn't be posting here if the solution was that simple. I've tried all such things. I've gotten no error messages during installation or anything and i've gotten no indication that something is not or shouldn't be working, except that it doesn't work.

Some deep problem is going on here, and I appreciate any insight or help you guys could give me. If you feel all these problems aren't truly caused by an audio issue, perhaps tell me to move this thread to another forum.


My System SpecsSystem Spec
07 Sep 2010   #2

Windows 7 Professional SP1 64 bit Retail

I can't offer any help other then to say I'm running Live 8 and have the same issue of not being able to run another sound device while the ASIO4ALL driver is running. If I switch to the MME/DirectX driver other devices will play but I loose sound quality and latency. I've been all over boards and no one has been able to offer a useable solution.
My System SpecsSystem Spec

 permissions (maybe) causing audio issues

Thread Tools

Similar help and support threads
Thread Forum
I need help with latency issues causing audio pops
Hello everyone, Happy New Year! I just installed my Christmas present to my self, an Audioquest Dragonfly ver 1.2 While it does sound better then the internal sound card I have pops going along with the sound. I researched the problem and found that i have rather severe latency issues,...
Sound & Audio
New SSD causing issues
Hello, I have recently installed a solid state hard drive into my laptop and since doing so I have experienced numerous system crashes. When this happens an error screen appears, but there is not enough time to read the content before it restarts and boot options kick in (ie safe mode etc). The...
BSOD Help and Support
Second OS causing permissions problems
Hi All I had to reinstall windows 7 over the weekend but I kept the original on the same drive (now windows.old). The problem is the new windows 7 isnt allowing me to overwrite,delete,etc files because the permissions are set to the old OS user. Is there anyway of doing a full sweep of all...
General Discussion
Having Issues with multiple audio drivers getting audio sync issues.
hey guys. I recently been having so many problems with audio sync issues when mounting a 3D image. Video plays fine in my media player. (have tried totalmediatheater and poweriso11 seems to be the best so far). anyway it seems like it plays fine in 2D but 3D is giving it audio sync issues. I think...
Sound & Audio
Software permissions causing headache
I installed filezilla ftp server to test a ftp software application i have built for use on an external server. When my application tries to copy a file to my server, the server reports a 550 error which means it cannot write to the folder eventhough it has full permission in the application...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:49.
Twitter Facebook Google+