Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: sound blaster live does not work

30 Sep 2009   #11
camaraododesert

WINDOWS 7
 
 

try this.. lordbob75

sorry for the poor english...

SUCESS INSTALLATION for Creative SB Live! 24-bit (CA0106) in "WINDOWS 7"
Integrated Audio Processor on MSI motherboard K9N DIAMOND (MS-7226)

(VERY IMPORTANT) HOW TO INSTALL (FOLLOW THE EXACT STEPS)

Go to Creative Sound Blaster - Sound cards for gaming, movies and music listening >
SUPPORT >
SOUND BLASTER >
If your product is not listed above, please click here. >
select LIVE! >
select live 24-bit (no external) >
latest downloads >
select "Creative Sound Blaster audio driver 1.04.0090" > download it.
(do not install direct from the .exe file downloaded)

(if you don't have winrar) Install the WINRAR
right click >
select EXTRACT TO SB24_PCDRV_LB_1_04_0090 > (or any local)
enter in this new folder >
enter in "DRIVER" folder >
double click in the SETUP file >
the installation will be lauch...
(the installation may be give few or much minutes or the system may be show the message
"not response" - DON NOT FINISH THIS PROCESS - wait for the complete install)
restart...

(IMPORTANT)
if the atualization Sound Blaster software appear, click in CANCEL... END.
(if you choose another option, will give the BLUE SCREEN OF THE DEATH)

Here is in full functionally. OK.


Creative Sound Blaster audio driver 1.04.0090
Filesize : 44.15 MB Download
Release date : 2 Jul 09

File Name : SB24_PCDRV_LB_1_04_0090.exe
This download is a driver providing Microsoft® Windows® 7 and Windows Vista® support for Creative Sound Blaster® Live!® and Audigy® series of audio devices. For more details, read the rest of this web release note.
This download supports the following audio devices only:
* Sound Blaster Live! 24-bit
* Sound Blaster Audigy Value/SE/LS
Requirements:
* Microsoft Windows 7 64-bit, Windows 7 32-bit, Windows Vista 64-bit with Service Pack 1 (SP1) or Windows Vista 32-bit with SP1
* Sound Blaster audio devices listed above
Notes:
* This driver is only for the Creative Sound Blaster audio device listed above.
DO NOT install this driver for other Sound Blaster audio devices.
* To install this driver
1. Download the file onto your local hard disk.
2. Close all other Windows applications.
3. Double-click the downloaded file.
4. Follow the instructions on the screen.


My System SpecsSystem Spec
.
01 Oct 2009   #12
Lordbob75

Windows 7 Ultimate x64, Mint 9
 
 

Kamaradodesert, thanks for the long write up.

I have long since ditched that card, and my onboard motherboard audio is of muchbetter quality than it ever was. So no worries there.

Thanks anways

~Lordbob
My System SpecsSystem Spec
06 Nov 2009   #13
vipergts1885

windows 7 ultimate
 
 

hello there my sound blaster does not work also ...i have both windows xp and windwos 7 on my pc..if i run windows xp everythign is fine but if i run windows 7 i have no sound..i have done everythign i know and have read about to fix it and nothin workds...ive downloaded over 30 different drivers non worked....when i check my device manager is said im running creative sb 5.1 but when i check it another way it said im running sb live series (wmd)...i am lost on how to get souind... i have no sound at all on windws 7 and when i try to run the auto update on the creative website it said i dont have any of there products but i go back to windows xp and auto update and it said im running creative sb live ...i have tried evey suggestion on this forum and nothing works i cant even get alil sound...im half temped to take windows 7 back and go back to xp if anyone could help it would be appreciated...i even went the dell website and downloaded every driver for my exact model and that didnt work...ive tried all the sb live drivers and theyt all say i have the wrong os or doesnt work on this os....and there seems to be no wsuch thing as a 32 driver all im finding is 64 same as what most ppl have said on here...i have even sent creative a email stating my problems and have yet to hear anyhting back...bottom line i need to know y one min i have a sb live series (wmd) then a sb live 5.1 im pretty sure it dont matter b/c there both a live series but dont know what else to do ...not exxagerating ive treid everythign ive read about and every single driver even remotely close to my car from the creative website...please help sorry if all this is confusing ...
My System SpecsSystem Spec
.

06 Nov 2009   #14
mushroomboy

Windows 7, Linux
 
 

;osdfjslpdifjrsdl;afjsd;alfjdspkfsda;lfjsdl;fjdsa;lfj;osdfjslpdifjrsdl;afjsd;alfjdspkfsda;lfjsdl;fjd sa;lfj;osdfjslpdifjrsdl;afjsd;alfjdspkfsda;lfjsdl;fjdsa;lfj;osdfjslpdifjrsdl;afjsd;alfjdspkfsda;lfjs dl;fjdsa;lfj;osdfjslpdifjrsdl;afjsd;alfjdspkfsda;lfjsdl;fjdsa;lfj;osdfjslpdifjrsdl;afjsd;alfjdspkfsd a;lfjsdl;fjdsa;lfj;osdfjslpdifjrsdl;afjsd;alfjdspkfsda;lfjsdl;fjdsa;lfj;osdfjslpdifjrsdl;afjsd;alfjd spkfsda;lfjsdl;fjdsa;lfj;osdfjslpdifjrsdl;afjsd;alfjdspkfsda;lfjsdl;fjdsa;lfj;osdfjslpdifjrsdl;afjsd ;alfjdspkfsda;lfjsdl;fjdsa;lfj;osdfjslpdifjrsdl;afjsd;alfjdspkfsda;lfjsdl;fjdsa;lfj;osdfjslpdifjrsdl ;afjsd;alfjdspkfsda;lfjsdl;fjdsa;lfj;osdfjslpdifjrsdl;afjsd;alfjdspkfsda;lfjsdl;fjdsa;lfj;osdfjslpdi fjrsdl;afjsd;alfjdspkfsda;lfjsdl;fjdsa;lfj


Oh dear lord, if you do a search you'll find 50X threads to this topic.

KX Audio Drivers [emu10k1]

That's my thread.

SoundBlaster Live! (EMU10K1) terrible sound?!

That's the FIRST google search for Sound Blaster Live Windows 7

Repeat: FIRST GOOGLE SEARCH.

[edit] Again, SBL was dropped after WinXP. Meaning ALL THE DRIVERS FOR THE EMU10K1 and EMU10K2 chipsets are BROKEN INTENTIONALLY. They want people to start using the XFI series cards. That is why you get the crackeling and massive bass problems.
My System SpecsSystem Spec
07 Nov 2009   #15
NoRulez

Win7/Vista/XP/Linux
 
 

Quote   Quote: Originally Posted by vipergts1885 View Post
hello there my sound blaster does not work also ...i have both windows xp and windwos 7 on my pc..if i run windows xp everythign is fine but if i run windows 7 i have no sound..i have done everythign i know and have read about to fix it and nothin workds...ive downloaded over 30 different drivers non worked....when i check my device manager is said im running creative sb 5.1 but when i check it another way it said im running sb live series (wmd)...i am lost on how to get souind... i have no sound at all on windws 7 and when i try to run the auto update on the creative website it said i dont have any of there products but i go back to windows xp and auto update and it said im running creative sb live ...i have tried evey suggestion on this forum and nothing works i cant even get alil sound...im half temped to take windows 7 back and go back to xp if anyone could help it would be appreciated...i even went the dell website and downloaded every driver for my exact model and that didnt work...ive tried all the sb live drivers and theyt all say i have the wrong os or doesnt work on this os....and there seems to be no wsuch thing as a 32 driver all im finding is 64 same as what most ppl have said on here...i have even sent creative a email stating my problems and have yet to hear anyhting back...bottom line i need to know y one min i have a sb live series (wmd) then a sb live 5.1 im pretty sure it dont matter b/c there both a live series but dont know what else to do ...not exxagerating ive treid everythign ive read about and every single driver even remotely close to my car from the creative website...please help sorry if all this is confusing ...
Quote   Quote: Originally Posted by NoRulez View Post
KX Project drivers work just fine in Vista and 7
OMG! Don't people even read the preceding messages in the same thread?
Yes, SBLive series drivers was discontinued after XP, but KX Project still carries on.
My System SpecsSystem Spec
07 Nov 2009   #16
mushroomboy

Windows 7, Linux
 
 

Exactly, we need somebody to Pin a thread about how SBL was discontinued!!! WHY OH WHY every day there is at least 1 new thread about SBL not working.
My System SpecsSystem Spec
19 Jan 2010   #17
JonDN

Windows 7
 
 

Try this guys, worked for me...

Also had this problem, heres how I fixed it...
Driver used (SB24_VTDRV_LB_1_04_0090.exe) available from creative.
Install and when done go to Control panel, Manage audio devices.. This should display a sound window with devices listed, select SB live and in bottom left corner click configure. Should be pretty much self explanatory after that.
My System SpecsSystem Spec
12 Jul 2012   #18
Ahsan Mansoor

windows 7 32 bit
 
 
sound card problem in windows 7

hello guys, can someone help me work my sound blaster live the model is SB0220 on my windows 7. i want to make it work but no matter drivers for win 7. the windows isnt digitally signing my soundcard. any help and suggestion are welcomed! hoping to get some reply from you guy
My System SpecsSystem Spec
14 Jul 2012   #19
Bernardus

Microsoft Windows 7 Ultimate 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Official kX Project Site -- News

kX Project -- Downloads page
This driver works perfect with the Creative Live series 5.1 SB0220 and another type, (the digital.) You have to play with the settings for the sound options and ok. The gameport didn't work but I don't use that one.
My System SpecsSystem Spec
15 Jul 2012   #20
Bernardus

Microsoft Windows 7 Ultimate 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Found another official one Customer Support: Downloads However you must install this one in advised mode The game port seems to be installed, but I can't test it. Ignore the warnings while installing.
My System SpecsSystem Spec
Reply

 sound blaster live does not work




Thread Tools




Similar help and support threads
Thread Forum
Sound blaster Live! Value card - no sound
Done the research, and unless I've missed something, there's a caveat that hasn't been addressed in this issue. I have an SB Live! value card, have installed the Daniel_K driver for it, following the suggestions about deleting the existing RealTek (which didn't seem to work, though I didn't put...
Sound & Audio
Creative Sound Blaster 5.1 live
Hi hope someone can help i am very new to this forum, at this moment i running XP Pro I want going to upgrade To Win 7 but it not recognise my Creative Soundblaster 5.1 sound card which is working fine under XP with all that i use i have been on web site to try & find driver for it. someone posted...
Sound & Audio
Sound Blaster Live for Windows 7
hello guys, can someone help me work my sound blaster live the model is SB0100 on my windows 7. i want to make it work but no matter drivers for win 7. the windows isnt digitally signing my soundcard. any help and suggestion are welcomed! hoping to get some reply from you guys!
Drivers
Sound blaster live!
The right drivers at the last post: https://www.sevenforums.com/sound-audio/79428-sound-blaster-live.html#post694541
Sound & Audio
Sound Blaster live
Please help. I have installed Win 7, but when I want to install Sound Blaster live software, it says that no sound card is installed. I installed the kx software and the sound works, but I cannot use my midi keyboard and somehow my micr0phone will not work in Skype. I would realy like my...
Hardware & Devices
Sound Blaster 5.1 Live!
hi at everybody. i'm new on this forum... yesterday i've installed windows 7 on my desktop pc, but i've some problems with audio card : model -> Creative Sound Blaster Live! 5.1 where i can find correct drivers for this audio card??? thanks a lot
Drivers


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 22:30.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App