Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Window 7 audio not working please help !!

24 Oct 2010   #211
ipodtouchme

Window 7 Ultimate 64bit
 
 

Hey everyone i brought the Creative PCI-E Titan-Co Titanium sound card now it works !!!!
Thanks everyone who try to help !!
I guess your right !! brianzion .... the sound card works
on the behalf of my computer i would like to say thank you ...
!! but theres one thing theres no driver for Creative PCI-E Titan-Co Titanium sound card for window 7 ... i let my computer to install itself ... it works but is that alright ????


My System SpecsSystem Spec
.
24 Oct 2010   #212
brianzion

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

good morning!!! o5.30 am here thats great news, what does it say in the instructions anything about drivers? im having a look on there website now for you if it aint broke dont try and fix it!!
My System SpecsSystem Spec
24 Oct 2010   #213
brianzion

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

Creative PCI Express Sound Blaster X-Fi Titanium Sound Card - Chosen by Pro Gamers

is it this one because it says you get in the package


PCI Express Sound Blaster X-Fi Titanium sound card
Quick Start leaflet
Installation CD containing:
Drivers for Windows®
Creative software suite
User's Guide


Software
Mode Switcher (to switch between Audio Creation, Entertainment and Game mode)
Audio Console
Creative MediaSource
Smart Recorder
SoundFont Bank Manager
Speaker Connection Wizard
THX Setup Console
Volume Panel
WaveStudio
Console Launcher
Creative Diagnostics
Get PowerDVD (Internet Download)

it has the driver here for it look in the pic i posted and go to the link here>>>

http://support.creative.com/Products...T=CategoryID:1



http://www.creative.com/products/soundblaster/howto/


Attached Thumbnails
Window 7 audio not working please help !!-brys-soundblaster.png  
My System SpecsSystem Spec
.

25 Oct 2010   #214
brianzion

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

post a speccy summary of the sound card my friend
My System SpecsSystem Spec
25 Oct 2010   #215
ipodtouchme

Window 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by brianzion View Post
post a speccy summary of the sound card my friend
alright wait up !!!
My System SpecsSystem Spec
25 Oct 2010   #216
brianzion

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

go to this link Creative Worldwide Support > PCI Express X-Fi Titanium

at the bottom of page to the right click on the link underneath Automatically updates your Creative product

its a big blue button
My System SpecsSystem Spec
25 Oct 2010   #217
ipodtouchme

Window 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by brianzion View Post
go to this link Creative Worldwide Support > PCI Express X-Fi Titanium

at the bottom of page to the right click on the link underneath Automatically updates your Creative product

its a big blue button
ALright done it ... it works now
i got the control panel for the creative sound card !! thank you
cost a lot but its worth it !! thanks again
My System SpecsSystem Spec
25 Oct 2010   #218
brianzion

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

Quote   Quote: Originally Posted by ipodtouchme View Post
Quote   Quote: Originally Posted by brianzion View Post
go to this link Creative Worldwide Support > PCI Express X-Fi Titanium

at the bottom of page to the right click on the link underneath Automatically updates your Creative product

its a big blue button
ALright done it ... it works now
i got the control panel for the creative sound card !! thank you
cost a lot but its worth it !! thanks again
so send a screen shot of the control panel i may think about getting one!! £75.00 over here when you got the control panel did it install the proper driver?
My System SpecsSystem Spec
25 Oct 2010   #219
ipodtouchme

Window 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by brianzion View Post
Quote   Quote: Originally Posted by ipodtouchme View Post
Quote   Quote: Originally Posted by brianzion View Post
go to this link Creative Worldwide Support > PCI Express X-Fi Titanium

at the bottom of page to the right click on the link underneath Automatically updates your Creative product

its a big blue button
ALright done it ... it works now
i got the control panel for the creative sound card !! thank you
cost a lot but its worth it !! thanks again
so send a screen shot of the control panel i may think about getting one!! £75.00 over here when you got the control panel did it install the proper driver?
it install properly its no in my control panel option but its in under a creative folder, but it has everything that i need to adjust my sound systems so its all good
better then my mother board system but the thing it cost money >.<


Attached Thumbnails
Window 7 audio not working please help !!-ahuh.png  
My System SpecsSystem Spec
25 Oct 2010   #220
brianzion

Operating System : Windows 7 Home Premium Edition 6.01.7600 SP1 (x64)
 
 

the reviews are very good did you get what i have marked in the screenshot?


Attached Thumbnails
Window 7 audio not working please help !!-bry-creative.png  
My System SpecsSystem Spec
Reply

 Window 7 audio not working please help !!




Thread Tools




Similar help and support threads
Thread Forum
Realtek audio, Gigabyte mobo: strange-sounding audio, mic not working
I have a self-assembled desktop PC - full specs in the signature below, but in short, it has an AMD Phenom II X6 1090T processor on a Gigabyte GA-970A-DS3P mainboard, which uses a Realtek Azalia ALC887 on-board sound system. I have no loudspeakers and listen to the computer sound exclusively...
Sound & Audio
Window 7 from XP audio driver changed.
Have updated from XP pro 32 bit to Windows 7 pro 32 bit , before the audio settings were from Realtek HD audio controller now they are Microsoft High Definition Audio Device. This is a very basic device , have checked on the Asrock site for a Realtek W7 driver but the latest one is a Vista...
Sound & Audio
Audio Jack not working, but USB Audio is.
My self built computer recently had a change of motherboard, I now have a Asrock N68C-GS FX. The front cases' and computers back audio jack are not working, I have tried numerous headphones and speakers. However my USB headset works perfectly. My drivers are all up to date, I'm struggling to...
Sound & Audio
Asus onboard audio no longer working since enabling front panel audio.
My audio rear outs used to work, but even so, i was primarily using hdmi out from my video card. I was also diagnosing BSODs at the time and sent my mobo back to asus for an rma. When it got back, I placed it in a different case and attached the font panel audio. Due to a new living...
Sound & Audio
Audio stops working, "No Audio Output Device Installed"
I'm running a Dell XPS 420, which came with Windows Vista. I decided this morning that I was going to give Windows 7 a try, backed up some media on another PC, and did a completely fresh install. Everything worked perfectly, I didn't even have to install any drivers. My native resolution was...
Sound & Audio
Onboard audio not working and audio drivers won't install
Hello everyone, I'm having a problem using my motherboard’s onboard HD audio instead of my video card’s audio, so without further ado here is the situation; I have an Asus maximus iii gene motherboard which has a SupremeFX X-Fi built-in sound card (this is a very nice card provided you can...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:55.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App