Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No sound via HDMI to ASUS Monitor

17 Jan 2011   #21
2MoveWreckingCr

Windows 7 Home Premium 32bit
 
 

Quote   Quote: Originally Posted by p5bdkw View Post
According to the DxDiag, your sound device vendor is 10EC which is Realtek,
so it's ok to install the Realtek HD audio driver.
However, it doesn't enable HDMI sound.

According to the DxDiag, your display device vendor is 8086 which is Intel.
So you should have the "Intel Graphics" driver installed.
The HDMI driver may be packaged with the Intel Graphics driver.
Intel probably packaged it there, just as ATI does with it's video drivers.
So you probably won't find a download for an Intel HDMI audio driver on the
Intel site.

You can try uninstalling the Intel video driver and install this driver.......
http://downloadcenter.intel.com/Deta...=2991&lang=eng
Thanks p5, but I try to install the driver it I get an error message saying "The driver being installed is not validated for this computer. Please obtain appropriate driver information from the computer manufacturer"

I'm guessing this is driver won't work for my computer? I didn't uninstall my Intel video driver because I was afraid I wouldn't be able to find it again it something should happen. Could that have had any affect on this process? This is frustating


My System SpecsSystem Spec
.
18 Jan 2011   #22
Sardonicus

Windows 7 Home Premium 64 bit
 
 

Can you post a snippet of your device manager, Sound, video and game controllers?
My System SpecsSystem Spec
18 Jan 2011   #23
2MoveWreckingCr

Windows 7 Home Premium 32bit
 
 

Quote   Quote: Originally Posted by p5bdkw View Post
Can you post a snippet of your device manager, Sound, video and game controllers?
Ok heres a look at my device manager along with the properties of my sound devices.


Attached Images
No sound via HDMI to ASUS Monitor-sound-video-game-snippet.png 
My System SpecsSystem Spec
.

19 Jan 2011   #24
WindowsStar

Windows 7 Enterprise (x64); Windows Server 2008 R2 (x64)
 
 

If you plug headphones into the mini-jack do you have sound?
My System SpecsSystem Spec
19 Jan 2011   #25
2MoveWreckingCr

Windows 7 Home Premium 32bit
 
 

Quote   Quote: Originally Posted by WindowsStar View Post
If you plug headphones into the mini-jack do you have sound?
Yes when the laptop is connected to the monitor via HDMI and I plug my headphones in I get sound through the headphones. When the headphones are not in, I get sound through my laptop speakers.
My System SpecsSystem Spec
19 Jan 2011   #26
WindowsStar

Windows 7 Enterprise (x64); Windows Server 2008 R2 (x64)
 
 

The reason I asked is my system does the same thing. To get the audio on the TV\monitor I had to do 2 things. 1) Make sure the TV\Monitor was receiving the audio via HDMI. There may be a setting in the menus that say PC audio (analog or digital) or PC audio on HDMI et cetera. Everyone lists it differently. 2) I had to go into the audio settings on my Windows 7 machine and select the OUTPUT audio as the HDMI, once I did that I did not hear it on the speakers or the headphones and it worked on the TV\monitor.

On a side note several times I made the change in Windows 7 and had my headphones or external speakers plugged in and the output audio would not change or stick between reboots. You may have to disconnect your headphones and speakers or if you cannot disconnect the speakers disable the analog audio output, for this to work.

I hope that helps -WS
My System SpecsSystem Spec
19 Jan 2011   #27
2MoveWreckingCr

Windows 7 Home Premium 32bit
 
 

Quote   Quote: Originally Posted by WindowsStar View Post
The reason I asked is my system does the same thing. To get the audio on the TV\monitor I had to do 2 things. 1) Make sure the TV\Monitor was receiving the audio via HDMI. There may be a setting in the menus that say PC audio (analog or digital) or PC audio on HDMI et cetera. Everyone lists it differently. 2) I had to go into the audio settings on my Windows 7 machine and select the OUTPUT audio as the HDMI, once I did that I did not hear it on the speakers or the headphones and it worked on the TV\monitor.

On a side note several times I made the change in Windows 7 and had my headphones or external speakers plugged in and the output audio would not change or stick between reboots. You may have to disconnect your headphones and speakers or if you cannot disconnect the speakers disable the analog audio output, for this to work.

I hope that helps -WS
Thanks WS but the issue is that there is no HDMI icon under Playback Devices to select. I have checked to show all disabled and disconnected devices but I still have icon to select. Also, my monitor does not have any settings to allow me to change between analog and digital from a PC.

I find this whole thing strange because under device manager it shows I have an Intel High Definition HDMI, but there is no icon for HDMI under playback devices.
My System SpecsSystem Spec
20 Jan 2011   #28
WindowsStar

Windows 7 Enterprise (x64); Windows Server 2008 R2 (x64)
 
 

I am at a loss. Must be a faulty driver.
My System SpecsSystem Spec
25 Jan 2011   #29
2MoveWreckingCr

Windows 7 Home Premium 32bit
 
 

Quote   Quote: Originally Posted by WindowsStar View Post
I am at a loss. Must be a faulty driver.
Thanks WS, this is truly a frustrating thing. The laptop originally came with Vista so I wonder if something was lost or corrupted in the upgrade to Seven.
My System SpecsSystem Spec
25 Jan 2011   #30
Wishmaster

Windows 7 Home Premium 64bit
 
 

If you right click the Volume Icon in the taskbar and choose Playback Devices it does not show a HDMI device like in my snip?

No sound via HDMI to ASUS Monitor-capture.jpg


If not, I would agree with WindowsStar. Possibly a faulty driver.
it may be worth downloading and re-installing.


My System SpecsSystem Spec
Reply

 No sound via HDMI to ASUS Monitor




Thread Tools




Similar help and support threads
Thread Forum
HDMI monitor no speakers-no sound from anywhere when connected?
I have an external monitor with no speakers I use as a dual display along with my laptop monitor. No sound comes out of my laptop speakers nor when I hook up external speakers to it while I have the external monitor hooked up by the HDMI cable. Is there anything I can do to get this to work?...
Sound & Audio
No Sound via HDMI on monitor speakers??!!!!?!!
Hello guys, I bought a new monitor from LG and connected it via HDMI to my laptop but the sound does not work on the speakers of my monitor could you help me please???
Sound & Audio
No sound via HDMI to ASUS Monitor
Despite going through the basic steps in disabling any other playback device but my monitor, I am still having trouble getting any sound on my monitor. I have an Asus VS238H-P and it is plugged from my laptop by a HDMI cable. Here is what I currently have: ...
Sound & Audio
ASUS VE248Q Monitor - No VGA Signal & HDMI not working
Hi All, I just set-up my new Asus computer with an Asus monitor. It seemed like a straight-forward task. I hooked up both the VGA and HDMI cables to the nVIDIA graphics card slot in the back of the tower. I keeping getting this message "VGA No Signal". I tested the VGA cable by using it on...
Graphic Cards
Loss of monitor sound via HDMI
Sometime over the past 3 days i have lost the sound come through the Sync-Master SB550_s27B550v (HMDI) i am at a loss on how to restore the sound. In the sound setting there is no monitor displayed only Speakers (front headphone jack works). & Realtek Digital Output. in the Realtek setting i have...
Sound & Audio
Asus K61-IC Sound coming from speakers when HDMI is plugged in
Hi everyone, Here is the issue I'm having. I have an Asus K61-IC dual booting Windows 7 Professional x64 (default) & Fedora 16 x64. In Windows, whenever I plug in a HDMI cable to watch a movie on my LCD TV audio will only come out of laptop speakers and when I open audio properties it says...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:17.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App