Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Creative XFI Xtreme problem

08 Mar 2011   #11
Ellebrius

Windows 7
 
 

Found it:
ASUSTek Computer in.
P5K SE
Intel P35/G33/G31

American Megatrends Inc.
Version 0901


My System SpecsSystem Spec
.
08 Mar 2011   #12
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Would also help to know which X-Fi. There is essentially three different series,

1. Xtreme Audio

2. Original X-Fi, which includes the Xtreme Music, Platinum, etc.

3. The new Titanium series.

all of which use a different driver.
My System SpecsSystem Spec
08 Mar 2011   #13
Ellebrius

Windows 7
 
 

Found this:

ASUSTeK Computer Inc. Model P5KSE
Chipset Intel P35/G33/G31 Rev' A2
Southbridge Intel 8280 1B (ICH9) Rev 02

American Megatrends Inc. Version 0901
My System SpecsSystem Spec
.

08 Mar 2011   #14
Ellebrius

Windows 7
 
 

SB X-FI Xtreme Audio, Version Driver 1.4.90
My System SpecsSystem Spec
08 Mar 2011   #15
Ellebrius

Windows 7
 
 

If we can't get this card to work properly again could someone suggest a soundcard that is compatible with Windows 7 and my system because that one sure isn't.
My System SpecsSystem Spec
08 Mar 2011   #16
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Let's try something completely different. If you haven't seen or heard of them give this modded driver/app package a try,

SB P17X Series Support Pack 2.7 (04/01/2010) - Aud... - Creative Labs

It is a self-extracting exe, so after downloading run it to extract. Do not install anything from it yet.

Next hope you're up for a bit of a challenge because first is to get rid of any drivers you have already installed and to stop Windows from re-installing upon startup.

1. Manually create restore point before beginning.

2. Look in Programs and Features and if there are any entries for Creative or X-Fi, uninstall them; do not restart yet.

3. Download this,

Take Ownership Shortcut

and install it. Very useful for what is next, but only use it on the specified folder(s).

4. Next open Windows Explorer and navigate to,

C:\Windows\System32\DriverStore\FileRepository

what you are looking for is the folder that Windows creates when you installed the driver for the first time, unfortunately it doesn't remove said folder when you uninstall the driver and that is why it gets re-installed upon startup. I also can't tell you specifically what the folder is called as I don't have one of those cards. Based on what it names it for my Xtreme Music for you it should be called (assuming 32 bit Windows),

P17.INF_x86_neutral_ (followed by a random string of numbers and letters)

If that isn't it do a search in the DriverStore folder for P17.INF. There may also be more than one depending on how many different driver files you have installed.

5. Once you have found the above folder(s), now right click on it and use the "Take Ownership" shortcut that was added from 32 above, and only use it on that folder(s), not the DriverStore folder itself.

6. Now delete the folder and restart. Now Windows won't automatically re-install the driver for the card.

7. Next go back to the extracted driver folder and run setup.exe there, that should get the driver installed.

If the driver won't install post back and I'll give a couple of methods to install it manually. Don't use the disk that came with the card unless you got it after Windows 7 came out as at best it will have an older Vista driver on it.
My System SpecsSystem Spec
08 Mar 2011   #17
Ellebrius

Windows 7
 
 

OK! Thank you for all this and it does seem a bit of a challenge, but heck I love those.

I'm gonna go try it now but I might take a while.

Will post back as soon as I get results one way or the other.

I am assuming you want me to also uninstal the Audio Console, Alchemy... etc ?
My System SpecsSystem Spec
08 Mar 2011   #18
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Yes, uninstall anything and everything you can find in Programs and Features to do with the card. All of those are included in the modded package so you will get them back.
My System SpecsSystem Spec
08 Mar 2011   #19
Ellebrius

Windows 7
 
 

I uninstalled everything and deleted the P17 folder.

Gonna restart comp now and try to install the downloaded Support Pack.

Be right back!
My System SpecsSystem Spec
08 Mar 2011   #20
Ellebrius

Windows 7
 
 

It took a while to install but it said it did. I got the final message 'Successfully installed you must restart your computer' but when the comp rebooted there was no sound. If I go to control panel---sound---It says no audio device installed.

You said to post back if it didn't work. I'm here and wont try anything else till I hear from you.
My System SpecsSystem Spec
Reply

 Creative XFI Xtreme problem




Thread Tools




Similar help and support threads
Thread Forum
Creative SB X-FI Xtreme Gamer / upgrade
Hello. I want to upgrade my soundcard Creative SB X-FI Xtreme Gamer and i don't if it's worth. For now i use my headphones Sennheiser 429 HD + Logitech 5.1 x530 but soon i'll have Behringer MS40 instead Logitech 5.1 x530 What would you advice me ? Should i go for Asus Xonar ? Should i go again...
Sound & Audio
Creative X-fi Xtreme Audio
Bought this card today. Because it said support for vista, I thought it would work in Windows 7 as well. Installed the card and I had immediately sound. Then I went to the creative site to install the drivers because I had only control over the volume. There was no EAX, no bass control, nothing....
Sound & Audio
Creative Sound Blaster X-Fi Xtreme Audio PCI - microphone problem
Hello there. Yesterday i've installed this sound card and everything works fine but no microphone. I can see it in control panel but it doesn't work. Mic is fine as i was using it before. I have Win 7 64bit. If you have any idea what can cause the issue please help, if nothing will work i will...
Sound & Audio
Creative SB x fi xtreme audio delay problem!
Hi, I've recently bought a creative SB x-fi xtreme audio, and no matter what update i do, I keep having delay problems( 0.5 to 1sec) when connecting my guitar through the mic/line entry....... To make things worse, the driver even crashes and all sounds get delayed, i mean even in windows media...
Sound & Audio
Creative X-Fi Xtreme Audio
Does anyone know where i can download drivers for this card for the Windows 7 RC1? ive tried the Beta drivers off Creative and had no joy, the ones that came out when the "leaked" RC1 was out and im gettin majorly cheesed off.... ive got everythig else set up how i want except the fact ive no sound...
Sound & Audio
Creative X-Fi Xtreme Audio x64
Hello, my Windows 7 x64 (7100) found after a clean install new optional updates which included drivers for my soundblaster X-Fi Xtreme Audio. I also used the drivers I got with the cd and installed them on my system. Everything is working now except a few options. I get sound in 5.1, but when I...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:19.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App