Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Creative XFI Xtreme problem

08 Mar 2011   #31
Ellebrius

Windows 7
 
 

Ok, thank you for not giving up on me. I'm gonna go give it a try and will report back.


My System SpecsSystem Spec
.
08 Mar 2011   #32
Ellebrius

Windows 7
 
 

A bit confused here...

I go to Device manager but I don't see PCI Sound Blaster Card, what I do see is under Sound, video and game controller and Called SB X-Fi Audio is that the one you want me to use Step 2 on?
My System SpecsSystem Spec
08 Mar 2011   #33
sam2fish

Windows 7 Professional x64
 
 

Ellebrius, I feel for you man...(without sound and internet, a computer has no meaning..).

I also have the XFi Xtreme Audio soundcard, in Win7pro. But with none of your problems. It is a 7.1 card, but I use a 5.1 speaker system. Pssst, my 5.1's work better when I have 4.1 mode enabled, with surround.

Creative was slow to get on-board with drivers for Windows-7. They make a damn good soundcard(s), but are a bit tardy with current drivers.

When I first installed Windows-7, Mikey saw the soundcard, but there was no real control of it. So I wanted to install the soundcard drivers off the cd, but Mikey didn't like that. So I tried installing them with using "Compatibility Mode", and it worked.

Since then I have done Windows updates, and all stays put.

This is all I can say. Here are snapshots of how it works on my system...


Attached Thumbnails
Creative XFI Xtreme problem-xfi-xteme-audio-my-program-features.jpg   Creative XFI Xtreme problem-xfi-xtreme-control-panel-sound.jpg  
Attached Images
Creative XFI Xtreme problem-xfi-audio-my-device-manager.jpg 
My System SpecsSystem Spec
.

08 Mar 2011   #34
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Yep, that's the one.
My System SpecsSystem Spec
08 Mar 2011   #35
Ellebrius

Windows 7
 
 

Stuck at Step 6


Insert the Creative Sound Blaster installation CD into your CD/DVD-ROM drive.
Exit from the installation wizard if it autoruns.
Click Start, Run and Browse. Browse to Z:\AUDIO\DRIVERS (where Z:\ represents the CD Rom drive Letter), and run CTZAPXX.EXE.
If you have a Sound Blaster X-Fi card, run SETUP.EXE.

If you have a Windows Vista/Windows XP combination CD-ROM disk for your Sound Blaster Audgy SE (SB0570) card, browse to Z:\XP\AUDIO\DRIVERS, and run SETUP.EXE.

In the Creative Driver Update Utility screen, select Driver Uninstallation under Update Option and select WDM Drivers under Driver Type.
Select the option Delete all shared Creative audio driver files, and and click OK.

------------------------------

Here I point it to the setup file in the extracted folder you had me download but it doesn't a Creative Driver Utility Screen, it just goes straight to Updating and installing drivers???
My System SpecsSystem Spec
08 Mar 2011   #36
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

OK try the the one in the location specified on the disk. If it doesn't work download this one that is from the driver I am using for my card (that file shouldn't be card/driver specific and work with any Creative card/driver), and is a bit older than the one in the Xtreme Audio pack. Just extract and rep[lace the one in your extracted folder with it.

Also just to be clear you are running the setup.exe found in the Driver folder, and not the one found in the main folder?


Attached Files
File Type: zip Setup.zip (16.7 KB, 34 views)
My System SpecsSystem Spec
08 Mar 2011   #37
Ellebrius

Windows 7
 
 

Since I couldn't find Creative Driver Update Utility screen in the Daniel K utility folder I extracted I went to my CD and got it to open from there and continued with all the steps. I had some trouble deleting the files in the Windows Temp folder but I cleared the attributes and managed. I'm soo tired now I can,t remember if I emptied the Recycle bin or not.

I then restarted the computer and rand the setup file in my extracted folder and installed the drivers. I still have the same problem: sound but not Audio Console etc. that recognizes the Sound Card.

I'm gonna give it another try again tomorrow starting from scratch and using *all* the steps slowly and carefully. I'll post back with my results. Ty again so much for all your time and help and to all others who posted.
My System SpecsSystem Spec
08 Mar 2011   #38
Ellebrius

Windows 7
 
 

By the way I just found the setup.exe file in the Driver folder. The instructions said got to Audio--Driver--setup.exe and there are no Audio folder. But there is a driver folder with it in it. Gonna start fresh tomorrow. Will let you know.
My System SpecsSystem Spec
08 Mar 2011   #39
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

OK, have a good night and see you here tomorrow.
My System SpecsSystem Spec
08 Mar 2011   #40
Ellebrius

Windows 7
 
 

I couldn't resist and I tried again carefully.

Guess what? It WORKS!!!!!!!!!!!!!!!

Everything works! Audio Console etc. I can't believe it!

You're the best! Thanks sooo much for all your help and sticking with me through all this and persisting until the problem was resolved. Can't tell you enough how much I appreciate all your efforts.

Again thank you... and now dinner time, I deserve it.
My System SpecsSystem Spec
Reply

 Creative XFI Xtreme problem




Thread Tools




Similar help and support threads
Thread Forum
Creative SB X-FI Xtreme Gamer / upgrade
Hello. I want to upgrade my soundcard Creative SB X-FI Xtreme Gamer and i don't if it's worth. For now i use my headphones Sennheiser 429 HD + Logitech 5.1 x530 but soon i'll have Behringer MS40 instead Logitech 5.1 x530 What would you advice me ? Should i go for Asus Xonar ? Should i go again...
Sound & Audio
Creative X-fi Xtreme Audio
Bought this card today. Because it said support for vista, I thought it would work in Windows 7 as well. Installed the card and I had immediately sound. Then I went to the creative site to install the drivers because I had only control over the volume. There was no EAX, no bass control, nothing....
Sound & Audio
Creative Sound Blaster X-Fi Xtreme Audio PCI - microphone problem
Hello there. Yesterday i've installed this sound card and everything works fine but no microphone. I can see it in control panel but it doesn't work. Mic is fine as i was using it before. I have Win 7 64bit. If you have any idea what can cause the issue please help, if nothing will work i will...
Sound & Audio
Creative SB x fi xtreme audio delay problem!
Hi, I've recently bought a creative SB x-fi xtreme audio, and no matter what update i do, I keep having delay problems( 0.5 to 1sec) when connecting my guitar through the mic/line entry....... To make things worse, the driver even crashes and all sounds get delayed, i mean even in windows media...
Sound & Audio
Creative X-Fi Xtreme Audio
Does anyone know where i can download drivers for this card for the Windows 7 RC1? ive tried the Beta drivers off Creative and had no joy, the ones that came out when the "leaked" RC1 was out and im gettin majorly cheesed off.... ive got everythig else set up how i want except the fact ive no sound...
Sound & Audio
Creative X-Fi Xtreme Audio x64
Hello, my Windows 7 x64 (7100) found after a clean install new optional updates which included drivers for my soundblaster X-Fi Xtreme Audio. I also used the drivers I got with the cd and installed them on my system. Everything is working now except a few options. I get sound in 5.1, but when I...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:28.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App