Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: sound blaster audigy giving errors

20 Jul 2009   #1
ranjan2001

Windows 7 Ultimate x64 build 7600
 
 
sound blaster audigy giving errors

Win 7 x64 build 7100
I cleaned the dust from the comp & since then I am getting this error, sound is only working on front 2 speakers. i ensured the card is properly installed, which it is. Last 4 months its been working fine with 4.1 speakers.

Now I cant start the EAX control setting.

I uninstalled the card & drivers & cleaned the registry then reinstalled the drivers from CD.

On installation of the drivers & sound it detects by old speakers as stereo only but all 4 speakers give sound which is too bad, I can now use the EAX control settings
then I run the windows update it download a creative driver which when installed does show me 4.1 speakers but now the EAX control panel wont open & gives error
"the audio device supported by this application is not detected. The application will exit"

any clue what went wrong & how can I get this working?




My System SpecsSystem Spec
.
20 Jul 2009   #2
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote:
any clue what went wrong & how can I get this working?
Yes, this,

Quote:
On installation of the drivers & sound it detects by old speakers as stereo only but all 4 speakers give sound which is too bad, I can now use the EAX control settings
then I run the windows update it download a creative driver
Don't install the driver from Windows Update if things are working. In fact it is a good idea to NEVER install a sound or video driver from Windows Update, they haver a very bad habit of breaking things.

Uninstall the Windows Update driver and see if things start working again. If that doesn't work running System Restore using the last restore point before the Windows Update driver got installed should fix it.
My System SpecsSystem Spec
21 Jul 2009   #3
7echno7im

Windows 7 7600.16384 x64
 
 

here is the latest 64-bit driver for your SoundBlaster Audigy Value....

Creative Worldwide Support

After installing this, it will also install an AutoUpdate applet that you can search and update your creative drivers and apps.

I thought EAX support on DirectSound was dropped with Vista (Becasue DX10 didn't include DirectSound)?

Look for the Creative Console Launcher
and also Alchemy, which is a work-around for restoring EAX to DirectSound games.


Alchemy use to be free for X-Fi only,10 bucks for audigy, but after a backlash, they made is free....

You can read more here about the app and decide if you want it:
http://connect.creativelabs.com/alch...digy/Home.aspx
My System SpecsSystem Spec
.

21 Jul 2009   #4
ranjan2001

Windows 7 Ultimate x64 build 7600
 
 

7echno7im
Thanks its now working with the new drivers which you gave the link, but the EAX does not load separately as it was in the earlier version which I installed from the CD, instaed it now loads along with sound properties.


Attached Thumbnails
sound blaster audigy giving errors-2009-07-21_205216.jpg  
My System SpecsSystem Spec
21 Jul 2009   #5
ranjan2001

Windows 7 Ultimate x64 build 7600
 
 

I cant get the bass boost/bass management & EQ to work at all.
When I select EQ & hit the setting button the same window (shown at right) opens up which does not show any equalizer.

How do I get the equalizer?

Another question I don't game at all will I benefit by installing Creative ALchemy 1.25.10 in my mp3 music & watching movies?

The note on creative site says
Do not install this application if you do not play DirectSound3D games in Windows Vista.
My System SpecsSystem Spec
21 Jul 2009   #6
7echno7im

Windows 7 7600.16384 x64
 
 

Attachment 19381no alchemy only provides EAX for old directsound games.

As far as the EQ (Creative COnsole Lauincher)

I guess it is not supported on Audigys any more, but you could try it:
http://support.creative.com/download...wnloadId=10941

Try to run the autoupdate app if it installed with the driver.


Attached Images
sound blaster audigy giving errors-cautoupdate.jpg 
My System SpecsSystem Spec
21 Jul 2009   #7
7echno7im

Windows 7 7600.16384 x64
 
 

Another way to get the the EQ from the bast driver is
go to control panel>Sound>right click speakers>properties>Tone
You just get the basic treble and bass but its better than the muffled sound of the default sound.
My System SpecsSystem Spec
Reply

 sound blaster audigy giving errors




Thread Tools




Similar help and support threads
Thread Forum
Sound Blaster Audigy 2 Platinum ex does not sound in Win7x64
Hello; I'm trying to make my "Sound Blaster Audigy 2 Platinum ex" works on Windows 7 64 bits, I did install the most new version of the drivers provided by Creative Labs, it seems like it is installed without any problems....the Device Manager shows all drivers are installed correctly...when I...
Sound & Audio
Creative Sound Blaster Audigy 24bit Sound Card
I installed windows 7 a little while ago but i cant seem to get a driver that will recognize my sound card. the computer doesnt think its installed correctly but when i was using Xp it was just fine. ive tried another PCI slot but no such luck. all of the drivers i have tried tell me that they dont...
Drivers
Sound Blaster audigy 2 Value malfunction
Hi. First of all, i would like to say, that i am from central europe, non-english speaking country so be tolerant to my language mistakes, please. Thanks. I didn't find here, or anywhere else, someone with similar problem, so that im asking you for help. Some time ago my sound card just stop...
Sound & Audio
Sound Blaster Audigy 2 isn't nearly as loud in Win 7
my sound card is the SB audigy 2. Back in XP the drivers usually worked fine and produced the right 'loudness' of sound. however in windows 7 the drivers that were automatically installed upon the OS installation do NOT play audio at the regular decibel levels. I tried going to downloading the...
Sound & Audio
Sound Blaster Audigy
seems a lot of people are having issues with the sound blaster audigy cards, me included. Im dual bootin windows 7 and XP, on windows XP my sound card works and everything, when i boot in windows 7, dosnt even detect my card. I have the driver i need to get it to work, its just not detecting it to...
Sound & Audio
Sound Blaster Audigy 2 isn't nearly as loud in Win 7
my sound card is the SB audigy 2 zs platinum. Back in XP the drivers usually worked fine and produced the right 'loudness' of sound. in vista i had to try a few different sets of drivers but got it working correct. however in windows 7 the drivers that were automatically installed upon the OS...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:38.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App