Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No HDMI audio to TV

14 Jul 2011   #11
Sardonicus

Windows 7 Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by bleron View Post
I cant solve this problem, but nevertheless I bought a 3.5mm stereo cable.
I removed the SPDIF cable from the computer, and I still have an HDMI cable connected to a DVI-HDMI adapter. The stereo cable is connected from the computer to the TV, but here is the problem:

When the HDMI cable is disconnected from the TV, I hear audio from the PC.
When the HDMI cable is connected to the TV, I hear no audio whatsoever from the PC.

Any help would be appreciated
Your card doesn't do HDMI. Since your card has DVI ports and DVI doesn't carry audio, the DVI-HDMI adapter is useless (for audio).

You may be able to use SPDIF to get audio from the card, to the motherboard, to an AV receiver, using the SPDIF outputs on the motherboard, but that's a separate issue.


My System SpecsSystem Spec
.
14 Jul 2011   #12
bleron

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by p5bdkw View Post
Quote   Quote: Originally Posted by bleron View Post
I cant solve this problem, but nevertheless I bought a 3.5mm stereo cable.
I removed the SPDIF cable from the computer, and I still have an HDMI cable connected to a DVI-HDMI adapter. The stereo cable is connected from the computer to the TV, but here is the problem:

When the HDMI cable is disconnected from the TV, I hear audio from the PC.
When the HDMI cable is connected to the TV, I hear no audio whatsoever from the PC.

Any help would be appreciated
Your card doesn't do HDMI. Since your card has DVI ports and DVI doesn't carry audio, the DVI-HDMI adapter is useless (for audio).
thats why i got a 3.5mm stereo cable running from my computer, yet im still having trouble getting picture with sound.

this is actually a different problem. sorry, i didnt really wanna make another thread.
My System SpecsSystem Spec
14 Jul 2011   #13
Sardonicus

Windows 7 Home Premium 64 bit
 
 

You may be able to get it work using the tutorial, but from what I've read, it's hit or miss.
If all fails, you'll need to get a card with an HDMI port.
My System SpecsSystem Spec
.

14 Jul 2011   #14
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by p5bdkw View Post

Your card doesn't do HDMI. Since your card has DVI ports and DVI doesn't carry audio, the DVI-HDMI adapter is useless (for audio).
Yes and no. Yes you're right that a normal DVI to HDMI adapter or cable won't carry audio, there are some that do. Some of the early ATI HD 2xxx series of cards that didn't have a native HDMI port came with an adapter like this,

http://www.newegg.com/Product/Produc...-007-_-Product

that does allow audio over HDMI from the proper DVI port on the card (only one of the two DVI ports supported it). The adapter is wired up differently to a regular adapter to make use of the unused pins to allow for audio. Same goes for any Nvidia card that used the SPDIF header for audio, only most of them didn't come with the adapter but could usually be obtained from the card manufacturer after asking about it.

bleron one thing comes to mind if your adapter/cable is one that allows for audio, did you happen to try reversing the SPDIF cable on either the card or the motherboard header? All it is is a two wire connection and if it is backwards on one end it will shows as being available/in use, but no sound comes out.
My System SpecsSystem Spec
14 Jul 2011   #15
Sardonicus

Windows 7 Home Premium 64 bit
 
 

Stormy13 is back.
Bleron missed you.
I hope he get's it working.
My System SpecsSystem Spec
14 Jul 2011   #16
bleron

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by p5bdkw View Post
Stormy13 is back.
Bleron missed you.
I hope he get's it working.
lol, i appreciate both of your help

Quote   Quote: Originally Posted by stormy13 View Post

bleron one thing comes to mind if your adapter/cable is one that allows for audio, did you happen to try reversing the SPDIF cable on either the card or the motherboard header? All it is is a two wire connection and if it is backwards on one end it will shows as being available/in use, but no sound comes out.
the thing is that i actually have this
EVGA | Products

the connection on the card is irreversible.
on the motherboard, ive alreadyy tried that and still nothing
My System SpecsSystem Spec
14 Jul 2011   #17
bleron

Windows 7 Ultimate x64
 
 

i assumed that that also works with XFX graphics cards so i got it.
but as of now, I give up on this hdmi and spdif, so I got a 3.5mm stereo cable running from my computer to my Sony tv.

so heres the new story,
when i connect both the HDMI cable and stereo cable to the TV, I get only picture, no sound.
but when i disconnect the HDMI cable and leave only the stereo cable connected, I get sound, but no picture.
this is driving me nuts

either way, I cant get it right.
My System SpecsSystem Spec
14 Jul 2011   #18
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Probably asking the obvious, but did you make sure that when both are connected that the Realtek audio (speakers and not digital) is set as the default playback device?
My System SpecsSystem Spec
14 Jul 2011   #19
bleron

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by stormy13 View Post
Probably asking the obvious, but did you make sure that when both are connected that the Realtek audio (speakers and not digital) is set as the default playback device?
lol, yes, speakers are set as default. my speakers are working fine but when i connect the same cable to the TV I get the above situation.
My System SpecsSystem Spec
14 Jul 2011   #20
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

You wouldn't happen to have anything showing in Device Manager for Nvidia audio would you? If so disable any that are showing (can be up to 4) and see what happens.

Also if you're using the latest or reasonably recent video driver, it is possible that when installing it also installed the Nvidia audio. Open Programs and Features and locate the Nvidia drivers entry and start the uninstall. That should bring up a Nvidia window asking whether to uninstall everything or only selected drivers, something like this,

No HDMI audio to TV-nvidiainstall.png

If the audio driver is there select only it to uninstall and leave the rest.


My System SpecsSystem Spec
Reply

 No HDMI audio to TV




Thread Tools




Similar help and support threads
Thread Forum
Realtek HDMI Output ATI HDMI Audio -Not Plugged In-
I'm trying to hook up my TV with my computer, and for the most part it's working. The video goes through and I get how to control it and everything. The only thing not working is the sound. I'm using an HDMI to HDMI cable, and like I said the video is fine. Also, when the cable is plugged into...
Sound & Audio
No HDMI audio after running Win 7 audio trouble shooter
I have an Acer Aspire Laptop 57362-4790 running Win 7 with all the latest updates. Audio is an Intel(R) High Definition Audio HDMI, and Realteck HDMI. Because I had no headphone output with the computer connected to my TV via the HDMI out I ran the Windows audio trouble shooter. I got a...
Sound & Audio
No Audio, HDMI (unplugged), No Audio device listed
Hi, I just got a new (cascaded) computer with seemingly no standard audio. The audio icon is a speaker with and X through it and the only audio device that populates the Playback Devices list is the HDMI digital audio. I have audio on the motherboard (think I can find it?? nope) and...
Sound & Audio
HDMI audio problem when connecting LCD TV to PC via HDMI
hi all, I have my media center PC connected to a Sansung LCD TV through an HDMI cable. Everything works fine; the PC detects TV and both audio and video travel through the HDMI cable from PC to TV The problem happens when I turn the TV OFF and ON. In this case, the video is back but not the...
Sound & Audio
No audio from rear jack & no hdmi audio
hi guys pretty new here so take it easy plz (lol) i have 2 problems regarding audio. 1. when i upgraded my pc i added a okish motherboard but i wanted sound from my front panel so i took the jumper cap off the prongs for audio but now i have added some desktop speakers and want to plug them...
Graphic Cards
Windows 7 - HDMI out no audio - Intel HDMI audio
Hey everyone, I recently upgraded to Windows 7 (Build 7100) from Vista (32 bit) and am having trouble getting audio from my HDMI out port. I am using the Mobile Intel 965 Express Chipset and have upgraded to the latest available driver but still no luck. I have attached a screen shot of my...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:36.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App