HT Omega Striker 7.1 and Windows 7 Problem

Page 2 of 4 FirstFirst 1234 LastLast

  1. Posts : 1
    Win 7 Ultimate
       #11

    dornif
    Thank you very much! Thought I was losing my mind there. Last thing I wanted to do was put that nasty CL audigy4 back in (removed all CL products when i read about them purposely crippling the Vista drivers) .... was accually thinking of using the onboard audio!
    Again thanks lots
      My Computer


  2. Posts : 3
    Windows 7 Professional x64
       #12

    I would submit that the relatively complicated procedure described above is not required for most. My HT Omega Striker 7.1 is working perfectly in Win7 Pro x64 and all I had to do was delete the HsMgr.exe file from the extracted files before running the setup program.
      My Computer


  3. Posts : 7
    Windows XP
       #13

    It would seem this issue is effecting a lot of the c-media based cards.
    Mines is a generic one mady by A-Sound using the cmi8768+ and within x64 apps would work, but ddl would remain stereo. And in x86 I had the issues as in here with no apps running ontop of the ddl still in stereo.
    Still since I have killed the task everythings as it should. I'd rather not replace it since if using other ones sticks it back to stereo again, then thats a bit of an issue still.

    Maybe something about the thread title can be changed to it highlights c-media cards can be done ?
      My Computer


  4. Posts : 38
    Windows 7 Pro x64
       #14

    Thank you thank you


    I researched the Omega before i bought it and i was hoping that this thread was going to work for me and it did. awesome! im beginning to like this forum alot. My only issue now is figuring out how to force surround sound all the time even when i listen to music.
    Last edited by Heinz Getwellvet; 02 Oct 2009 at 05:31. Reason: question
      My Computer


  5. Posts : 7
    Windows XP
       #15

    kpoverdorf said:
    I researched the Omega before i bought it and i was hoping that this thread was going to work for me and it did. awesome! im beginning to like this forum alot. My only issue now is figuring out how to force surround sound all the time even when i listen to music.

    If you mean so the music will be on all speakers, seems you need to select 2 channel in DDLive mode to get it playing on 5.1. Leave it in 6 speaker mode then it will just come out as stereo.

    This is all a bit different to XP, thats for sure!

    Of course, if you arnt using DDlive but via the analogue outs, then im not sure whats what there, never used them!
      My Computer


  6. Posts : 38
    Windows 7 Pro x64
       #16

    Wow


    Thank you so much. I couldn't figure it out. That's great. Now, when i am watching a movie that has real surround sound will it effect the quality becuase its in 2 channel?
      My Computer


  7. Posts : 7
    Windows XP
       #17

    Assuming the film has a Dolby Digital or DTS soundtrack then it should switch to passthru and preserve the 5.1.

    One thing I have noticed about the control panel, to play games it suggests to switch it to 8 channel mode.
    This is all a bit different compared to the XP version, thats for sure.
      My Computer


  8. Posts : 1
    7
       #18

    wow its finally fixed DORNIF YOU are the man! 1mil thx


    I had to register to let dornif and all others looking for the fix know!! IF you follow his instructions to the T. Then Boys and Girls its BLUE SKIES nothing but BLUE SKIES do i see.....

    OMEGA STRIKER IS 100%!..Win 7600 final is very very happy, and that makes me feel sooooo good.

    I am in your debt for this borrow dornif. Glad i found this forum and your fix. Now all is smooth sailing w/ 7 final and my beloved Omega Striker

    Note: Striker icon appeared in tray after installing/rebooting, no more AVG alerts on the SysWOW64. I was getting false alarm on that as though it was some sorta Trojan? odd? really bugged me that did.
    Also during the boot i can hear the 7 boot sounds, before the fix it was at such a low faded level, i thought i was hearing things.

    My gaming box now runs like a Billion bucks! This bug fix even seems to have helped the boot speed on 7 ,and smoother running as well! My Windows 7 was acting slightly sick prior, and the Volume Mixer-Speakers window it would flutter and fade, parts would disappear had to close and open to fix. Now Volume Mixer-Speakers window its acting totally normal, had to be the Omega Striker/Windows7 bug!


    Maybe, something minor you might fix to the instructs? for some that might get confused, its on step 3 concerning (PROGRAM): Copy striker81737W7ex\PROGRAM to s81731ex\Vista\Program.

    I understand you mean (PROGRAM FOLDER) some could, might get fouled up, and not see that "PROGRAM" you mean is the Program Folder. I had to ask myself if i was copy/paste/replace to the right place, sorta stalled me for a sec. HA!

    EXCELLENT BUG FIX BY dornif YOU ARE A SUPER HERO!
      My Computer


  9. Posts : 1
    Windows 7 ult 64bit
       #19

    SO i thought I followed to the T, went back 2x and redid each step (so i thought) and each time, i get to the end of the driver install, and it hangs up for a long time, and then tells me to plug in the card.

    I did research and it says that if this happens, it is because it is trying to install a 32bit driver or something like that. any help is appreciated.
      My Computer


  10. Posts : 8,870
    Windows 7 Ult, Windows 8.1 Pro,
       #20

    You don't need to bother with this procedure anymore because Omega has released new drivers for Windows 7. HT Omega - Driver Downloads
      My Computer


 
Page 2 of 4 FirstFirst 1234 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:41.
Find Us