Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 5.1 surround problems (realtek)

06 Nov 2009   #121
The Stodd

Windows 7
 
 

New Realtek drivers

Realtek

Will test later, fingers crossed.


My System SpecsSystem Spec
.
07 Nov 2009   #122
holfire

Windows Seven 64 bits
 
 

Even with this new driver, 5.1 doesn't work ! Only 2.1 =(

Anybody here have the solution ? I'm searching for so long !
My System SpecsSystem Spec
07 Nov 2009   #123
simonfilth

Windows 7
 
 

Quote   Quote: Originally Posted by 4n00815 View Post
I fix a problem... You only need to set blue jack as center/subwoofer speaker, red as side speakers and green/black as front speakers and it will work
But you can't really do it with the Windows 7 realtek manager. only in windows xp.

@holfire

yeah i know i've had the same problem ever since windows 7 came out during the summer and i still haven't found solution
My System SpecsSystem Spec
.

07 Nov 2009   #124
holfire

Windows Seven 64 bits
 
 

@simonfilth

Yeah so... I think we haven't the choice : Buy a sound card !

5.1 works on windows 7 only if we have a sound card, not just a chipset inteagreated in the motherboard.
My father have 5.1 and it perfectly works on 7, and he has a aureon 5.1 card.

I hope I'm wrong... I don't want buy something again !

Sorry if I don't speak english very well, I'm french.
My System SpecsSystem Spec
08 Nov 2009   #125
The Stodd

Windows 7
 
 

Quote   Quote: Originally Posted by holfire View Post
@simonfilth

Yeah so... I think we haven't the choice : Buy a sound card !

5.1 works on windows 7 only if we have a sound card, not just a chipset inteagreated in the motherboard.
My father have 5.1 and it perfectly works on 7, and he have a aureon 5.1 card.

I hope I'm wrong... I don't want buy something again !

Sorry if I don't speak english very well, I'm french.
Yep. same here. GRRRR!
My System SpecsSystem Spec
14 Nov 2009   #126
whoosh7

win7
 
 

heyguys - I have "just upgraded" from 7100 Ultimate 64 bit - to full release and I can tell you it now works properly ! 5.1 rear speakers, front, centre and sub all going with the latest realtek drivers and doing that disable uac after installing the realtek drivers and before re-booting
PS I registered just to post this :-) as this was the best thread I could find on T'InterWebThingy that told me I was not alone !
My System SpecsSystem Spec
14 Nov 2009   #127
Billy

 

Quote   Quote: Originally Posted by whoosh7 View Post
heyguys - I have "just upgraded" from 7100 Ultimate 64 bit - to full release and I can tell you it now works properly ! 5.1 rear speakers, front, centre and sub all going with the latest realtek drivers and doing that disable uac after installing the realtek drivers and before re-booting
PS I registered just to post this :-) as this was the best thread I could find on T'InterWebThingy that told me I was not alone !
I just tried this and music still won't play in 5.1, only 2.1... All my games play in 5.1 properly but I like music in 5.1 as well
My System SpecsSystem Spec
15 Nov 2009   #128
asilzade

Windows 7
 
 

i hope, everyone has done this
My System SpecsSystem Spec
15 Nov 2009   #129
match

Windows 7
 
 

I'd like to add my 2 cents as well. I, too, have the same problem. I have an onboard Realtek HD Audio driver and was working fine on my Windows XP. Since I installed Windows 7 Ultimate, the 5.1 speakers don't work on movies or music and the volume seems rather low. I have tested the 5.1 channels and all speakers should work fine but the current output is only receiving 2.1. It just seems like the audio is not being directed properly and it's all being clumped into the 2.1 speakers. Hope there is a solution or driver update for this soon because it's driving me insane.
My System SpecsSystem Spec
16 Nov 2009   #130
Billy

 

Quote   Quote: Originally Posted by simonfilth View Post
it's not fixed. still the same problem. although i found actually a nice solution but it doesn't work completely. i managed to get sound from all of my speakers, but it's not really 5.1 surround. it's just that i put that every single jack was front speakers so from all the speakers, i got the sound as it was played from the front speakers.
I just tried this and it sounds much better than speaker fill in my opinion, although I wouldn't use it playing games, where I actually get 5.1 surround.
My System SpecsSystem Spec
Reply

 Windows 7 5.1 surround problems (realtek)




Thread Tools




Similar help and support threads
Thread Forum
Realtek onboard sound card with 5.1 surround speaker fill problem
I recently installed a new motherboard Asus Sabertooth 990FX. It has an on-board sound card "Realtek® ALC 892 8-Channel High Definition Audio CODEC". I'm using 5.1 surround speakers from creative. Speaker fill with windows update driver, or Realteks driver from Asus' website, has the same outcome. ...
Sound & Audio
Realtek HD Audio RCA Recieve No surround
Hey all, I got a new (old/used) RCA Receiver (RV-9953A) and 5 monitors and a subwoofer. When I put in a cd or run the test tone on the receiver all of the speakers and subwoofer check out--no problems. When I run a test on the Realtek HD Audio Manager however, it doesn't want to play from...
Sound & Audio
5.1 Surround Problems with Realtek HD Audio Manager
Hi everyone! First post on the forums =P What the title says. Basically I have had to remove my soundcard (a Creative X-Fi Soundblaster) as it was completely blocking off the fan on my new graphics card (ATI Radeon HD 5850 - and yes there is no space left on my motherboard!). As a result I have...
Sound & Audio
Surround Sound + Realtek
OK So! Ive tried EVERYTHING even bought a new set of speakers thought the others were broken. I am running windows 7 ultimate and i have tried every realtek driver known to man. And I still can't get my surround sound to work I haven't re-assigned the jacks cause i am not to sure how to do that...
Sound & Audio
Surround Sound Problems Windows 7 64bit
Hi this is my first post so if I have'nt done something correct sorry in advance. But my problem is that I cannot get my surround sound to work on windows 7:cry:, it worked fine when i had XP. It has the option but just will not play it. I have a Abit AB9 pro motherboard, Quad Core 6600, 8GB...
Sound & Audio
Surround Problems
I just re-installed win 7 RTM and I can't get my sound drivers to work right. I have a Creative Soundblaster Extreme Gamer and a set of 5.1 surround speakers. I installed the drivers for win 7 and the console launcher to set up my sub. I clicked on 5.1 surround and bass redirection, the same thing...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 13:19.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App