Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 5.1 surround problems (realtek)

26 Jan 2010   #181
mutha88

Windows 7 x64
 
 

hdmi, why should I use optional "upmix-crap" in the Realtek drivers, like "Speaker Fill", when in Windows XP SP3, I have a pure, untouched, unupmixed, proper 5.1 sound in every windows or non-windows application?

The question is rhetorical.

And one more thing... In RARE cases my 5.1 is working, while playing games... Again, only under Windows 7...

I think too, that this isn't a Realtek failure... It is a Microsoft failure. They should fix it, now. My motherboard is produced in mid 2009... The audio chipset should be completely and "without-failure-ly" supported... Just like the Ubuntu or any other kind of Linux... This sucks!

This is my last negative post in this topic. I'll write to you guys, when my Realtek ALC1200 starts to work in Windows 7. Good luck to all!


My System SpecsSystem Spec
.
26 Jan 2010   #182
beefbrains

windows 7
 
 

I will give microsoft this much. there are so many versions of drivers for each device that it makes it very difficult to test that they all will work before the final release. But on the other hand how many billions of dollars did microsoft net? I can tell you it should be enough to make the software or OS right. And to give the other side to that it is the responsibility of the hardware manufacturer to get the right versions of the drivers so that your stuff will work. So it goes both ways. I can almost bet that realtek knows the problem exsits because its all over their forums so I would expect to see some newer drivers that should fix the problem in the near future.

As for the realtek not working on this machine I still havent fixed it. Odly I have another PC with realtek drivers and yes it does seem to work fine except for some features. Another thing, there are like17 different versions of the realtek drivers that actually make the audio work and will install in windows but on this one machine it seems that none of them will make the 5.1 7.1 speakers all work correctly like the rest of the people.
My System SpecsSystem Spec
27 Jan 2010   #183
hdmi

8.1 x64
 
 

Quote   Quote: Originally Posted by mutha88 View Post
hdmi, why should I use optional "upmix-crap" in the Realtek drivers, like "Speaker Fill"
You should use optional "upmix-crap" in the Realtek drivers, like "Speaker Fill" EACH TIME YOU LISTEN STEREO MUSIC and NOT WHEN YOU LISTEN TO 5.1 TRACKS.
My System SpecsSystem Spec
.

27 Jan 2010   #184
The Stodd

Windows 7
 
 

Quote   Quote: Originally Posted by hdmi View Post
Quote   Quote: Originally Posted by mutha88 View Post
hdmi, why should I use optional "upmix-crap" in the Realtek drivers, like "Speaker Fill"
You should use optional "upmix-crap" in the Realtek drivers, like "Speaker Fill" EACH TIME YOU LISTEN STEREO MUSIC and NOT WHEN YOU LISTEN TO 5.1 TRACKS.
SO how are we supposed to utilise 5.1 for surround sound then? Or are you not understanding the point of this thread???
My System SpecsSystem Spec
27 Jan 2010   #185
hdmi

8.1 x64
 
 

By doubleclicking on these:


Attached Images
Windows 7 5.1 surround problems (realtek)-surround.png 
My System SpecsSystem Spec
27 Jan 2010   #186
mutha88

Windows 7 x64
 
 

hdmi, excuse me, I don't think, you are helping.

My point was, that in Winamp, WMP or a DVD with LPCM/stereo stream... Under Windows XP SP3... I DON'T HAVE to TURN ON the SPEAKER FILL option, to have a 5.1 surround! (excuse me for the caps lock)

Besides, the Speaker Fill options doesn't sound NICE while upmixing stereo source. Have you tried it? And if you have tried it, what do you think? That it is better? Don't think so on my almost brand new Logitech G51 5.1 system...

Besides, the volume levels, while Speaker Fill is turned on are very random/scrambled... This drives me mad too. Speaker Fill isn't a diamond. Just a shaped rock.
My System SpecsSystem Spec
27 Jan 2010   #187
jimbo45

Linux CENTOS 7 / various Windows OS'es and servers
 
 

Quote   Quote: Originally Posted by johngalt View Post
Are any / all / some of you using hte W7 drivers or the Realtek 2.14 HD drivers?
Hi there

This is STILL one thing I use an XP virtual machine for - even the Virtual Audio driver has a decent CUSTOM settable equalisation. The W7 drivers just have "Fixed Presets" -- absolute rubbish.

I'm actually moving most of my Multimedia off W7 anyway and running it on a dedicated server. I'm using a W2K3 server (XP drivers work fine) and may change to a "Vortex" type multimedia or W2008 Server or even Linux.

The only multimedia I use on a computer now is watching a DVD (also soon to be replaced by my Multimedia streaming system) or watching TV.

Cheers
jimbo
My System SpecsSystem Spec
27 Jan 2010   #188
RST101

Windows 7 Ultimate x64.
 
 

Jimbo here you go. Click on the button next to where it says reset and a graphic eq pops up so you can adjust to your own taste..


Attached Thumbnails
Windows 7 5.1 surround problems (realtek)-capture.png  
My System SpecsSystem Spec
28 Jan 2010   #189
The Stodd

Windows 7
 
 

Quote   Quote: Originally Posted by hdmi View Post
By doubleclicking on these:


Mine's sorted itself anyway! I installed GOM player and now have 5.1 - it's not as good as it was in XP, rear speakers are alot quieter, but it's there. However, if I update to the latest or even the same realtek drivers I lose 5.1 and go back to stereo. I've no idea what I did to make it work.

I'm also convinced this is a Windows 7 problem and not a driver problem.
My System SpecsSystem Spec
28 Jan 2010   #190
Kingz

Windows 7
 
 
Windows 7 Low volume in speaker.

Hi...
I have a sound problem with windows 7 (it's works fine with xp) I check the speakers with one of my friends system he also installed win 7 the same think happens low sounds.
Headphones are working fine. But the speakers sound is too low.
Is there any way to fix the problem.


Help plz..
Thanks in advance.
Kingz
My System SpecsSystem Spec
Reply

 Windows 7 5.1 surround problems (realtek)




Thread Tools




Similar help and support threads
Thread Forum
Realtek onboard sound card with 5.1 surround speaker fill problem
I recently installed a new motherboard Asus Sabertooth 990FX. It has an on-board sound card "Realtek® ALC 892 8-Channel High Definition Audio CODEC". I'm using 5.1 surround speakers from creative. Speaker fill with windows update driver, or Realteks driver from Asus' website, has the same outcome. ...
Sound & Audio
Realtek HD Audio RCA Recieve No surround
Hey all, I got a new (old/used) RCA Receiver (RV-9953A) and 5 monitors and a subwoofer. When I put in a cd or run the test tone on the receiver all of the speakers and subwoofer check out--no problems. When I run a test on the Realtek HD Audio Manager however, it doesn't want to play from...
Sound & Audio
5.1 Surround Problems with Realtek HD Audio Manager
Hi everyone! First post on the forums =P What the title says. Basically I have had to remove my soundcard (a Creative X-Fi Soundblaster) as it was completely blocking off the fan on my new graphics card (ATI Radeon HD 5850 - and yes there is no space left on my motherboard!). As a result I have...
Sound & Audio
Surround Sound + Realtek
OK So! Ive tried EVERYTHING even bought a new set of speakers thought the others were broken. I am running windows 7 ultimate and i have tried every realtek driver known to man. And I still can't get my surround sound to work I haven't re-assigned the jacks cause i am not to sure how to do that...
Sound & Audio
Surround Sound Problems Windows 7 64bit
Hi this is my first post so if I have'nt done something correct sorry in advance. But my problem is that I cannot get my surround sound to work on windows 7:cry:, it worked fine when i had XP. It has the option but just will not play it. I have a Abit AB9 pro motherboard, Quad Core 6600, 8GB...
Sound & Audio
Surround Problems
I just re-installed win 7 RTM and I can't get my sound drivers to work right. I have a Creative Soundblaster Extreme Gamer and a set of 5.1 surround speakers. I installed the drivers for win 7 and the console launcher to set up my sub. I clicked on 5.1 surround and bass redirection, the same thing...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:15.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App