Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 5.1 surround problems (realtek)

11 Feb 2010   #201
lanurd

Windows 7 Professional
 
 

Did you install it as administrator? I just reinstalled it in my Windows 7 Ultimate x64 setup and I'm getting discreet DTS 5.1 there also.

I also had to start PowerDVD 9 as administrator.


My System SpecsSystem Spec
.
11 Feb 2010   #202
lanurd

Windows 7 Professional
 
 

Just tried it with it with H@ll Ride which is in Dolby True HD. Dialogue out of the center, music out of fronts and effects out the rear.

It is certainly working for me.

I'll try a few more Blu-rays and a couple of HD DVD's.
My System SpecsSystem Spec
11 Feb 2010   #203
lanurd

Windows 7 Professional
 
 

It also works with Serenity and Swordfish. Both HD DVD with Dobly Digital Plus using PowerDVD 7 on Windows 7 Professional x86.
My System SpecsSystem Spec
.

12 Feb 2010   #204
zloxxx

windows 7 (for now)
 
 

jjust to tell you that after a couple of days I again tried to set up sound,and again downloaded realtek drivers and installed them again for the fourth time but as administrator this time(maybe that helped).set settings to 5.1,set spiker fill,and bass management,restarted computer and now all of speakers working well.(don't know how but.....i like it ).hope will help someone
My System SpecsSystem Spec
12 Feb 2010   #205
hdmi

8.1 x64
 
 

Of course it works lol. Like I already posted before, try installing decent player software first...
My System SpecsSystem Spec
13 Feb 2010   #206
lanurd

Windows 7 Professional
 
 

Quote   Quote: Originally Posted by hdmi View Post
Of course it works lol. Like I already posted before, try installing decent player software first...
Okay, so you don't believe me.

I downloaded and installed Arcsoft Totalmedia Theater 3.0.1.161 and am now watching "Star Trek" in Dolby TrueHD.

I will admit I had to go to the Program Files, right click on uDTStart.exe and uDigital Theatre.exe and set their properties (compatibility tab) privlege level to "Run as administrator" before all 6 speakers fired up.

I think this proves the sounds issues in Windows 7 are directly related to the "Run as administrator" option.

Can someone else try setting the privlege levels to verify this?
My System SpecsSystem Spec
16 Feb 2010   #207
albuvladi

Windows 7
 
 
for zloxxx

Hey zloxxx, did you first uninstall the old realtek driers, or did you just installed the new ones over the old ones?
My System SpecsSystem Spec
16 Feb 2010   #208
hdmi

8.1 x64
 
 

Quote   Quote: Originally Posted by lanurd View Post
Quote   Quote: Originally Posted by hdmi View Post
Of course it works lol. Like I already posted before, try installing decent player software first...
Okay, so you don't believe me.

I downloaded and installed Arcsoft Totalmedia Theater 3.0.1.161 and am now watching "Star Trek" in Dolby TrueHD.

I will admit I had to go to the Program Files, right click on uDTStart.exe and uDigital Theatre.exe and set their properties (compatibility tab) privlege level to "Run as administrator" before all 6 speakers fired up.

I think this proves the sounds issues in Windows 7 are directly related to the "Run as administrator" option.

Can someone else try setting the privlege levels to verify this?
Try using 'Media Player Classic - Home Cinema' without choosing Run as administrator. It works on my Medion Akoya P6612 laptop with Realtek HD and on my old Asus P5LD2 with Realtek HD, it works.
My System SpecsSystem Spec
18 Feb 2010   #209
jahtog

7 ultimate x64
 
 
solution

there is a button
go to advanced devicesettings

click it

select bottom option
with the individual assigements of inputs or something

listen ur sjit should be how u want it

chill
My System SpecsSystem Spec
19 Feb 2010   #210
jaekfre

 
 
Subwoofer crossover

Somewhat off topic, but does anyone know if the alc888 has the option to adjust the crossover frequency for the subwoofer output? I can't find it anywhere and I've spent about 4 hours with no progress googling it.

I didn't even have the adjustable equalizer when I first got the new computer with windows 7. I installed the latest drivers and now have the adjustable equalizer but not the sub crossover. If the crossover is not adjustable, does anyone know what frequency the crossover is fixed at?

Thanks
My System SpecsSystem Spec
Reply

 Windows 7 5.1 surround problems (realtek)




Thread Tools




Similar help and support threads
Thread Forum
Realtek onboard sound card with 5.1 surround speaker fill problem
I recently installed a new motherboard Asus Sabertooth 990FX. It has an on-board sound card "Realtek® ALC 892 8-Channel High Definition Audio CODEC". I'm using 5.1 surround speakers from creative. Speaker fill with windows update driver, or Realteks driver from Asus' website, has the same outcome. ...
Sound & Audio
Realtek HD Audio RCA Recieve No surround
Hey all, I got a new (old/used) RCA Receiver (RV-9953A) and 5 monitors and a subwoofer. When I put in a cd or run the test tone on the receiver all of the speakers and subwoofer check out--no problems. When I run a test on the Realtek HD Audio Manager however, it doesn't want to play from...
Sound & Audio
5.1 Surround Problems with Realtek HD Audio Manager
Hi everyone! First post on the forums =P What the title says. Basically I have had to remove my soundcard (a Creative X-Fi Soundblaster) as it was completely blocking off the fan on my new graphics card (ATI Radeon HD 5850 - and yes there is no space left on my motherboard!). As a result I have...
Sound & Audio
Surround Sound + Realtek
OK So! Ive tried EVERYTHING even bought a new set of speakers thought the others were broken. I am running windows 7 ultimate and i have tried every realtek driver known to man. And I still can't get my surround sound to work I haven't re-assigned the jacks cause i am not to sure how to do that...
Sound & Audio
Surround Sound Problems Windows 7 64bit
Hi this is my first post so if I have'nt done something correct sorry in advance. But my problem is that I cannot get my surround sound to work on windows 7:cry:, it worked fine when i had XP. It has the option but just will not play it. I have a Abit AB9 pro motherboard, Quad Core 6600, 8GB...
Sound & Audio
Surround Problems
I just re-installed win 7 RTM and I can't get my sound drivers to work right. I have a Creative Soundblaster Extreme Gamer and a set of 5.1 surround speakers. I installed the drivers for win 7 and the console launcher to set up my sub. I clicked on 5.1 surround and bass redirection, the same thing...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:15.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App