Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 5.1 surround problems (realtek)

20 Feb 2010   #211
Melee54

Windows 7
 
 

Just did a brand new install of windows. Accidentally caught some malware that Malwarebtes, SuperAntiSpyware, Spybot, Avast, or MSE couldn't remove. Figured what the heck and reinstalled...

Still no "5.1"... Maybe what I'm thinking of wasn't even 5.1, but before I installed Windows 7 x64 on this build, I ran a 32bit XP just to test my card and speakers. The sound was amazing. I don't care if it was true 5.1 or not, but on XP everything I played came out of each speaker and it didn't sound like junk speaker-fill.

Installed 7, got the gigabyte azalia drivers, installed as admin, set up surround sound so that it passes the test, but videos and music still aren't 5.1 unless crappy speaker-fill is on.

I haven't tested any of my 5.1 DVDs yet, but I don't really care if they work or not. I just want music coming out of my speakers like it did in XP...


My System SpecsSystem Spec
.
20 Feb 2010   #212
Fantail

7 x64 | 7 x64
 
 

I've installed the latest drivers and am using a Logitech 5.1 sound system. The plug for the rear speakers goes into the jack for the side speakers on the motherboard in order for it to work. Utility - system test identifies each speaker correctly as a 5.1 system. Movie tracks seem to play correctly. If I use the designated rear speaker jack on the motherboard, does not work unless I select 7.1 in the utility and disable two speakers. But then tracks do not play correctly.
Now that it's working correctly it sounds good and I dig it! I get the feeling that these 5.1 sound systems for today's computers are not created equal. I mean by how they seem to designate speakers. And I'm wondering for those having trouble, if they could plug two sets of speakers plus a subwoofer directly into the motherboard jacks if they would still have trouble?
My System SpecsSystem Spec
22 Feb 2010   #213
zloxxx

windows 7 (for now)
 
 

for melee54,you must turn on speaker fill,because only like that you can hear all five speakers.maybe on xp you had instaled some other filter like ac3 or something,and that was creating more realistic 5.1.but only you could know that.sorry for my bad english
My System SpecsSystem Spec
.

22 Feb 2010   #214
Rivahratt

Windows 7 Home Premium 32-bit
 
 

I have been having a similar issue with my Realtek card in Windows 7. Although I can hear a little static from all of the speakers when I turn the volume up really high, 5.1 channel audio does not play out of all the speakers. Very strange.
My System SpecsSystem Spec
22 Feb 2010   #215
Melee54

Windows 7
 
 

Quote   Quote: Originally Posted by zloxxx View Post
for melee54,you must turn on speaker fill,because only like that you can hear all five speakers.maybe on xp you had instaled some other filter like ac3 or something,and that was creating more realistic 5.1.but only you could know that.sorry for my bad english
Nope, I didn't have any weird filters or anything. In XP it just WORKED... And it sounded awesome.

I've been using dumb speakerfill since Windows 7.


Also, Faintail, I've tried your method of switching up the inputs, etc... Still doesn't do it for me.
My System SpecsSystem Spec
23 Feb 2010   #216
lanurd

Windows 7 Professional
 
 

Guys, turn off speaker fill and set the executables compatibility privlege level to "Run this program as an administrator". It's the only thing that works.
My System SpecsSystem Spec
24 Feb 2010   #217
holfire

Windows Seven 64 bits
 
 

Hello, I'm still with my 5.1 problem. My motherboard : MSI P45 Neo with realtek alc888

The lastest drivers are installed on my PC.

I've only 2.1 and I think I've tried all the solutions ! So, there's a solution who works to get real 5.1 or not ?


Thanks .
My System SpecsSystem Spec
06 Mar 2010   #218
20th Centry Hax

Windows XP Pro SP2, Windows 7
 
 

I really want this problem solved
Things like this really shit me to tears

And whats worse, the line in on my pc works fine through all speakers
I just want it to basically put (when im playing music) Front and left through all the speakers, so i dont have to change all the speakers to front and left when playing music

-cheers
My System SpecsSystem Spec
21 Mar 2010   #219
doob

windows 7
 
 

i finally solved my issue with this.
i'm using Ver: R2.31 which was from my motherboard site. i right click on speaker in tray and select playback devices. then select speakers and click properties. under enhancements select bass management and dts connect....ok. voila everything solved!
i hope this helps somebody as i wasted many hours on trying to get surround sound working properly...btw wmp works with this now and no need to use any other player.
My System SpecsSystem Spec
22 Mar 2010   #220
jahtog

7 ultimate x64
 
 

what do you mean with dts connect?
My System SpecsSystem Spec
Reply

 Windows 7 5.1 surround problems (realtek)




Thread Tools




Similar help and support threads
Thread Forum
Realtek onboard sound card with 5.1 surround speaker fill problem
I recently installed a new motherboard Asus Sabertooth 990FX. It has an on-board sound card "Realtek ALC 892 8-Channel High Definition Audio CODEC". I'm using 5.1 surround speakers from creative. Speaker fill with windows update driver, or Realteks driver from Asus' website, has the same outcome. ...
Sound & Audio
Realtek HD Audio RCA Recieve No surround
Hey all, I got a new (old/used) RCA Receiver (RV-9953A) and 5 monitors and a subwoofer. When I put in a cd or run the test tone on the receiver all of the speakers and subwoofer check out--no problems. When I run a test on the Realtek HD Audio Manager however, it doesn't want to play from...
Sound & Audio
5.1 Surround Problems with Realtek HD Audio Manager
Hi everyone! First post on the forums =P What the title says. Basically I have had to remove my soundcard (a Creative X-Fi Soundblaster) as it was completely blocking off the fan on my new graphics card (ATI Radeon HD 5850 - and yes there is no space left on my motherboard!). As a result I have...
Sound & Audio
Surround Sound + Realtek
OK So! Ive tried EVERYTHING even bought a new set of speakers thought the others were broken. I am running windows 7 ultimate and i have tried every realtek driver known to man. And I still can't get my surround sound to work I haven't re-assigned the jacks cause i am not to sure how to do that...
Sound & Audio
Surround Sound Problems Windows 7 64bit
Hi this is my first post so if I have'nt done something correct sorry in advance. But my problem is that I cannot get my surround sound to work on windows 7:cry:, it worked fine when i had XP. It has the option but just will not play it. I have a Abit AB9 pro motherboard, Quad Core 6600, 8GB...
Sound & Audio
Surround Problems
I just re-installed win 7 RTM and I can't get my sound drivers to work right. I have a Creative Soundblaster Extreme Gamer and a set of 5.1 surround speakers. I installed the drivers for win 7 and the console launcher to set up my sub. I clicked on 5.1 surround and bass redirection, the same thing...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:10.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App