Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 5.1 surround problems (realtek)

19 Aug 2010   #241
Billy

 

This is the software I downloaded from Realtek High Definition Audio Codecs, although it seems it may have something to do with my motherboard as well. I just noticed the big in the window. I'll update my realtek drivers tonight and see if anything changes.

Update: Just updated to R2.51 drivers instead of R2.49 and it's the same.



My System SpecsSystem Spec
.
20 Aug 2010   #242
bigblocktowncar

Windows 7 Pro 64bit
 
 

Hmm...I have an evga X58 3xsli motherboard. Maybe I can try downloading a driver from their website. So even though you just updated to the newest driver via the Realtek website you still have the option to change the connectors?
My System SpecsSystem Spec
20 Aug 2010   #243
Billy

 

Yeah thats right and I still have the big logo
My System SpecsSystem Spec
.

20 Aug 2010   #244
bigblocktowncar

Windows 7 Pro 64bit
 
 

I might trying downloading it from another place...Maybe my motherboard does not allow for on the fly connector retasking?? I don't know if that is strictly a software issue or if it could also have something to do with the motherboard construction.

Either way, this should have been fixed either by Microsoft or by Realtek long ago. This thread has been open for a long time, and there is no solution other than workarounds which work for some people and do not work for others.
My System SpecsSystem Spec
26 Sep 2010   #245
mutha88

Windows 7 x64
 
 

I have the ALC1200 audio chipset. I think the last version I've tested was the R2.42. Under Windows Seven I didn't had any 5.1 sound with that version.

Does the R2.52 changed anything or not? Have anyone with ALC1200 tested it?
My System SpecsSystem Spec
29 Nov 2010   #246
GuyVdN

Windows 7 Ultimate x64
 
 

I got the 5.1 sound to work by using the ffdshow audio decoder. Only problem is that your audio player has to support this.

These steps work with GOM player and Media Player Classic Home Cinema.
Right Click Player -> Filters - ffdShow Audio Decoder - Properties
Now you have 2 options.
1. Check Dolby Decoder and check Apply Dolby Pro Logic II decoding to all stereo sources. (I am currently using this setting and it sounds great)
2. Check Mixer and check Expand stereo to surround. With this option you can modify the surround matrix to your needs.
My System SpecsSystem Spec
02 Dec 2010   #247
Koyfo

Windows 7 Ultimate SP1 x64
 
 

Hi guys, I'm new here. Nice vbulletin forum & very beautiful worked out!

To the stuff now, here is my solution to Windows Media Player 12. The same goes for other applications, you just have to install ffdshow (eg K-Lite Mega Codec Pack).

For any questions, check my specs @ my profile.



You need to be an system administrator! Follow the pictures...




Check my audio settings in the next 3 pics







Play an MP3 file with your WMP12. Open process explorer and search (CTRL-F) for the MP3DMOD.DLL that your WMP12 is using to play MP3 files


Now go find it, and take ownership of it




Select FULL ownership!


Now that you have ownership, rename it to MP3DMOD.DLL.BAK or keep it in a backup place, forcing WMP12 that way to use another decoder (ffdshow)







Remove wmplayer.exe from the list


Apply the Mixer filter and make these settings





Now enjoy real 2+2+1+1 sound
My System SpecsSystem Spec
02 Dec 2010   #248
Billy

 

Quote   Quote: Originally Posted by Koyfo View Post
Now enjoy real 2+2+1+1 sound
and this will only affect Media Player 12? I use the Zune program a lot to listen to music. I also play games(which work in 5.1)

Edit: Just followed your instructions, verified that it works with mp12. Do you know how to make the Zune program do this? I'll just learn to use Media Player 12 :-)

Update: One more thing, can this be done with .wma files?
My System SpecsSystem Spec
02 Dec 2010   #249
Koyfo

Windows 7 Ultimate SP1 x64
 
 

Well i don't know if Zune uses ffdshow. If it uses it, then you are ok! You can easily check if ffdshow is used to decode the file you are playing via taskbar!

My System SpecsSystem Spec
02 Dec 2010   #250
Billy

 

Quote   Quote: Originally Posted by Koyfo View Post
Well i don't know if Zune uses ffdshow. If it uses it, then you are ok! You can easily check if ffdshow is used to decode the file you are playing via taskbar!

Ah yeah I assumed as much. I don't see the WMA codec in it's list so I guess I'll just have to re-rip a few of my cds(like 5 of them are WMA instead of MP3 for some reason)
My System SpecsSystem Spec
Reply

 Windows 7 5.1 surround problems (realtek)




Thread Tools




Similar help and support threads
Thread Forum
Realtek onboard sound card with 5.1 surround speaker fill problem
I recently installed a new motherboard Asus Sabertooth 990FX. It has an on-board sound card "Realtek® ALC 892 8-Channel High Definition Audio CODEC". I'm using 5.1 surround speakers from creative. Speaker fill with windows update driver, or Realteks driver from Asus' website, has the same outcome. ...
Sound & Audio
Realtek HD Audio RCA Recieve No surround
Hey all, I got a new (old/used) RCA Receiver (RV-9953A) and 5 monitors and a subwoofer. When I put in a cd or run the test tone on the receiver all of the speakers and subwoofer check out--no problems. When I run a test on the Realtek HD Audio Manager however, it doesn't want to play from...
Sound & Audio
5.1 Surround Problems with Realtek HD Audio Manager
Hi everyone! First post on the forums =P What the title says. Basically I have had to remove my soundcard (a Creative X-Fi Soundblaster) as it was completely blocking off the fan on my new graphics card (ATI Radeon HD 5850 - and yes there is no space left on my motherboard!). As a result I have...
Sound & Audio
Surround Sound + Realtek
OK So! Ive tried EVERYTHING even bought a new set of speakers thought the others were broken. I am running windows 7 ultimate and i have tried every realtek driver known to man. And I still can't get my surround sound to work I haven't re-assigned the jacks cause i am not to sure how to do that...
Sound & Audio
Surround Sound Problems Windows 7 64bit
Hi this is my first post so if I have'nt done something correct sorry in advance. But my problem is that I cannot get my surround sound to work on windows 7:cry:, it worked fine when i had XP. It has the option but just will not play it. I have a Abit AB9 pro motherboard, Quad Core 6600, 8GB...
Sound & Audio
Surround Problems
I just re-installed win 7 RTM and I can't get my sound drivers to work right. I have a Creative Soundblaster Extreme Gamer and a set of 5.1 surround speakers. I installed the drivers for win 7 and the console launcher to set up my sub. I clicked on 5.1 surround and bass redirection, the same thing...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 13:19.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App