Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 5.1 surround problems (realtek)

08 Feb 2009   #31
racy

Windows 7 Beta
 
 

Quote   Quote: Originally Posted by wmaster View Post
Just to let you know, I have got this to work pretty well now.
I am a newebee. I just installed Windows 7 Ultimate 64 on an MCE system (see sig) that has been doing everying right for years (more than 4). I had to change out the Fusion HDTV express for a the pinnicle USB as fusion would not support the 64 bit version. I downloaded both Realtek WDM_R214 (hd drivers) and 6285_Vista_APO_PG536 (ac'97 drivers for 64 vista).

I only get two channel via RCA left, right (Two analog in on Dell 42 Plasma) and Optical out to a Sony DAVFX900Wreceiver. When running MCE 2005 evertying works great. I get the full on REaltek configuration tools (the one with the crazy bee sound) and can listen to DVD, HDTV, other via either the L/R RCA to the Plasma's speakers, or Optical (spid straight through) to the SOny.

I get only 2 channel from the optical in Windows 7 64 with above drivers. Also, here is the crazy useless config CPL that i get from ASUS (attached). when i try to conigure 6CH or 8CH only L/R work via the optical to the sony...

Also, why am i getting the old ASUS configuration CPL?

Sig did not kick in here is what I have:

Windows Ultimate 7 64 bit
ASUS A8N32-SLI Deluxe, 4 GIG
AMD Athlon 64 X2 Dual Core 3800+ 2.01 GHz
WD 500GIG SATA2 Cavier Green
2x Seagate 1TB SATA
1x WD ATA 320 GB
1x NEC ATA DVDRW Nd-3520AW
NVIDIA GeForce 7300 GT
Hauppauge WinTV PVR PCI II X2
Pinnacle PCTV 801e X1 (USB) - Fusion HDTV Express in but no on
Realtek Ac'97 Audio
Microsoft LifeCam VX-6000
Misc USB (Bluetooth, X-10 Power, X-10 Video, IR Repeater)




Attached Thumbnails
Windows 7 5.1 surround problems (realtek)-asus-config-manager.jpg  
My System SpecsSystem Spec
.
07 Mar 2009   #32
kerph32

Windows 7
 
 

here's what worked for me to get sound out of my rear speakers-



right-click on taskbar speakers > playback devices > properties > enhancements > enable Environment (ROOM) and Speaker fill

hope that helps someone!
My System SpecsSystem Spec
12 Mar 2009   #33
OziiX

Windows 7 Beta
 
 

I have the same problem with Creative XFI Xtreme Music, is there any solution with this guys? I have Win 7 Build 7048
My System SpecsSystem Spec
.

08 May 2009   #34
Dexterqo

Windows 7
 
 

Quote   Quote: Originally Posted by kerph32 View Post
here's what worked for me to get sound out of my rear speakers-



right-click on taskbar speakers > playback devices > properties > enhancements > enable Environment (ROOM) and Speaker fill

hope that helps someone!
You are God ! Thank you very much, my rear speaker working good right now ! Thanks
My System SpecsSystem Spec
09 May 2009   #35
Dexterqo

Windows 7
 
 

hmm, but the sound is very distorted.. In XP is sound very nice and clean. If I turn on Environment (ROOM) and Speaker Fil in win7 the sound is distorted
My System SpecsSystem Spec
09 May 2009   #36
12eason

Windows 7077
 
 

Jesus, I never use speaker fill to expand stereo, or even cmss on creative for that matter. I use ac3 filter to upmix stereo. I'd use ffdshows dolby prologic II upmixer if it didn't add slight distortion, but ffdshows version of stereo expansion is still preferable to realtek or creatives.

Speaker fill and cmss are just glorified stereo cloners, whereas ac3filter and ffdshow use prologic noise cancelation matrixes to create proper surround effects as well as dealing with discreet bass properly too.
My System SpecsSystem Spec
15 May 2009   #37
jmekerila

windows 7
 
 
who can help me ?

hi ! i have a 5.1 sound card realtek on my acer aspire 7720G laptop and i can not find the hd audio driver for this acer i have a week with many nights of searching on google to resolve that problem . Who can help me ?

who know´s where can i find a driver ?
My System SpecsSystem Spec
22 Jun 2009   #38
simonfilth

Windows 7
 
 

i have exactly the same problem and i think i know what the solution is but somehow i can't get it to work. i know that in order to fix the problem that my realtek driver will actually work in all applications in windows 7 is to unplug them and plug the cables again and then simply show the computer which one is which, but the problem on my side is that the window does not appear, like it did in windows xp. it only shows that a cable has been plugged in, but it doesn't ask which one is it, like it did in windows xp. any ideas? i tried almost everything already lol and i'm pretty sure that this is the solution but i just somehow can't get that pop-up window to show lol.

after reading the sticky topic with the re-assigning jack outputs, i did everything that was explained in the first post, but it never changed anything for some reason. can someone help please? i would really like to use my 5.1 on windows 7
My System SpecsSystem Spec
22 Jun 2009   #39
jmekerila

windows 7
 
 
read!

search on google this! Vista_Win7_R226 is the realtek driver for wind7
My System SpecsSystem Spec
22 Jun 2009   #40
simonfilth

Windows 7
 
 

I think everyone has the same problem and it's not about anyone's computer specs, but it's with realtek and the fact that you can't normally set up your 5.1 system on windows 7.

@jmekerila:
when i try to install the file you were talking about, i get this error:


My System SpecsSystem Spec
Reply

 Windows 7 5.1 surround problems (realtek)




Thread Tools




Similar help and support threads
Thread Forum
Realtek onboard sound card with 5.1 surround speaker fill problem
I recently installed a new motherboard Asus Sabertooth 990FX. It has an on-board sound card "Realtek® ALC 892 8-Channel High Definition Audio CODEC". I'm using 5.1 surround speakers from creative. Speaker fill with windows update driver, or Realteks driver from Asus' website, has the same outcome. ...
Sound & Audio
Realtek HD Audio RCA Recieve No surround
Hey all, I got a new (old/used) RCA Receiver (RV-9953A) and 5 monitors and a subwoofer. When I put in a cd or run the test tone on the receiver all of the speakers and subwoofer check out--no problems. When I run a test on the Realtek HD Audio Manager however, it doesn't want to play from...
Sound & Audio
5.1 Surround Problems with Realtek HD Audio Manager
Hi everyone! First post on the forums =P What the title says. Basically I have had to remove my soundcard (a Creative X-Fi Soundblaster) as it was completely blocking off the fan on my new graphics card (ATI Radeon HD 5850 - and yes there is no space left on my motherboard!). As a result I have...
Sound & Audio
Surround Sound + Realtek
OK So! Ive tried EVERYTHING even bought a new set of speakers thought the others were broken. I am running windows 7 ultimate and i have tried every realtek driver known to man. And I still can't get my surround sound to work I haven't re-assigned the jacks cause i am not to sure how to do that...
Sound & Audio
Surround Sound Problems Windows 7 64bit
Hi this is my first post so if I have'nt done something correct sorry in advance. But my problem is that I cannot get my surround sound to work on windows 7:cry:, it worked fine when i had XP. It has the option but just will not play it. I have a Abit AB9 pro motherboard, Quad Core 6600, 8GB...
Sound & Audio
Surround Problems
I just re-installed win 7 RTM and I can't get my sound drivers to work right. I have a Creative Soundblaster Extreme Gamer and a set of 5.1 surround speakers. I installed the drivers for win 7 and the console launcher to set up my sub. I clicked on 5.1 surround and bass redirection, the same thing...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:10.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App