Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Creative Sound Cards.

06 Sep 2010   #131
gudia

Windows 7
 
 
please help

I have creative sound blaster 128D i cant able to install it in windows 7 please help me.


My System SpecsSystem Spec
.
07 Sep 2010   #132
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

gudia, welcome to the forums.

If that card is what I think it is the chances of any driver for it is slim to none.

Would help to know exactly which card it is. Easiest would be to pull the card and locate the model number, should be along the top edge of the card and should look like either SBxxxx or CTxxxx.
My System SpecsSystem Spec
07 Sep 2010   #133
sygnus21

Windows 10 Pro
 
 

Quote   Quote: Originally Posted by stormy13 View Post
If that card is what I think it is the chances of any driver for it is slim to none.
Yeah, If it's what I think it is a well we're talking about a 12 year old card, and well, as stated above, drivers for that is slim to none but closer to none.

BTW does is look like this....

Creative Sound Cards.-creative-sb-pci-128.jpg

creative sound blaster 128D - Google Search


My System SpecsSystem Spec
.

08 Sep 2010   #134
gudia

Windows 7
 
 
yeah this is.

Yes this is my card i know its to old but i jst have it can you help me to install it?
My System SpecsSystem Spec
08 Sep 2010   #135
sygnus21

Windows 10 Pro
 
 

I'm sorry to say but there are no Windows 7 drivers for that card, thus I can't help you install it without them.

Sorry

However answering stormy's question....

Quote   Quote: Originally Posted by stormy13 View Post
Would help to know exactly which card it is. Easiest would be to pull the card and locate the model number, should be along the top edge of the card and should look like either SBxxxx or CTxxxx.
might provide a little hope, though I doubt it given the age of the card.

Good luck.
My System SpecsSystem Spec
08 Sep 2010   #136
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

About that best you can hope for for that old card is to try and install the last XP driver for it,

Creative Worldwide Support > Sound Blaster PCI 128

using compatibility mode,

Compatibility Mode

Is the rest of the computer of similar vintage, or is it newer? Depending on what you have you would probably be better of using the onboard sound.
My System SpecsSystem Spec
12 Sep 2010   #137
wally774

Windows 7 32 bit
 
 
X-fi audio extreme 'disappears' in Windows 7

I have the most up to date driver for the x-fi extreme and Windows 7 recognizes it when I reboot. But after some period of time (usually a few hours), it disappears from the device manager and can't be found. The only way I can recover it is to reboot again. Is there any way to keep it as recognized? has anyone else run into this problem? Thanks.
My System SpecsSystem Spec
16 Sep 2010   #138
gudia

Windows 7
 
 

thank you i will buy a new card
My System SpecsSystem Spec
20 Nov 2010   #139
GPWs2k

Windows 7 Ultimate x64
 
 

Alright, I've read every post here and I feel as if I am experiencing a problem slightly different than anyone else.

I have an on-board Creative sound card (Sound Blaster X-Fi Xtreme Audio on a MSI P6N Diamond motherboard) and have successfully installed the audio drivers to a point where I can hear audio. Where the problem is, though, is the microphone is being sensed backwards.

For example: My microphone jack in the rear of my computer currently has nothing plugged into it, yet the status says that something is plugged into it. If I were to plug a standard microphone into the jack, the computer switches the recognition to "Not plugged in" and will not receive signals from the microphone.

I have tried using the Creative Audio Control Panel to switch the FlexiJack settings between "Line in" and "Microphone" but nothing will change the fact that the computer is recognizing the inputs backwards.

Any advise will be greatly appreciated.
My System SpecsSystem Spec
23 Dec 2010   #140
donrocker

Win 7 Ultimate 32bit
 
 
stormy Plz help! SB Audigy 2 Software suite

hello everyone, i need a complete software suite for my creative SB audigy 2 win 7 32bit and 64bit supported...that is having EAX console and surround mixer n all others..plzz help me guide me...;-(
My System SpecsSystem Spec
Reply

 Creative Sound Cards.




Thread Tools




Similar help and support threads
Thread Forum
Low volume with new sound card(Creative Sound Blast 5.1 VX)
Hello! I got a new sound card today. Installed it, installed the drivers from the CD, plugged in the headphones and it works. But the sound levels are way to low. I raised the volume in all the places I could find, but it's still a bit low. Here's the card: Creative Sound Blaster 5.1 VX...
Sound & Audio
Creative SB cards not working on new pc setup
Hello, i have 3 creative audio cards SB X-Fi Xtreme Gamer/Audio and SB Audigy 2 zs. Resently i have changed motherboard Asus M5A78LUSB3 with fx 6xxx CPU to Asus P8P67 LE with i7 4xxx CPU, all other components remained (they are 2 DIMM G Skill RipjawsX F3-10666CL7-4GBXH, AMD Radeon HD 5800 Series)....
Sound & Audio
Pax Drivers for Creative Sound Cards
Tweaked drivers available which are alternatives to Creatives own drivers. Supports X-fi, Audigy and Forte cards, including Titanium HD and Fatality series. Can be found here - Get the latest X-fi Pax Drivers here Updated regularly. :D
Sound & Audio
Creative Sound Blaster Audigy 24bit Sound Card
I installed windows 7 a little while ago but i cant seem to get a driver that will recognize my sound card. the computer doesnt think its installed correctly but when i was using Xp it was just fine. ive tried another PCI slot but no such luck. all of the drivers i have tried tell me that they dont...
Drivers
Non Creative Labs Sound cards
I'm tired of trying to get Creative cards (like the X-Fi XtremeGamer) to work reliably with Windows 7 Ultimate x64 (on a new install, after manually installing the drivers because Creative's installer fails consistently. Now the update called for by Windows Update also fails because "Setup is...
Sound & Audio
Sound skips after some time (tried diff. sound cards)
Hello, I used to have Vista on this computer and didn't have audio problems. I've upgraded to Windows 7 and use the latest drivers available for my sound card (Striker 7.1). I have also tried not using these drivers and instead using a USB sound card (Sennheiser that comes with one of their...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:12.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App