Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Creative Sound Cards.

13 Nov 2009   #51
Arcalimon

Windows 7 Ultimate 64bit
 
 

I did reassignement now Itunes recognize my 5.1 but Dragon Age Origins :P

Not sure about Aion, also Media Player (I launched LOTR The Two Towers) is totally muted


My System SpecsSystem Spec
.
14 Nov 2009   #52
Mcyoung5

Windows 7 Ultimate 64-bit
 
 

Might wanna check updates for LOTR:TTT, the problem could be that the version you have doesn't support 5.1 or that there's just a bug and a newer patch will fix it. I hate that about video games, I'm still waiting for CombatArms to work with windows 7!
My System SpecsSystem Spec
14 Nov 2009   #53
Mcyoung5

Windows 7 Ultimate 64-bit
 
 

If that's not the case then I suggest maybe finding out how to contact the SB Support team and discussing the problem with them. They may be able to help you, but they might also want you to buy a new card. If they say to buy a new card don't! Just insist that it is their drivers AND NOT your card.
My System SpecsSystem Spec
.

15 Nov 2009   #54
Arcalimon

Windows 7 Ultimate 64bit
 
 

Now, sound seems to be sorted even if i haven't 5.1 from some apps anymore, and i just found out that my microphone does not works any suggestion on this?
My System SpecsSystem Spec
15 Nov 2009   #55
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

You have it set to mic and not "What U Hear"?
My System SpecsSystem Spec
15 Nov 2009   #56
Arcalimon

Windows 7 Ultimate 64bit
 
 

Yes i do, i also tried to launch the ''Setup a Microphone'' from ''accessibility'' in the control panel, and i get the following message:

''Your current default speech engine does not support this action at this time''


sidenote: in the playback devices i have only the Microphone as an available device, i also activated everything from the creative consoles.


edit1: anyway mate you made me have good sound back from my card i have only the fear that there's something wrong with it cause the lack of 5.1 sound and the mic not working are things that are worrying me
My System SpecsSystem Spec
16 Nov 2009   #57
Arcalimon

Windows 7 Ultimate 64bit
 
 

Stormy any news for me?
My System SpecsSystem Spec
16 Nov 2009   #58
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote:
in the playback devices i have only the Microphone as an available device
Unless you like hearing everything that comes out of the speakers, you need to have the mic muted under playback (line in as well), and only unmuted in the recording properties.

As much as I hate to say it I have a feeling about the only thing that may solve it is to do a clean 7 install and start from scratch. Reason for saying that is that with all the different drivers you have tried, there is pretty much no way to know whether everything has been uninstalled/removed (same can be said for just about any driver, not just Creative ones). The problem is that there are driver files all over the place (System32, SysWOW64, WinSXS, you name it), and there is just no way to get rid of or even really finding which one (especially if it is in the WinSXS folder) is causing the problem(s).

That's why I suggest doing a clean install of Windows, and starting over. Easier to do if you have a spare hard drive you can use (a partition will do as well, but then you end up with the dual boot options), then you can leave the current install alone. If you don't have a spare drive, make sure to backup what you want to save first (can even use Windows own backup utility and make a full backup is you have someplace with the space to hold it, and reload the image using the Windows disk if necessary).
My System SpecsSystem Spec
16 Nov 2009   #59
mushroomboy

Windows 7, Linux
 
 

Quote   Quote: Originally Posted by Arcalimon View Post
Stormy any news for me?
You are using the emu20k1 chipset, which means you should be able to use the official drivers for Windows 7 as that is the first in the X-Fi series and hasn't been discontinued. The Daniel K drivers are for Emu10k1 and Emu10k2, SBL and SBA. So what I would do is go and complain to Creative, visit their boards and throw a ruckus. Because a currently supported card should work, and it IS their fault. Really all you can do is test different configurations and settings for the drivers, or start going back in driver versions until you get something that works.

[edit] and do what the guy above said Try a clean install.
My System SpecsSystem Spec
16 Nov 2009   #60
Arcalimon

Windows 7 Ultimate 64bit
 
 

Any other way to erase everything without the third format??
My System SpecsSystem Spec
Reply

 Creative Sound Cards.




Thread Tools




Similar help and support threads
Thread Forum
Low volume with new sound card(Creative Sound Blast 5.1 VX)
Hello! I got a new sound card today. Installed it, installed the drivers from the CD, plugged in the headphones and it works. But the sound levels are way to low. I raised the volume in all the places I could find, but it's still a bit low. Here's the card: Creative Sound Blaster 5.1 VX...
Sound & Audio
Creative SB cards not working on new pc setup
Hello, i have 3 creative audio cards SB X-Fi Xtreme Gamer/Audio and SB Audigy 2 zs. Resently i have changed motherboard Asus M5A78LUSB3 with fx 6xxx CPU to Asus P8P67 LE with i7 4xxx CPU, all other components remained (they are 2 DIMM G Skill RipjawsX F3-10666CL7-4GBXH, AMD Radeon HD 5800 Series)....
Sound & Audio
Pax Drivers for Creative Sound Cards
Tweaked drivers available which are alternatives to Creatives own drivers. Supports X-fi, Audigy and Forte cards, including Titanium HD and Fatality series. Can be found here - Get the latest X-fi Pax Drivers here Updated regularly. :D
Sound & Audio
Creative Sound Blaster Audigy 24bit Sound Card
I installed windows 7 a little while ago but i cant seem to get a driver that will recognize my sound card. the computer doesnt think its installed correctly but when i was using Xp it was just fine. ive tried another PCI slot but no such luck. all of the drivers i have tried tell me that they dont...
Drivers
Non Creative Labs Sound cards
I'm tired of trying to get Creative cards (like the X-Fi XtremeGamer) to work reliably with Windows 7 Ultimate x64 (on a new install, after manually installing the drivers because Creative's installer fails consistently. Now the update called for by Windows Update also fails because "Setup is...
Sound & Audio
Sound skips after some time (tried diff. sound cards)
Hello, I used to have Vista on this computer and didn't have audio problems. I've upgraded to Windows 7 and use the latest drivers available for my sound card (Striker 7.1). I have also tried not using these drivers and instead using a USB sound card (Sennheiser that comes with one of their...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:12.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App