Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: X-Fi Titanium outputs 2.1 despite being set on 5.1

26 Aug 2009   #1
JollyGreen

Windows 7
 
 
X-Fi Titanium outputs 2.1 despite being set on 5.1

OK, This is an X-Fi Titanium Professional installed on Win7 x64 with the newest drivers available from the Creative site.

I can test the audio from within the Console Launcher or Diagnostics and all 5.1 speakers have good clear audio, when I play from Itunes/Windows Media Player/Internet I only get sound from the Front left and right speakers.

I have adjusted every setting in the Creative control panel and Console Launcher as well as whatever Windows settings I could find.

I am 99.9% sure cables are plugged in the right inputs.

Why can't I get 5.1 sound!?!


My System SpecsSystem Spec
.
26 Aug 2009   #2
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Because most (more like all, with the exception of DVD-Audio) music/mp3's/etc are all stereo sources. Only way to get 5.1/surround sound is to use something like CMSS3D (check the manual that came with your card) or DDL (Dolby Digital Live).
My System SpecsSystem Spec
26 Aug 2009   #3
JollyGreen

Windows 7
 
 

Card didn't come with a manual and I couldn't find a link to a pdf version.

Its even in 2.1 when playing Fallout 3, surely that would be 5.1 output right?
My System SpecsSystem Spec
.

26 Aug 2009   #4
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by JollyGreen View Post
Card didn't come with a manual and I couldn't find a link to a pdf version.
Check the cd that came with the card for the help files/manual.

Quote   Quote: Originally Posted by JollyGreen View Post
Its even in 2.1 when playing Fallout 3, surely that would be 5.1 output right?
You need to use Alchemy with that game,

Games - Fallout 3
My System SpecsSystem Spec
27 Aug 2009   #5
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by JollyGreen View Post
OK, This is an X-Fi Titanium Professional installed on Win7 x64 with the newest drivers available from the Creative site.

I can test the audio from within the Console Launcher or Diagnostics and all 5.1 speakers have good clear audio, when I play from Itunes/Windows Media Player/Internet I only get sound from the Front left and right speakers.

I have adjusted every setting in the Creative control panel and Console Launcher as well as whatever Windows settings I could find.

I am 99.9% sure cables are plugged in the right inputs.

Why can't I get 5.1 sound!?!
It might help to go into the win7 sound crontrol panel and set up your speakers from there. Also try this setting adjustment out. The one on the right is important.


Attached Thumbnails
X-Fi Titanium outputs 2.1 despite being set on 5.1-application-control-device.png  
My System SpecsSystem Spec
Reply

 X-Fi Titanium outputs 2.1 despite being set on 5.1




Thread Tools




Similar help and support threads
Thread Forum
X-FI Titanium and BSOD
Hi, I've installed my new X-FI Titanium (SB0880) and drivers from internet (directly from Creative and apply all updates), i have a new BSOD with "Page fault in non paged area", only in "Lord of the rings online". My computer work fine in work env. (music, audio chat, webcam, ...) Windows...
BSOD Help and Support
Creative X-Fi Fatal1ty Titanium - Should I?
Hey guys, Matt here. If anyone has been creeping about, I've been having issues with sound configuration in Windows 7. After a bit of digging, I've found a fix... Buy a new damn card. Just want all you forum goers opinions, Is this card all that it is cracked up to be? Links to...
Sound & Audio
X-fi Titanium Problems: EMI etc.
Hello all, I recently upgraded from an X-fi Xtreme Gamer to an X-fi Titanium PCI-E 1x card in preparation for an SLI config. However, I've recently noticed sound loss and drops about ten minutes of using my audio in games and browsing. There were times of electromagnetic interference whines but I...
Sound & Audio
SB Titanium will not work under Win7
I've posted elsewhere here about my Win7 upgrade. I run a Dell XPS 420. Upgraded to Win7 x64 Ultimate (no regrets overall - love it!). But my SoundBlaster X-Fi Extreme Audio would no longer record "What U Hear." Creative admitted that X-Fi Audio cards will not record What U Hear under Win7. They...
Sound & Audio
problem soundblaster xfi titanium
hello I have this problem with my xfi titanium audio card after i install the audio card and install the drivers for windows 7 i have a number of problems first of all the speakers in the control panel-sound-manage audio devices appear unplugged and only the spdif option appears active so i...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:44.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App